Subject: [Disman] ITU-T SG4 Liason

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Mon, 10 Feb 2003 14:20:30 +0100

Randy and DISMAN WG, 

Dave Sidor just reminded me that we (IETF DISMAN WG) 
have not yet responded to their Liason as per below.

Can you pls see to it that we do prepare a response?

the Liason statement is also posted at:
   http://www.ietf.org/IESG/LIAISON/ITU-DISMAN.txt

Thanks,
Bert 
------------------------------
Steve Coya wrote:
> 
> Dave,
> 
> The SG4-DISMAN text will be listed on the IETF's Liaison Statements Web
> Page <http://www.ietf.org/IESG/liaison.html> when it is regenerated
> tonight.
> 
> Steve

----------------------

"Sidor, Dave [NC1:6L30:EXCH]" wrote:
> 
> Bert, Randy, Randy,
> 
> In Bert's email below he raised an issue that SG 4 addressed at its
> meeting that concluded on Friday. The SG 4 input is presented below
> Bert's email and also attached as a Word document. I have also copied
> this email to the IETF email address for communication statements from
> other organizations.
> 
> Dave Sidor
> Chairman, ITU-T SG 4
> 
> -----------------
> 
> "Wijnen, Bert (Bert)" wrote:
> >
> > Is this just me that sort of wrries when I see
> >
> > > Some more duplication cases in ITU-IANA-ALARM-TC:
> > >
> >
> > To me it is either a set of ITU controled TCs, or a set
> > of IANA controled TCs. How is this going to work out
> > if both organisations need to stay in sync on this?
> >
> > Has anybody checked with ITU that they are happy to be
> > restricted to 255 code points? Can we get that in a
> > statement from them (possibly from SG 4?)?
> >
> > Do we have arranged for ITU to check and sign-off on the
> > values we currently have in this document?
> >
> > Maybe I am just worrying too much... I am pretty busy with
> > other stuff, so I have not followed all the emails/postings
> > all that closely.
> >
> > Bert
> 
> -------------------------------
> 
> ITU - Telecommunication Standardization Sector
> 
> Temporary Document 86 (Rev.1) (PLEN)
> 
> STUDY GROUP 4
> 
> Geneva, 8 - 19 April 2002
> 
> QUESTIONS:      19/4
> 
> SOURCE: ITU-T Study Group 4
> 
> TITLE:  Additional input regarding the use of  M.3100 probable causes for
> the ITU Alarm MIB
> _____________
> 
> COMMUNICATION STATEMENT
> 
> TO:     IETF disman WG
> 
> APPROVAL:       Agreed to at STUDY GROUP 4 MEETING
> 
> FOR:    ACTIOND
> 
> EADLINE:        January 1,  2003
> 
> CONTACT :
> Dave Matthews
> Acting Rapporteur, Question 19/4
> AT&T
> USA
> Tel :   +1 732 420 1613
> Email: [email-masked]
> 
> At the ITU-T Study Group 4 meeting in April 2002, we have examined
> version 6 of the IETF Alarm MIB focusing of course on those aspects
> related to the ITU-T SG 4 Recommendations and offer the following
> comments:
> 
> - We have examined version 6 of the Alarm MIB
> (draft-ietf-disman-alarm-mib-06) and noted your incorporation of the
> M.3100 probable causes semantics. We thank you for that action in
> response to our July 2001 communication statement.
> 
> - If you recall, in our July 2001 communication statement, we suggested
> the need for some extensibility mechanism and also we have been made
> aware that probable cause semantics other than that from the ITU-T are
> being reviewed, presumably for possible inclusion. We have discussed the
> possible impact of the latter and have come to the following
> conclusions:
> 
> 1) While we value the identical number assignments for the M.3100
> probable causes, regardless of the number assignments, we believe the
> ITU-T semantics are the most important aspect to retain.
> 
> 2) Though M.3100 is currently using less than 256 probable causes, there
> is a likelihood that additional values will be needed.  (The M.3100
> syntax of ASN.1 INTEGER is, of course, able to support larger values.)
> 
> 3) We have noted in section 5.2 that you have specified an
> IANAItuProbableCause textual convention apparently dedicated to the
> ITU-T probable causes and support that separation from any other
> probable cause asssignments. To ensure that separation, we recommend
> that the first paragraph of section 5.2 be replaced with the following
> text:
> 
> "Values of IANAItuProbableCause can only be given out if they correspond
> to ITU probable causes semantics present in ITU-T Recommendations and
> are agreed to by the disman working group."
> 
> We believe this text reflects the fact that this textual convention is
> limited to representing the ITU semantics while at the same time
> identifying the IETF as the owner of the alarm MIB. Other textual
> conventions would be presumably required to define the semantics and
> number assignments of other probable causes.
> 
> 4) To assist the reader of the current specification, we recommend the
> replacement of the DESCRIPTION text with the following text: " ITU
> probable cause values for alarms are currently assigned as per
> M.3100-1995 (1-254), X.733-1992 (256-287), and X.736-1992 (288-303)."
> 
> 5) We also note that code 158 (reinitialized) is missing.
> 
> We would be grateful if you would keep us informed of your progress on
> this topic.
> 
>   ------------------------------------------------------------------------
>                                                 Name: T01-SG04-020408-TD-PLEN-0086!R1!MSW-E.doc
>    T01-SG04-020408-TD-PLEN-0086!R1!MSW-E.doc    Type: WINWORD File (application/msword)
>                                             Encoding: base64

---

From: "Randy Presuhn" <[email-masked]>
Date: Mon, 10 Feb 2003 18:09:27 -0800

Hi -

We discussed this in the thread "FW: Probable Cause", available in
the archives at ftp://amethyst.bmc.com/pub/disman/archives/2002-04
I was not aware that a response was needed.

The consensus was that since were defining mappings for ITU and DMTF
codes to ones for this MIB, that there really wasn't an "ownership" issue,
addressing the concerns in points (1) and (2).  Point  (3) is addressed
in the IANA considerations section, though the WG specifically decided
that it did NOT want to become "immortal".  Point (4) is accomodated
by the description text, with the complete citations in the references
section.  Point (5) will need comment from the authors, since the value
158 is "applicationSubsystemFailure"

Randy

> From: "Wijnen, Bert (Bert)" <[email-masked]>
> To: "Randy Presuhn (E-mail)" <[email-masked]>; "Disman (E-mail)" <[email-masked]>
> Cc: "Dave Sidor (E-mail)" <[email-masked]>; "David Matthews" <[email-masked]>; "Randy Bush (E-mail)"
<[email-masked]>; "Scott Bradner (E-mail)" <[email-masked]>
> Sent: Monday, February 10, 2003 5:20 AM
> Subject: [Disman] ITU-T SG4 Liason
>

---

From: "Randy Presuhn" <[email-masked]>
Date: Mon, 10 Feb 2003 18:09:27 -0800

Hi -

Randy

---

From: "Randy Presuhn" <[email-masked]>
Date: Mon, 17 Feb 2003 17:15:18 -0800

Hi -

> From: "Randy Presuhn" <[email-masked]>
> To: "Wijnen, Bert (Bert)" <[email-masked]>; "Disman (E-mail)" <[email-masked]>
> Sent: Monday, February 10, 2003 6:09 PM
> Subject: Re: [Disman] ITU-T SG4 Liason
....
> 158 is "applicationSubsystemFailure"
...

So, what IS the resolution of this?

Randy

---

From: "Randy Presuhn" <[email-masked]>
Date: Mon, 17 Feb 2003 17:15:18 -0800

Hi -

....
...

Randy