Subject: RE: [Disman] "table wrapping" in alarm MIB -15-

From: "Sharon Chisholm" <[email-masked]>
Date: Tue, 11 Nov 2003 13:23:33 -0500

Hi

The following is the proposed resolution to Randy-75-4  Assuming no 
objection, this item will be considered closed conditional on the 
proposed edit being done.

In the definition of alarmActiveEntry replace
          "Entries appear in this table when alarms are raised.  They
          are removed when the alarm is cleared."

With
          "Entries appear in this table when alarms are raised.  They
          are removed when the alarm is cleared.

          If under extreme resource constraint the system is unable to 
          add any more entries into this table, then the 
          alarmActiveOverflow statistic will be increased by one."

Add new item

  alarmActiveOverflow  OBJECT-TYPE
      SYNTAX      Counter32
      MAX-ACCESS  read-only
      STATUS      current
      DESCRIPTION
         "The number of active alarms that have not been put into 
          the alarmActiveTable since system restart as a result 
          of extreme resource constraints."
      ::= { alarmActive 5 }

Sharon

-----Original Message-----
From: Randy Presuhn [mailto:[email-masked]] 
Sent: Tuesday, October 21, 2003 11:14 PM
To: Disman (E-mail)
Subject: Re: [Disman] "table wrapping" in alarm MIB -15-

Hi -

> From: "Sharon Chisholm" <[email-masked]>
> To: "Disman (E-mail)" <[email-masked]>
> Sent: Tuesday, October 21, 2003 7:30 PM
> Subject: RE: [Disman] "table wrapping" in alarm MIB -15-
...
> I think we are in danger of fundamentally changing the architecture of 
> this 'active alarm' list for the sake of a corner case. It's not like 
> we didn't think of this, but rather that we didn't want an 
> architecture that encouraged partial active alarm lists.
>
> What exactly is the wg chair looking for with this?
...

The chair wants the guy the AD asked to review the document to be happy.

He'd like text that says what happens when an alarm model entry matches a
notification delivered to the alarm inrastructure, and there is not
sufficient storage (or other resources) available to create a new alarm
entry.  Possibilities:

    - no alarm entry is created
    - some alarm entry is deleted or cleared to make room (algorithm needs
to be spelled out)
    - something records that this has happened

My personal opinion is that creating no entry, and recording that fact in a
counter is probably a reasonable solution, but am open to other
possibilities.  We went through the design issues in the log MIB.  I suspect
the tradeoffs are very similar here. This reviewer will be happy as long as
the MIB is explicit about what happens; I think this MIB's proponents will
figure out what the best thing would be to do when storage is exhausted.

I agree that it's desirable to not encourage partial active alarm lists, but
I also want *realistic* standards, i.e., no assumptions that storage is
infinite.

Randy (In all his roles.  :-)

---

From: "Sharon Chisholm" <[email-masked]>
Date: Tue, 11 Nov 2003 13:23:33 -0500

Hi

With

Add new item

Sharon

-----Original Message-----
From: Randy Presuhn [mailto:[email-masked]] 
Sent: Tuesday, October 21, 2003 11:14 PM
To: Disman (E-mail)
Subject: Re: [Disman] "table wrapping" in alarm MIB -15-

Hi -

...
...

---

From: Randy Presuhn <[email-masked]>
Date: Wed, 12 Nov 2003 09:17:29 -0600 (GMT-06:00)

Hi -

This looks ok to me.  I'd suggest putting a UNITS on the proposed counter.

Randy

-----Original Message-----
From: Sharon Chisholm <[email-masked]>
Sent: Nov 11, 2003 12:23 PM
To: "Disman (E-mail)" <[email-masked]>
Subject: RE: [Disman] "table wrapping" in alarm MIB -15-

Hi

With

Add new item

Sharon

-----Original Message-----
From: Randy Presuhn [mailto:[email-masked]] 
Sent: Tuesday, October 21, 2003 11:14 PM
To: Disman (E-mail)
Subject: Re: [Disman] "table wrapping" in alarm MIB -15-

Hi -

...
...

---

From: Randy Presuhn <[email-masked]>
Date: Wed, 12 Nov 2003 09:17:29 -0600 (GMT-06:00)

Hi -

Randy

-----Original Message-----
From: Sharon Chisholm <[email-masked]>
Sent: Nov 11, 2003 12:23 PM
To: "Disman (E-mail)" <[email-masked]>
Subject: RE: [Disman] "table wrapping" in alarm MIB -15-

Hi

With

Add new item

Sharon

-----Original Message-----
From: Randy Presuhn [mailto:[email-masked]] 
Sent: Tuesday, October 21, 2003 11:14 PM
To: Disman (E-mail)
Subject: Re: [Disman] "table wrapping" in alarm MIB -15-

Hi -

...
...

---

From: "Sharon Chisholm" <[email-masked]>
Date: Mon, 17 Nov 2003 09:08:15 -0500

Hi

With

Add new item

      UNITS       "active alarms"    

Sharon
-----Original Message-----
From: Randy Presuhn [mailto:[email-masked]] 
Sent: Wednesday, November 12, 2003 10:17 AM
To: [email-masked]
Subject: RE: [Disman] "table wrapping" in alarm MIB -15-

Hi -

Randy

-----Original Message-----
From: Sharon Chisholm <[email-masked]>
Sent: Nov 11, 2003 12:23 PM
To: "Disman (E-mail)" <[email-masked]>
Subject: RE: [Disman] "table wrapping" in alarm MIB -15-

Hi

With

Add new item

Sharon

-----Original Message-----
From: Randy Presuhn [mailto:[email-masked]] 
Sent: Tuesday, October 21, 2003 11:14 PM
To: Disman (E-mail)
Subject: Re: [Disman] "table wrapping" in alarm MIB -15-

Hi -

...
...

---

From: "Sharon Chisholm" <[email-masked]>
Date: Mon, 17 Nov 2003 09:08:15 -0500

Hi

With

Add new item

Sharon
-----Original Message-----
From: Randy Presuhn [mailto:[email-masked]] 
Sent: Wednesday, November 12, 2003 10:17 AM
To: [email-masked]
Subject: RE: [Disman] "table wrapping" in alarm MIB -15-

Hi -

Randy

-----Original Message-----
From: Sharon Chisholm <[email-masked]>
Sent: Nov 11, 2003 12:23 PM
To: "Disman (E-mail)" <[email-masked]>
Subject: RE: [Disman] "table wrapping" in alarm MIB -15-

Hi

With

Add new item

Sharon

-----Original Message-----
From: Randy Presuhn [mailto:[email-masked]] 
Sent: Tuesday, October 21, 2003 11:14 PM
To: Disman (E-mail)
Subject: Re: [Disman] "table wrapping" in alarm MIB -15-

Hi -

...
...