Subject: Re: [Disman] Log MIB Implementation Survey

From: Wes Hardaker <[email-masked]>
Date: Fri, 09 Jul 2004 14:43:36 -0700

>>>>> On Mon, 5 Apr 2004 12:29:02 -0700, "Randy Presuhn" <[email-masked]> said:

Randy> Here is the Implementation Survey for RFC 3014, the Log MIB.

Here is an extremely late...  oh you get the point: sorry.

Module: NOTIFICATION-LOG-MIB
Implementation Source:                 Net-SNMP
Management Application / Agent:        subagent in the management station

notificationLogConfigGroup (y/n): n
notificationLogStatsGroup (y/n): y
notificationLogLogGroup (y/n): y
notificationLogDateGroup (y/n): y

OBJECTs:
nlmConfigGlobalEntryLimit (rw/ro): rw
lower bound: 0
upper bound: by memory

nlmConfigLogEntryLimit (rw/ro): no
lower bound: ________
upper bound: ________

nlmConfigLogEntryStatus: (rw/ro): no

Randy> Deployment / Operational Experience:

I actually implemented this on our receiver side a while ago (to test
a new automatic-storage API mechanism actually, but thats besides the
point).  Thus, the log reports only things that were actually received
by the demon and are reported to the agent running on the management
station through a agentx connection between the notification receiver
and the agent.  We don't support anything but the default log group
and no configuration.  I don't know if anyone is actually using the
results of the days work I did in throwing it together.

That being said, it is highly likely that we'll be implementing it in
the agent in the near future since a fairly large number of clients
are suddenly going to need support for it on the agent side.

-- 
"In the bathtub of history the truth is harder to hold than the soap,
 and much more difficult to find."  -- Terry Pratchett

---

From: "Randy Presuhn" <[email-masked]>
Date: Mon, 12 Jul 2004 17:45:14 -0700

Hi -

> From: "Wes Hardaker" <[email-masked]>
> To: "Randy Presuhn" <[email-masked]>
> Cc: "Disman (E-mail)" <[email-masked]>
> Sent: Friday, July 09, 2004 2:43 PM
> Subject: Re: [Disman] Log MIB Implementation Survey
...
> Here is an extremely late...  oh you get the point: sorry.
...

Thanks!  Are there any others out there?

Randy

---

From: "David T. Perkins" <[email-masked]>
Date: Mon, 12 Jul 2004 21:46:58 -0700

HI,

The most important issue is how the results areto be  interpreted.
 From my experience at Riverstone and with talking with
Ram about the cisco implementation, my interpretation is
that the current log MIB is not a good solution for the
need that it addresses. It's sort of hard to get excited
about developing a replacement, given the low deployment
of SNMPv3, and the almost universal model of locating the
filtering and access control in element managers instead
of in managed devices.

>Thanks!  Are there any others out there?
Regards,
/david t. perkins

---

From: "Randy Presuhn" <[email-masked]>
Date: Tue, 13 Jul 2004 10:58:35 -0700

Hi -

> From: "David T. Perkins" <[email-masked]>
> To: "Randy Presuhn" <[email-masked]>; "Disman (E-mail)" <[email-masked]>
> Sent: Monday, July 12, 2004 9:46 PM
...
...

Several IETF meetings you and Ram said that you'd
write up the issues that concern you and possible
solutions. Any progress?  An off-list discussion
(especially one that I haven't seen) is of little help to
me as WG chair, or to the rest of the WG.

Randy