Subject: [DMM] Req#1

From: Alper Yegin <[email-masked]>
Date: Tue, 5 Nov 2013 18:24:48 +0200

Hello folks,

   REQ1:  Distributed processing

          IP mobility, network access and routing solutions provided by
          DMM MUST enable distributed processing for mobility management
          so that traffic does not need to traverse centrally deployed
          mobility anchors and thereby avoid non-optimal routes.

The real issue is not the "central location of the anchor", but "off-path location of the anchor".

The triangular route is caused by forcing the packets to traverse an anchor node that is not on the direct IP path between the MN and the CN.

See the CNet-Homing proposal. http://www.ietf.org/id/draft-yegin-dmm-cnet-homing-01.txt. We place the anchor in corresponding network, or the ISP serving that network. Therefore, the path going via that anchor does not cause triangulation. Some people may perceive that as locating the anchor in a central location (though this time it's not an "absolute/unchanging" center as implied in the current text).

Therefore I recommend the following revision:

   REQ1:  Distributed processing

          IP mobility, network access and routing solutions provided by
          DMM MUST enable distributed processing for mobility management
          so that traffic is not forced to traverse off-path
          mobility anchors and thereby avoid non-optimal routes.

Alper

---

From: h chan <[email-masked]>
Date: Tue, 5 Nov 2013 22:21:04 +0000

Is the following also acceptable:

          so that traffic can avoid traversing

          mobility anchors that are in non-optimal routes.

I am trying to write it in simple wording and not getting into a new term such as "off path"
H Anthony Chan

From: [email-masked] [mailto:[email-masked]] On Behalf Of Alper Yegin
Sent: Tuesday, November 05, 2013 8:25 AM
To: dmm
Subject: [DMM] Req#1

Hello folks,

Alper

---

From: Alper Yegin <[email-masked]>
Date: Wed, 6 Nov 2013 02:32:20 +0200

Works for me.

Alper

On Nov 6, 2013, at 12:21 AM, h chan wrote:

> I am trying to write it in simple wording and not getting into a new term such as “off path”
> H Anthony Chan
>

---

From: h chan <[email-masked]>
Date: Wed, 6 Nov 2013 02:01:31 +0000

Alper

I check the draft again. The draft does talk about distributed mobility management versus centralized mobility management. Dropping "centralized anchors" entirely in the requirement is going to produce a domino effect in other places.

Now I think an alternative is to say that only those centralized anchors that are not in non-optimal route are an issue.

          so that traffic can avoid traversing centrally deployed

          mobility anchors when such anchors are in non-optimal routes.

That means you have no problem of using centralized anchors as long as they are not in non-optimal routes. That should also accommodate your proposed solution. Are you okay with this compromised wording.

H Anthony Chan

From: Alper Yegin [mailto:[email-masked]]
Sent: Tuesday, November 05, 2013 4:32 PM
To: h chan
Cc: dmm
Subject: Re: [DMM] Req#1

Works for me.

Alper

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Alper Yegin
Sent: Tuesday, November 05, 2013 8:25 AM
To: dmm
Subject: [DMM] Req#1

Hello folks,

Alper

---

From: Alper Yegin <[email-masked]>
Date: Wed, 6 Nov 2013 04:18:58 +0200

Anthony,

The harmful type of "centralized" anchor is the one that is in single/fixed location typically far from the MN, which naturally causes sub-optimal route for most, if not all, end2end data-paths.
That's what we are trying to avoid with the DMM solutions.
Though, it'd take considerable effort to elaborate on that in the I-D at this 11th hour.
So, instead, let's go with your text. It's sufficient.

Alper

On Nov 6, 2013, at 4:01 AM, h chan wrote:

> Alper
>  
> I check the draft again. The draft does talk about distributed mobility management versus centralized mobility management. Dropping “centralized anchors” entirely in the requirement is going to produce a domino effect in other places.
>

---

From: h chan <[email-masked]>
Date: Wed, 6 Nov 2013 05:51:57 +0000

Thank you for your kind understanding to avoid extensive editing at the 11th hour. I may perhaps make another attempt at this 10th hour by trying to use some of your wording.

          so that traffic can avoid the non-optimal routes that are

          caused by traversing a centrally deployed mobility anchor

          in a single/fixed location.

H Anthony Chan

From: Alper Yegin [mailto:[email-masked]]
Sent: Tuesday, November 05, 2013 6:19 PM
To: h chan
Cc: dmm
Subject: Re: [DMM] Req#1

Anthony,

Alper

Alper

H Anthony Chan

Works for me.

Alper

Hello folks,

Alper

---

From: <[email-masked]>
Date: Wed, 6 Nov 2013 13:41:57 +0000

By definition an IP mobility anchor leads to non-optimal route. Actually, the idea behind req#1 is to avoid using mobility anchor far from the optimal route; and,  effectively, this anchor is usually far from both the MN and the CN
Alper, does the following rewording address your concern?

          so that traffic can avoid traversing single mobility anchor far from the optimal route.

De : [email-masked] [mailto:[email-masked]] De la part de h chan
Envoyé : mercredi 6 novembre 2013 06:52
À : Alper Yegin
Cc : dmm
Objet : Re: [DMM] Req#1

H Anthony Chan

Anthony,

Alper

Alper

H Anthony Chan

Works for me.

Alper

Hello folks,

Alper

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Alper Yegin <[email-masked]>
Date: Wed, 6 Nov 2013 16:03:04 +0200

Hello Pierrick, both your and Anthony's latest text address my concern.

Thanks.

Alper

---

From: h chan <[email-masked]>
Date: Thu, 7 Nov 2013 02:35:24 +0000

I will take Pierrick's text.

H Anthony Chan

From: Alper Yegin [mailto:[email-masked]]
Sent: Wednesday, November 06, 2013 6:03 AM
To: [email-masked]
Cc: h chan; dmm
Subject: Re: [DMM] Req#1

Thanks.

Alper

On Nov 6, 2013, at 3:41 PM, <[email-masked]<mailto:[email-masked]>> wrote:

De : [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] De la part de h chan
Envoyé : mercredi 6 novembre 2013 06:52
À : Alper Yegin
Cc : dmm
Objet : Re: [DMM] Req#1

H Anthony Chan

Anthony,

Alper

Alper

H Anthony Chan

Works for me.

Alper

Hello folks,

Alper

Thank you.