Subject: [DMM] APIs

From: Alper Yegin <[email-masked]>
Date: Wed, 3 Sep 2014 10:28:34 +0300

Folks,

There was discussion about necessity of APIs for DMM yesterday.
Let's continue that discussion here.

It is true that IETF's primary focus is "protocol design".
But when it's necessary, IETF also defines APIs.
See, IPv6 basic socket API, for example.
And, as a very relevant item, see RFC 5014, source address selection API.

In RFC 5014, there's even consideration to "mobility", in terms of apps selecting home address vs care-of address as their source address.

I think by now it's clear to everyone that we can no longer treat all IP flows equally when it comes to providing IP mobility treatment to them.
This is already recognized in the charter.

The way to take apps' mobility need into account is to give them an API. RFC 5014 already made an attempt at that, but fell short. Now that we have a better understanding of the issues, we should extend that API.

Once we define that API, other APIs (OS specific ones that are not under the control of IETF) can follow the same path.

Discussion welcome.

Alper

---

From: "Moses, Danny" <[email-masked]>
Date: Tue, 16 Sep 2014 09:07:00 +0000

I agree.

In the past, applications were quite indifferent to the platform they are executing on and were very limited in the controlling how their generated data is transmitted (or received). Today, applications need to be much more aware and 'behave' appropriately in various aspects like: Power management, cost saving (amount of bytes transfer over an expensive cellular connection) and even mobility aspects.

In order to control (and monitor) communication aspects, applications require APIs. I also believe (and hope) that we can address these needs through Socket enhancements.

	/Danny

>From: dmm [mailto:[email-masked]] On Behalf Of Alper Yegin
>Sent: Wednesday, September 03, 2014 10:29
>To: [email-masked]
>Subject: [DMM] APIs
>
>Folks,
>
>The way to take apps' mobility need into account is to give them an API. RFC 5014 already made an attempt at that, but fell short. Now that we have a better >understanding of the issues, we should extend that API.
>

_______________________________________________
dmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dmm
---------------------------------------------------------------------
A member of the Intel Corporation group of companies

This e-mail and any attachments may contain confidential material for
the sole use of the intended recipient(s). Any review or distribution
by others is strictly prohibited. If you are not the intended
recipient, please contact the sender and delete all copies.