Subject: [DMM] 3GPP CSIPTO

From: Alper Yegin <[email-masked]>
Date: Mon, 1 Sep 2014 10:50:50 +0300

Dear DMMers,

Here's an update on 3GPP SA1 CSIPTO work…

Two weeks ago there was an SA1 meeting (SA1#67), and in that meeting SA1 has completed the CSIPTO normative work.
As you might remember, SA1 is in charge of defining service requirements.

The next step for CSIPTO is to initiate a work item in SA2.

And here's a copy-paste of the normative requirements (accepted doc is S1-143607.zip):

Some types of services (e.g. streaming services, VOIP, VPN, HTTPS-Based Services) cannot tolerate a change of IP address of the UE without disruption of the service.

SIPTO can be performed with or without coordination between the UE and the network. The following requirements apply to coordinated SIPTO:

-     The 3GPP system shall be able to support multiple connections that are associated with the same defined IP network where each connection may or may not support IP address preservation.

-     The 3GPP system shall be able to determine if an IP flow requires IP address preservation or not. Based on this determination, the 3GPP network shall be able to offload selected IP traffic in coordinated manner between UE and the network, in order to minimize service disruption.

-      The 3GPP system shall be able to detect when a connection becomes suboptimal and decide when to establish a new optimal connection to the same defined IP network or use an existing connection.

Note 1: The definition of optimal and suboptimal can be based on a number of implementation criteria like geography, topology and load balancing etc.

-     The 3GPP system shall minimize the number of connections of a UE without disrupting the UE’s services, e.g. to ensure economical use of network resources.

-     The 3GPP system shall be able to ensure that the actual average aggregate bit rate for IP flows of packet data network connections associated with the same packet data network does not significantly exceed the subscribed aggregate maximum bit rate for this packet data network when two connections are used with the same defined IP network.

Note 2:  Requirements for Coordinated SIPTO do not apply to IMS.

---

From: Marco Liebsch <[email-masked]>
Date: Mon, 1 Sep 2014 13:25:16 +0000

Hi Alper,

thanks for posting the update. One clarifying question on the following service requirement:

'The 3GPP system shall minimize the number of connections of a UE without disrupting the
UE's services, e.g. to ensure economical use of network resources'

Can this be understood as the number of connections, which is to be minimized, is equal to the
number of mobility session and associated IP addresses?

Is this to minimize the states in the network, or is the intention to limit the control-plane
signaling with the mobile device to setup/teardown the connection?

Thanks for your feedback in advance,
marco

From: dmm [mailto:[email-masked]] On Behalf Of Alper Yegin
Sent: Montag, 1. September 2014 09:51
To: [email-masked]
Subject: [DMM] 3GPP CSIPTO

Dear DMMers,

Here's an update on 3GPP SA1 CSIPTO work...

And here's a copy-paste of the normative requirements (accepted doc is S1-143607.zip<http://www.3gpp.org/ftp/tsg_sa/WG1_Serv/TSGS1_67_SophiaAntipolis/docs/S1-143607.zip>):

-     The 3GPP system shall minimize the number of connections of a UE without disrupting the UE's services, e.g. to ensure economical use of network resources.

---

From: Alper Yegin <[email-masked]>
Date: Mon, 1 Sep 2014 17:39:32 +0300

Hi Marco,

> ‘The 3GPP system shall minimize the number of connections of a UE without disrupting the
> UE’s services, e.g. to ensure economical use of network resources’
>  

You can say that.

The idea is to make sure the simultaneous PDN connections do not keep adding up each time the UE encounters a new GW.

Alper

---

From: "Sri Gundavelli (sgundave)" <[email-masked]>
Date: Tue, 2 Sep 2014 15:32:51 +0000

Alper -

> The idea is to make sure the simultaneous PDN connections do not keep adding up each time the UE encounters a new GW.

Is that not truly a deployment consideration ? If the approach is gateway selection based on application/CN basis, can the network control this ?

Regards
Sri

From: Alper Yegin <[email-masked]<mailto:[email-masked]>>
Date: Monday, September 1, 2014 7:39 AM
To: Marco Liebsch <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [DMM] 3GPP CSIPTO

Hi Marco,

You can say that.

Alper

From: dmm [mailto:[email-masked]] On Behalf Of Alper Yegin
Sent: Montag, 1. September 2014 09:51
To: [email-masked]<mailto:[email-masked]>
Subject: [DMM] 3GPP CSIPTO

Dear DMMers,

---

From: Alper Yegin <[email-masked]>
Date: Wed, 3 Sep 2014 09:54:55 +0300

Sri,

On Sep 2, 2014, at 6:32 PM, Sri Gundavelli (sgundave) wrote:

> Is that not truly a deployment consideration ?

Supporting #N simultaneous PDN connections per UE has implications on the systems. 
So, it's not really only about deployment considerations.

> If the approach is gateway selection based on application/CN basis, can the network control this ?
> 

Not sure how to answer that. Probably this can be discussed in the context of a specific solution….

Alper

> 
> Regards
> Sri
> 
> 
> 
> 
> From: Alper Yegin <[email-masked]>
> To: Marco Liebsch <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>

---

From: Jouni Korhonen <[email-masked]>
Date: Wed, 03 Sep 2014 11:17:54 +0300

9/3/2014 9:54 AM, Alper Yegin kirjoitti:
>> > The idea is to make sure the simultaneous PDN connections do not
>> keep adding up each time the UE encounters a new GW.
>>

The 3GPP system is able to support up to 11 PDN Connections (or any 
bearers to be precise). This limit is on both UE and network side. What 
I cannot now remember on top of my head is whether the limitation is 
just per UE-PGW pair. Need to check that.

So, it also means the maximum number of prefixes per UE in 11.. unless 
prefix delegation is used (but in that case the prefixes are not for the 
UE but the LAN side nodes).

> context of a specific solution….

Network should be able to control this. If not, it will be added most 
probably.

- JOuni

>
> Alper
>
>
>
>>
>> Regards
>> Sri
>>
>>
>>
>>
>> From: Alper Yegin <[email-masked] <mailto:[email-masked]>>
>> Cc: "[email-masked] <mailto:[email-masked]>" <[email-masked]
>> <mailto:[email-masked]>>
>>> ‘/The 3GPP system shall minimize the number of connections of a UE
>>> without disrupting the
>>> UE’s services, e.g. to ensure economical use of network resources/’
>> The idea is to make sure the simultaneous PDN connections do not keep
>> adding up each time the UE encounters a new GW.
>>
>> Alper
>>
>>
>>
>>
>>
>>> *From:*dmm [mailto:[email-masked]]*On Behalf Of*Alper Yegin
>>> *Sent:*Montag, 1. September 2014 09:51
>>> *To:[email-masked] <mailto:[email-masked]>
>>> *Subject:*[DMM] 3GPP CSIPTO
>>> Dear DMMers,
>>> Two weeks ago there was an SA1 meeting (SA1#67), and in that meeting
>>> SA1 has completed the CSIPTO normative work.
>>> And here's a copy-paste of the normative requirements (accepted doc
>>> is S1-143607.zip
>>> <http://www.3gpp.org/ftp/tsg_sa/WG1_Serv/TSGS1_67_SophiaAntipolis/docs/S1-143607.zip>):
>>> Some types of services (e.g. streaming services, VOIP, VPN,
>>> HTTPS-Based Services) cannot tolerate a change of IP address of the
>>> UE without disruption of the service.
>>>
>>> SIPTO can be performed with or without coordination between the UE
>>> and the network. The following requirements apply to coordinated SIPTO:
>>>
>>> -The 3GPP system shall be able to support multiple connections that
>>> are associated with the same defined IP network where each connection
>>> may or may not support IP address preservation.
>>>
>>> -The 3GPP system shall be able to determine if an IP flow requires IP
>>> address preservation or not. Based on this determination, the 3GPP
>>> network shall be able to offload selected IP traffic in coordinated
>>> manner between UE and the network, in order to minimize service
>>> disruption.
>>>
>>> -The 3GPP system shall be able to detect when a connection becomes
>>> suboptimal and decide when to establish a new optimal connection to
>>> the same defined IP network or use an existing connection.
>>> Note 1:      The definition of optimal and suboptimal can be based on
>>> a number of implementation criteria like geography, topology and load
>>> balancing etc.
>>> -The 3GPP system shall minimize the number of connections of a UE
>>> without disrupting the UE’s services, e.g. to ensure economical use
>>> of network resources.
>>> -The 3GPP system shall be able to ensure that the actual average
>>> aggregate bit rate for IP flows of packet data network connections
>>> associated with the same packet data network does not significantly
>>> exceed the subscribed aggregate maximum bit rate for this packet data
>>> network when two connections are used with the same defined IP network.
>>>
> _______________________________________________
> dmm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dmm
>