Subject: [DMM] DMM FPC I-D - Implementation

From: "Bertz, Lyle T [CTO]" <[email-masked]>
Date: Fri, 26 Aug 2016 20:00:12 +0000

All,

Last week at the Intel Developer Forum in San Francisco (US), Intel and Sprint demonstrated a virtual Evolved Packet Core (vEPC) that included, amongst other features, a SGW and PGW (3GPP functions similar to MAG and LMA).   This software

1.       Used a Separated Control and Dataplane Node with an intermediate SDN Controller - Opendaylight's Beryllium release.

2.       Used IETF DMM FPC-v03 (https://datatracker.ietf.org/doc/draft-ietf-dmm-fpc-cpdp/?include_text=1) for communication of some sessions (others were simulated to ensure we met the demonstration timelines).

The Control and Dataplane software performs well (10Gbps down / 3Gbps up for 250K users) on a single Intel processor's *core* based upon the open source DPDK libraries from Intel.  The demonstration shows the promise of separation of Control and Data planes.

We had to deviate quite a bit from the version 03 specification to support 3GPP but version 04 adds the 3GPP model as an option.  Many of the general changes in version 04 are influenced by the implementation.

Work is already underway to implement version 04 with several internal changes, e.g. moving from the Opendaylight MD-SAL (model driven) approach to the application driven (AD-SAL) approach, as focus is now on performance.  I hope to share more details in the future.  As a part of the final version of the FPC I-D we will submit an Implementation Status section in the draft per RFC 7942.

Lyle Bertz
Sprint

________________________________

This e-mail may contain Sprint proprietary information intended for the sole use of the recipient(s). Any use by others is prohibited. If you are not the intended recipient, please contact the sender and delete all copies of the message.

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 29 Aug 2016 10:00:52 -0500

On Fri, Aug 26, 2016 at 3:00 PM, Bertz, Lyle T [CTO]
<[email-masked]> wrote:
> All,
>
>
>
> Last week at the Intel Developer Forum in San Francisco (US), Intel and
> Sprint demonstrated a virtual Evolved Packet Core (vEPC) that included,
> amongst other features, a SGW and PGW (3GPP functions similar to MAG and
> LMA).   This software
>
> 1.       Used a Separated Control and Dataplane Node with an intermediate
> SDN Controller – Opendaylight’s Beryllium release.
>
> 2.       Used IETF DMM FPC-v03
> (https://datatracker.ietf.org/doc/draft-ietf-dmm-fpc-cpdp/?include_text=1)
> for communication of some sessions (others were simulated to ensure we met
> the demonstration timelines).
>
>
>
> The Control and Dataplane software performs well (10Gbps down / 3Gbps up for
> 250K users) on a single Intel processor’s *core* based upon the open source
> DPDK libraries from Intel.  The demonstration shows the promise of
> separation of Control and Data planes.
>

I think that 3GPP already implemented control and data plane separation.

Regards,

Behcet
>
>
> We had to deviate quite a bit from the version 03 specification to support
> 3GPP but version 04 adds the 3GPP model as an option.  Many of the general
> changes in version 04 are influenced by the implementation.
>
>
>
> Work is already underway to implement version 04 with several internal
> changes, e.g. moving from the Opendaylight MD-SAL (model driven) approach to
> the application driven (AD-SAL) approach, as focus is now on performance.  I
> hope to share more details in the future.  As a part of the final version of
> the FPC I-D we will submit an Implementation Status section in the draft per
> RFC 7942.
>
>
>
> Lyle Bertz
>
> Sprint
>
>
> This e-mail may contain Sprint proprietary information intended for the sole
> use of the recipient(s). Any use by others is prohibited. If you are not the
> intended recipient, please contact the sender and delete all copies of the
> message.
>
> _______________________________________________
> dmm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dmm
>

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 29 Aug 2016 10:15:03 -0500

As I mentioned in my previous mail, 3GPP already supports control
plane data plane separation, they just call it user plane control
planes.

See:

https://en.wikipedia.org/wiki/System_Architecture_Evolution

I think you are confused by the SDN approaches in the control plane in 3GPP.

However, 3GPP decided not to pursue SDN. But they will pursue NFV instead.

FYI.

Regards,

Behcet

---

From: "Bertz, Lyle T [CTO]" <[email-masked]>
Date: Mon, 29 Aug 2016 15:49:31 +0000

You're correct.  The separation work mentioned below is SDN focused but multiple protocols between the Controller, acting as a FPC Agent, and DPN are used.

-----Original Message-----
From: Behcet Sarikaya [mailto:[email-masked]]
Sent: Monday, August 29, 2016 10:15 AM
To: Bertz, Lyle T [CTO] <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [DMM] DMM FPC I-D - Implementation

As I mentioned in my previous mail, 3GPP already supports control plane data plane separation, they just call it user plane control planes.

See:

FYI.

Regards,

Behcet

On Fri, Aug 26, 2016 at 3:00 PM, Bertz, Lyle T [CTO] <[email-masked]> wrote:
> All,
>
>
>
> Last week at the Intel Developer Forum in San Francisco (US), Intel
> and Sprint demonstrated a virtual Evolved Packet Core (vEPC) that
> included, amongst other features, a SGW and PGW (3GPP functions similar to MAG and
> LMA).   This software
>
> (https://datatracker.ietf.org/doc/draft-ietf-dmm-fpc-cpdp/?include_tex
> t=1) for communication of some sessions (others were simulated to
> ensure we met the demonstration timelines).
>
>
>
> The Control and Dataplane software performs well (10Gbps down / 3Gbps
> up for 250K users) on a single Intel processor’s *core* based upon the
> open source DPDK libraries from Intel.  The demonstration shows the
> promise of separation of Control and Data planes.
>
>
>
> We had to deviate quite a bit from the version 03 specification to
> support 3GPP but version 04 adds the 3GPP model as an option.  Many of
> the general changes in version 04 are influenced by the implementation.
>
>
>
> changes, e.g. moving from the Opendaylight MD-SAL (model driven)
> approach to the application driven (AD-SAL) approach, as focus is now
> on performance.  I hope to share more details in the future.  As a
> part of the final version of the FPC I-D we will submit an
> Implementation Status section in the draft per RFC 7942.
>
>
>
> Lyle Bertz
>
> Sprint
>
>
> This e-mail may contain Sprint proprietary information intended for
> the sole use of the recipient(s). Any use by others is prohibited. If
> you are not the intended recipient, please contact the sender and
> delete all copies of the message.
>