Subject: [DMM] I-D Action: draft-ietf-dmm-distributed-mobility-anchoring-08.txt

From: [email-masked]
Date: Fri, 02 Mar 2018 10:15:22 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Distributed Mobility Management WG of the IETF.

        Title           : Distributed Mobility Anchoring
        Authors         : H. Anthony Chan
                          Xinpeng Wei
                          Jong-Hyouk Lee
                          Seil Jeon
                          Carlos J. Bernardos
	Filename        : draft-ietf-dmm-distributed-mobility-anchoring-08.txt
	Pages           : 15
	Date            : 2018-03-02

Abstract:
   This document defines distributed mobility anchoring in terms of the
   different configurations and functions to provide IP mobility
   support.  A network may be configured with distributed mobility
   anchoring functions for both network-based or host-based mobility
   support according to the needs of mobility support.  In the
   distributed mobility anchoring environment, multiple anchors are
   available for mid-session switching of an IP prefix anchor.  To start
   a new flow or to handle a flow not requiring IP session continuity as
   a mobile node moves to a new network, the flow can be started or re-
   started using a new IP address configured from the new IP prefix
   which is anchored to the new network.  The mobility functions and
   their operations and parameters are general for different
   configurations.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dmm-distributed-mobility-anchoring/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-dmm-distributed-mobility-anchoring-08
https://datatracker.ietf.org/doc/html/draft-ietf-dmm-distributed-mobility-anchoring-08

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dmm-distributed-mobility-anchoring-08

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Sri Gundavelli (sgundave)" <[email-masked]>
Date: Fri, 2 Mar 2018 19:05:15 +0000

Hi Carlos/Anthony/Authors,

Thanks for the updates. Please summarize the changes that went into -08
version, and also let the WG know on the open issues.

Sri

On 3/2/18, 10:15 AM, "dmm on behalf of [email-masked]"
<[email-masked] on behalf of [email-masked]> wrote:

>_______________________________________________
>dmm mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/dmm

---

From: Carlos Jesús Bernardos Cano <[email-masked]>
Date: Tue, 06 Mar 2018 22:40:14 +0100

Hi Sri,

Apologies for the delayed reaction. We were busy with the last minute
I-D submission.

Regarding the changes that went into -08, this is my summary:

- Drastic shortening of the document, aiming at reducing its complexity
and length. We have shortened from ~45 pages to ~15 pages.

- Simplification of the terminology and associated drawings, to just
focus on data plane anchors (control plane is mentioned, but the
document is about anchoring, so it is about data plane).

- Removal of parts about hierarchical networks and NEMO.

- Minimization of all the part about anchor mobility, as there is no
solution that the WG has identified as viable. We limit the doc to
anchor switching and anchor selection.

- Keep the focus on the document being informational (it is not
normative, so no solution is specified).

Regarding open issues, I'd like to request some volunteers in the WG to
take a look (even a first quick one) to provide some feedback about
whether we are on the right track or not. It'd be really ideal if we
could have some discussion before the f2f in London, so we could try to
close/decide on open issues by the London meeting.

Thanks!

Carlos

On Fri, 2018-03-02 at 19:05 +0000, Sri Gundavelli (sgundave) wrote:
> > This draft is a work item of the Distributed Mobility Management WG
> > of
> > the IETF.
> > 
> > https://datatracker.ietf.org/doc/draft-ietf-dmm-distributed-mobilit
> > y-ancho
> > ring/
> > 
> > https://tools.ietf.org/html/draft-ietf-dmm-distributed-mobility-anc
> > horing-
> > 08
> > https://datatracker.ietf.org/doc/html/draft-ietf-dmm-distributed-mo
> > bility-
> > anchoring-08
> > 
> > https://www.ietf.org/rfcdiff?url2=draft-ietf-dmm-distributed-mobili
> > ty-anch
> > oring-08
> > 
> >

---

From: Marco Liebsch <[email-masked]>
Date: Wed, 7 Mar 2018 09:28:48 +0000

Hi Carlos, Anthony,

I had a brief look and see a big improvement, way better to read. Since I volunteered during last f2f to review (..),
I'll take the current version and we can follow your proposal to talk before the f2f.

marco

-----Original Message-----
From: dmm [mailto:[email-masked]] On Behalf Of Carlos Jesús Bernardos Cano
Sent: Dienstag, 6. März 2018 22:40
To: Sri Gundavelli (sgundave); [email-masked]
Subject: Re: [DMM] I-D Action: draft-ietf-dmm-distributed-mobility-anchoring-08.txt

Hi Sri,

Apologies for the delayed reaction. We were busy with the last minute I-D submission.

- Drastic shortening of the document, aiming at reducing its complexity and length. We have shortened from ~45 pages to ~15 pages.

- Simplification of the terminology and associated drawings, to just focus on data plane anchors (control plane is mentioned, but the document is about anchoring, so it is about data plane).

- Minimization of all the part about anchor mobility, as there is no solution that the WG has identified as viable. We limit the doc to anchor switching and anchor selection.

- Keep the focus on the document being informational (it is not normative, so no solution is specified).

Regarding open issues, I'd like to request some volunteers in the WG to take a look (even a first quick one) to provide some feedback about whether we are on the right track or not. It'd be really ideal if we could have some discussion before the f2f in London, so we could try to close/decide on open issues by the London meeting.

Thanks!

Carlos

On Fri, 2018-03-02 at 19:05 +0000, Sri Gundavelli (sgundave) wrote:
> > of the IETF.
> > Please note that it may take a couple of minutes from the time of 
> > submission until the htmlized version and diff are available at 
> > tools.ietf.org.
> >

---

From: Carlos Jesús Bernardos Cano <[email-masked]>
Date: Wed, 07 Mar 2018 10:35:14 +0100

Thanks a lot Marco!

Looking forward to getting your comments.

Carlos

On Wed, 2018-03-07 at 09:28 +0000, Marco Liebsch wrote:
> Hi Carlos, Anthony,
> 
> I had a brief look and see a big improvement, way better to read.
> Since I volunteered during last f2f to review (..),
> - Drastic shortening of the document, aiming at reducing its
> complexity and length. We have shortened from ~45 pages to ~15 pages.
> 
> Regarding open issues, I'd like to request some volunteers in the WG
> to take a look (even a first quick one) to provide some feedback
> about whether we are on the right track or not. It'd be really ideal
> if we could have some discussion before the f2f in London, so we
> could try to close/decide on open issues by the London meeting.
> 
> Thanks!
> 
> Carlos
> 
> > > A New Internet-Draft is available from the on-line Internet-
> > > Drafts 
> > > directories.
> > >   This document defines distributed mobility anchoring in terms
> > > of 
> > > the
> > >   available for mid-session switching of an IP prefix
> > > anchor.  To 
> > > start
> > >   a new flow or to handle a flow not requiring IP session
> > > continuity 
> > > as
> > >   a mobile node moves to a new network, the flow can be started
> > > or
> > > re-

---

From: "Sri Gundavelli (sgundave)" <[email-masked]>
Date: Wed, 7 Mar 2018 16:27:37 +0000

Hi Carlo,

Thank you.

>and length. We have shortened from ~45 pages to ~15 pages.

Incredible! 

This is exactly what I hoped for. I never understood why there was so much
of text and what it was saying. This helps in IESG reviews. Given that its
a significant re-write, we unfortunately require some good amount of new
reviews. But, this is progress.

Sri

On 3/6/18, 1:40 PM, "Carlos Jesús Bernardos Cano" <[email-masked]> wrote:

>> > continuity as
>> > submission