Subject: [DMM] New Liaison Statement, "LS on indicating service continuity usage of the additional IPv6 prefix in Router Advertisement"

From: Liaison Statement Management Tool <[email-masked]>
Date: Thu, 22 Mar 2018 10:49:55 -0700

Title: LS on indicating service continuity usage of the additional IPv6 prefix in Router Advertisement
Submission Date: 2018-03-22
URL of the IETF Web page: https://datatracker.ietf.org/liaison/1567/

From: Suresh Krishnan <[email-masked]>
To: Sri Gundavelli <[email-masked]>,Dapeng Liu <[email-masked]>,Terry Manderson <[email-masked]>,Suresh Krishnan <[email-masked]>,Robert Hinden <[email-masked]>,Ole Troan <[email-masked]>
Cc: Dapeng Liu <[email-masked]>,Terry Manderson <[email-masked]>,IPv6 Maintenance Discussion List <[email-masked]>,Ole Troan <[email-masked]>,Sri Gundavelli <[email-masked]>,The IETF Chair <[email-masked]>,Robert Hinden <[email-masked]>,Distributed Mobility Management Discussion List <[email-masked]>,Suresh Krishnan <[email-masked]>
Response Contacts: [email-masked]
Technical Contacts: 
Purpose: For information

Body: 1	Overall description

SA2 would like to thank the IETF DMM working group chairs for their LS reply on indicating the mobility property of the additional IPv6 prefix in Router Advertisement in S2-181481.

Regarding the following components in the IETF’s reply LS:
     1.) The approach of coloring IPv4 and IPv6 addresses/prefixes with mobility properties.
     3.) The approach of indicating the coloring meta-data to the applications on the mobile node (UE in 3GPP terminology).

SA2 has noted that both aspects are covered in the IETF DMM draft draft-ietf-dmm-ondemand-mobility-13 and has also noted that it will be released soon as informational standard.

Regarding the following component in the IETF’s reply LS:
    2.) The approach of network including property meta-data in address assignment procedures

SA2 would like to point out that among the four mechanisms for address configuration delivery mentioned in your LS reply (i.e. DHCPv4, DHCPv6, IPv6 ND and IKEv2) only the IPv6 ND mechanisms, and in particular the Router Advertisement message, seem to be applicable in the 5G System architecture in the specific context of Multi-homed IPv6 PDU Sessions.

With respect to the following question in the IETF’s reply LS:
                We also like to point out that, all though the LS statement explicitly refers to both IPv4 and IPv6 address types, however it only mentions about (RA) (IPv6       
                ND implied) as the mechanism for address property delivery. It is to be noted that the approach of delivering coloring meta-data in RA messages will most  
                likely be to limited to IPv6 address/prefix types and will not be extended to IPv4 addresses. If this capability is required for IPv4, we may have to possibly         
                extend DHCP protocol(s).

                We request 3GPP to clarify if the Ask is explicitly for IPv6, or if its for both IPv4 and IPv6 address/prefix types.

SA2 would like to clarify that the request is explicitly for IPv6. SA2 discussed the example documents that were referenced in your LS reply and concluded that the following draft seems to be the most promising candidate for the problem under discussion in this correspondence: https://www.ietf.org/id/draft-feng-dmm-ra-prefixtype-01.txt.
SA2 would like to kindly ask IETF DMM working group to keep SA2 updated of the work on the subject of including property meta-data in IPv6 ND address assignment procedures for potential use in the 5G System to indicate the mobility property of additional IPv6 prefixes assigned as part of the Multi-homed IPv6 PDU Session functionality.

2	Actions
To IETF DMM working group:
    ACTION: SA2 would like to kindly ask IETF DMM working group to keep SA2 updated of the work on the subject of including property meta-data in IPv6 ND address assignment procedures for potential use in the 5G System to indicate the mobility property of additional IPv6 prefixes assigned as part of the Multi-homed IPv6 PDU Session functionality.

3	Dates of next TSG SA WG2 meetings
TSG SA WG2 Meeting 127	16 - 20 Apr 2018	Sanya, CN
TSG SA WG2 Meeting 127-Bis	28 May – 1 Jun 2018	Newport Beach, US
Attachments:

    S2-182967_was2844_LS_IETF_SSC3
    https://www.ietf.org/lib/dt/documents/LIAISON/liaison-2018-03-22-3gpp-tsgsa-sa2-int-6man-dmm-ls-on-indicating-service-continuity-usage-of-the-additional-ipv6-prefix-in-router-advertisement-attachment-1.docx

---

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 23 Mar 2018 10:48:21 +0100

Le 22/03/2018 à 18:49, Liaison Statement Management Tool a écrit :
[...]

> SA2 would like to point out that among the four mechanisms for
> address configuration delivery mentioned in your LS reply (i.e.
> DHCPv4, DHCPv6, IPv6 ND and IKEv2) only the IPv6 ND mechanisms, and
> in particular the Router Advertisement message, seem to be applicable
> in the 5G System architecture in the specific context of Multi-homed
> IPv6 PDU Sessions.
Please tell SA2 that current 4G cellular networks are specified to, and
do use to some extent, DHCPv6 Prefix Delegation to assign a prefix to an
end node like an IoT Router.

A /56 prefix delivered to the end node should have the same capabilities
as an address. We also want that /56 prefix to be more stable, or less
stable, etc.

I dont understand why 5G System architecture excludes DHCPv6 from the 
list of applicable address configuration delivery.

I understand why 5G System architectures prefers ND - it is for addresses.

Alex

> _______________________________________________
> dmm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dmm
>

---

From: "Moses, Danny" <[email-masked]>
Date: Sat, 24 Mar 2018 15:45:23 +0000

Hi Alex,

As you know, I have written a draft that defines an extension to DHCPv6 for supporting OnDemand values (also for SSC modes - Service and Session Continuity) with prefix delegation. I discussed that with SA2 people and they are aware of that possibility. Currently, SA2 prefer the RA mobility extension and there was not enough support in the dmm WG for the DHCPv6 option. 

So, unfortunately I do not think we should advocate for an approach that is not supported by us (dmm).

Please also note that SSC modes is part of release 15. Please refer to TS 23.501 and TS 23.502 for more technical details. Stage 2 of release 15 has been finalized in December 2017 and Stage 3 is scheduled for the summer of 2018 (I do not remember the exact date).

Unfortunately, we (IETF) are often too late in providing specifications in time for 3GPP releases. This is partially due to our tendency to drag our work (in my opinion). Just see how long the OnDemand work is taking us. Here we have a chance to provide a specification that will be gladly adopted by the Cellular world. If not in release 15, at least in release 16.

Let's meet the challenge and prove to ourselves that we can be useful in this case.

By the way, my personal view is that we should provide the extensions to both RA and DHCPv6. I accept that due to the fact that SA2 prefers RA, we should give it a higher priority.

Regards,
Danny   

-----Original Message-----
From: dmm [mailto:[email-masked]] On Behalf Of Alexandre Petrescu
Sent: Friday, March 23, 2018 09:48
To: [email-masked]
Subject: Re: [DMM] New Liaison Statement, "LS on indicating service continuity usage of the additional IPv6 prefix in Router Advertisement"

> SA2 would like to point out that among the four mechanisms for address 
> configuration delivery mentioned in your LS reply (i.e.
> DHCPv4, DHCPv6, IPv6 ND and IKEv2) only the IPv6 ND mechanisms, and in 
> particular the Router Advertisement message, seem to be applicable in 
> the 5G System architecture in the specific context of Multi-homed
> IPv6 PDU Sessions.
Please tell SA2 that current 4G cellular networks are specified to, and do use to some extent, DHCPv6 Prefix Delegation to assign a prefix to an end node like an IoT Router.

A /56 prefix delivered to the end node should have the same capabilities as an address. We also want that /56 prefix to be more stable, or less stable, etc.

I dont understand why 5G System architecture excludes DHCPv6 from the list of applicable address configuration delivery.

Alex

> https://www.ietf.org/lib/dt/documents/LIAISON/liaison-2018-03-22-3gpp-
> tsgsa-sa2-int-6man-dmm-ls-on-indicating-service-continuity-usage-of-th
> e-additional-ipv6-prefix-in-router-advertisement-attachment-1.docx
> 

_______________________________________________
dmm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dmm
---------------------------------------------------------------------
A member of the Intel Corporation group of companies

This e-mail and any attachments may contain confidential material for
the sole use of the intended recipient(s). Any review or distribution
by others is strictly prohibited. If you are not the intended
recipient, please contact the sender and delete all copies.

---

From: "Sri Gundavelli (sgundave)" <[email-masked]>
Date: Mon, 26 Mar 2018 05:14:52 +0000

Alex:

This is a good point. Yes, there is DHCPv6 prefix delegation support in
3GPP architecture for supporting mobile router use-cases. This is
essentially for delegating prefixes for the networks attached to the UE.
This was introduced in Rel-10 by cisco. I have not followed the recent SA2
discussions and I do not know if MR support based on DHCPv6 will continue
to be supported or not, and if they have considered the alternative
options for supporting the same. I think we can certainly ask that
question, but I also wonder if the coloring is specific to the PDU
session, or if its broadly applicable for all UE address/prefix
assignments. 

Sri

On 3/23/18, 2:48 AM, "dmm on behalf of Alexandre Petrescu"
<[email-masked] on behalf of [email-masked]> wrote:

>> With respect to the following question in the IETF¹s reply LS:
>>                  We also like to point out that, all though the LS
>>statement explicitly refers to both IPv4 and IPv6 address types, however
>>it only mentions about (RA) (IPv6
>>                  ND implied) as the mechanism for address property
>>delivery. It is to be noted that the approach of delivering coloring
>>meta-data in RA messages will most
>>                  likely be to limited to IPv6 address/prefix types and
>>will not be extended to IPv4 addresses. If this capability is required
>>for IPv4, we may have to possibly
>>                  extend DHCP protocol(s).
>> 
>>                  We request 3GPP to clarify if the Ask is explicitly
>>for IPv6, or if its for both IPv4 and IPv6 address/prefix types.
>> 
>> 
>> SA2 would like to clarify that the request is explicitly for IPv6. SA2
>>discussed the example documents that were referenced in your LS reply
>>and concluded that the following draft seems to be the most promising
>>candidate for the problem under discussion in this correspondence:
>>https://www.ietf.org/id/draft-feng-dmm-ra-prefixtype-01.txt.
>> SA2 would like to kindly ask IETF DMM working group to keep SA2 updated
>>of the work on the subject of including property meta-data in IPv6 ND
>>address assignment procedures for potential use in the 5G System to
>>indicate the mobility property of additional IPv6 prefixes assigned as
>>part of the Multi-homed IPv6 PDU Session functionality.
>> 
>> 
>> 2	Actions
>>      ACTION: SA2 would like to kindly ask IETF DMM working group to
>>keep SA2 updated of the work on the subject of including property
>>meta-data in IPv6 ND address assignment procedures for potential use in
>>the 5G System to indicate the mobility property of additional IPv6
>>prefixes assigned as part of the Multi-homed IPv6 PDU Session
>>functionality.
>> 
>> 
>> TSG SA WG2 Meeting 127-Bis	28 May  1 Jun 2018	Newport Beach, US
>> Attachments:
>> 
>>https://www.ietf.org/lib/dt/documents/LIAISON/liaison-2018-03-22-3gpp-tsg
>>sa-sa2-int-6man-dmm-ls-on-indicating-service-continuity-usage-of-the-addi
>>tional-ipv6-prefix-in-router-advertisement-attachment-1.docx
>>