Subject: Re: [DNA] Issue about multiply connected to the same link andDNAbe ing per-interface or not (was Re: WG LC commentsondraft-ietf-dna-goals-01. txt)

From: Brijesh Kumar <[email-masked]>
Date: Thu, 30 Sep 2004 13:58:21 -0400

----- Original Message -----
From: JinHyeock Choi <[email-masked]>
Date: Thursday, September 30, 2004 11:59 am
Subject: Re: [DNA] Issue about multiply connected to the same link and DNAbe ing per-interface or not (was Re: WG LC comments ondraft-ietf-dna-goals-01. txt)

> > > It seems that we are in agreement that
> > >
> > > 1. DNA schemes are typically run per interface.
> > > 2. When a host has multiple interfaces, the DNA related
> > >    informations can be shared between interfaces for the
> > >    better performance. DNA on separate interfaces need
> > >    not be completely independent.
> > 
> > Agreed.
> 
> Glad to hear that. 

I would like to add something to this interesting conversation.

Actually, it is hard to determine when multiple interfaces can share DNA related information and when they can't without some external knowledge. If two interfaces share the same link layer, you would most likely need to share the DNA information since both device interfaces will try to connect to the same attachment point. However, it need not be the case in all cases since interfaces may be configured to whatever a user wants. For example, interface A may be configured to connect to Red Basestation and interface B can be configured to connect to only Blue Base stations. How will a system determine if interfaces should share DNA information or not?

If the interfaces have different link layers, then they will most likely connect to two different attachment points, which may or may not be on the same sub-network. Again, in thhis case also, it is hard to determine whether interfaces can share DNA information or not?.

I think that sharing information between interfaces is good goal, but the mechanisms to achieve don't seem quite straight forward. 

Cheers,

--brijesh

---

From: Erik Nordmark <[email-masked]>
Date: Thu, 30 Sep 2004 11:14:05 -0700

> Actually, it is hard to determine when multiple interfaces can share DNA related information and when they can't without some external knowledge. If two interfaces share the same link layer, you wo…

I can answer the question with an example solution. I picked the 
complete-prefix list (but I could have picked a linkid solution as well 
for this example).
If the prefix lists are maintained independently of the network 
interfaces, then the fact that a prefix is seen in a RA on the wlan0 
interface, where the prefix was recently heard (less than the prefix 
lifetime) on the eth3 interface, means that the host can assume that 
wlan0 is now connected to the same link as eth3 was connected to before.
Thus it can apply the prefix list and default routers it knew back on eth3.

Of course, there might be security easons to limit this. For instance, 
if the host knows that wlan0 is insecure somehow.

    Erik