Subject: Re: [DNA] Issue 2: What if no prefix is advertised?

From: Sathya Narayanan <[email-masked]>
Date: Thu, 18 Jan 2007 16:07:55 -0500

If we are going to mandate that the router advertise one prefix even
when stateful autoconfiguration is used and that it must be the smallest
prefix, we are implicitly requiring the adminstrator to configure each
of these routers with this information, right? Or, are we talking about
the routers sniffing DHCP messages - What does it mean?

I am leaving this open for now, until I hear comments on this question.

- Sathya

JinHyeock Choi wrote:

>> Issue: If stateful autoconfiguration is used, the routers may not
>> advertise any prefix in its RA message. DNA will not work without prefix
>> advertised. Current text relies on DHCP confirm message exchange for DNA
>> in that case.
>>
>> Agreement at the meeting: Lets mandate the inclusion of one prefix in
>> all RA message, with L= 0 and A=0. But, atleast one prefix is a MUST.
>> The router MUST include the smallest prefix either in PIO or LPO of all
>> RA messages.
>> Note: I am not refering to the smallest prefix as "LinkID" because in
>> "Issue 6", I will be proposing the removal of the concept of LinkIDs.
>> The forward compatibility advantage of the LinkIDs can be easily
>> supported and refer to the email on Issue 6 is further details.
>>
>> If you have any objections to the proposed change please post your
>> objections on the list.
>
>
> I agree and, IMO, the concept of 'LinkID' is of help. It would be
> simpler to mandate to include LinkID prefix.
>
> Best Regards
>
> JinHyeock

---

From: Greg Daley <[email-masked]>
Date: Fri, 19 Jan 2007 16:04:20 +1100

Hi Sathya,

We have an issue in that routers may already be available which do
not advertise a prefix (as it is not precluded).

I would suggest that these routers should try to advertise a prefix, 
be it a learned or native (PIO) prefix.

That way routers can participate if they learn of other prefixes.
Otherwise, they will still advertise if there are no prefixes known anyway.
This will provide hosts with the A= and M= flags sufficient to initiate DHCP
(which is not a DNA process but can provide the change detection required).

Greg

----- Original Message -----
From: Sathya Narayanan <[email-masked]>
Date: Friday, January 19, 2007 8:10 am
Subject: Re: [DNA] Issue 2: What if no prefix is advertised?
To: Dna <[email-masked]>

> when stateful autoconfiguration is used and that it must be the 
> smallestprefix, we are implicitly requiring the adminstrator to 
> configure each
> of these routers with this information, right? Or, are we talking 
> aboutthe routers sniffing DHCP messages - What does it mean?
> 
> >> all RA message, with L= 0 and A=0. But, atleast one prefix is a 
> MUST.>> The router MUST include the smallest prefix either in PIO 
> or LPO of all
> >> RA messages.
> >> "Issue 6", I will be proposing the removal of the concept of 
> LinkIDs.>> The forward compatibility advantage of the LinkIDs can 
> be easily

---

From: "Templin, Fred L" <[email-masked]>
Date: Fri, 19 Jan 2007 12:49:26 -0800

I haven't followed these discussions closely, but would
there be anything wrong with a router advertising a prefix
with 'A'='L'=0?

Nodes that receive the prefix could consider it as a
"landmark prefix" for the link, but would not infer
anything further from it such as address configuration
expectations, neighbor relationships with other nodes
that receive the prefix, etc. Should there be a draft
issued to discuss this (or, maybe there already has)?

Thanks - Fred
[email-masked]  

> -----Original Message-----
> From: Greg Daley [mailto:[email-masked]] 
> Sent: Thursday, January 18, 2007 9:04 PM
> To: Sathya Narayanan
> Cc: Dna

---

From: Sathya Narayanan <[email-masked]>
Date: Fri, 19 Jan 2007 15:56:01 -0500

Hello Greg -

I agree with what you have said.

But, the open issue is different: the case we are talking about with 
this issue is when stateful address configuration is used on a 
particular link. We agreed during the last meeting to mandate the router 
on such a link to advertise atleast one prefix (the smallest prefix) 
with A=0 and L=0, so that the hosts can still use the RS/RA exchange to 
find out about network attachement. At the moment, there is text in the 
draft for using DHCP CONFIRM - we thought we could remove this text 
after mandating that routers advertise atleast one prefix.

My questions is: how will the routers know about a prefix if stateful 
address configuration is used - do we understand/agree that the routers 
MUST be configured with this information (atleast one prefix) even when 
stateful address configuration is used. Is that acceptable?

Sathya

>>>>advertise any prefix in its RA message. DNA will not work 
>>>>        
>>>>
>>without prefix
>>    
>>
>>>>advertised. Current text relies on DHCP confirm message exchange 
>>>>        
>>>>
>>for DNA
>>    
>>
>>>>in that case.
>>>>
>>>>Agreement at the meeting: Lets mandate the inclusion of one 
>>>>        
>>>>
>>prefix in
>>    
>>
>>>>Note: I am not refering to the smallest prefix as "LinkID" 
>>>>        
>>>>
>>because in
>>    
>>

---

From: Greg Daley <[email-masked]>
Date: Mon, 22 Jan 2007 09:36:42 +1100

Hi Sathya,

I agree that we can ask DNA routers to do this,
and perhaps for DNA purposes MUST is OK.

Greg

----- Original Message -----
From: Sathya Narayanan <[email-masked]>
Date: Saturday, January 20, 2007 7:56 am
Subject: Re: [DNA] Issue 2: What if no prefix is advertised?
To: Greg Daley <[email-masked]>
Cc: Dna <[email-masked]>

> >(which is not a DNA process but can provide the change detection 
> required).>
> >Greg
> >