Subject: Re: [dns-privacy] WG Review: DNS PRIVate Exchange (dprive)

From: Bob Harold <[email-masked]>
Date: Wed, 8 Oct 2014 08:53:35 -0400

It seems that qname minimization would increase the number of queries in
cases where the same DNS server has both a zone and it parent zone.  Extra
queries and more round trips is a concern.  Can someone quantify how much
affect it would have?

For example, minimized queries might take 5 queries:
com
example.com
dept.example.com
group.dept.example.com
host.group.dept.example.com

But if the last three were all on the example.com DNS servers, it would
currently take only three queries, without minimization.  And how much does
caching reduce the affect?

-- 
Bob Harold
DNS and DHCP
University of Michigan

On Tue, Oct 7, 2014 at 6:01 PM, Stephen Farrell <[email-masked]>
wrote:

>
>
> On 07/10/14 22:54, Warren Kumari wrote:
> > Sorry, to me Stephane's qname minimizations is an obvious no-brainer
> > -- we should Just Do It(tm)[0].
> ...
> > [0]: Yes, we should test it and make 100% sure it doesn't break
> > something[1]. It seems so obviously safe that I'm concerned there is a
> > monster under the bed...
>
> +1 getting that done in DNSOP or DPRIVE is right, I don't really
> care so much myself
>
> S.
>
> _______________________________________________
> dns-privacy mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dns-privacy
>

---

From: Andrew Sullivan <[email-masked]>
Date: Wed, 8 Oct 2014 09:27:22 -0400

On Wed, Oct 08, 2014 at 08:53:35AM -0400, Bob Harold wrote:
> cases where the same DNS server has both a zone and it parent zone.  

Yes, certainly.

> caching reduce the affect?

That sort of depends on how long the TTLs are :)

A

-- 
Andrew Sullivan
[email-masked]

---

From: Paul Hoffman <[email-masked]>
Date: Wed, 8 Oct 2014 07:17:22 -0700

When Warren sent his message yesterday, he hadn't noticed that the DNSOP WG is working on adopting the query minimization draft. So far, there is great interest and so any discussion of it should happen on the DNSOP mailing list, probably not here. If DNSOP doesn't adopt the draft, we can maybe discuss it on this list. Having two parallel discussion would probably be a bad thing.

--Paul Hoffman

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Mon, 13 Oct 2014 15:56:22 +0200

[May be last email on Q12N before it moves to dnsop.]

On Wed, Oct 08, 2014 at 08:53:35AM -0400,
 Bob Harold <[email-masked]> wrote 
 a message of 115 lines which said:

> It seems that qname minimization would increase the number of
> queries in cases where the same DNS server has both a zone and it
> parent zone.

Some time ago, it was common (root name servers were also serving
.com...) Now, it is less so, so I guess (no, I do not have hard data)
that it is not a big problem in practice.