Subject: [dns-privacy] REMINDER: Call for Adoptions on the 3 documents.

From: Warren Kumari <[email-masked]>
Date: Fri, 17 Apr 2015 14:48:29 -0400

A reminder that this is underway -- we'd like lots of responses, so
don't be shy...

W

On Wed, Apr 15, 2015 at 9:08 AM, Warren Kumari <[email-masked]> wrote:
> Hi all,
>
> So, the big day has finally arrived -- we are initiating calls for
> adoption on the three documents. < http://i.imgur.com/SKX3P8J.gif >
>
> For *each* of the below documents, please **clearly** state if you
> would like DPRIVE to adopt it, or if you think that it will be a
> distraction / not helpful.
>
> 1) Confidential DNS:
> https://datatracker.ietf.org/doc/draft-wijngaards-dnsop-confidentialdns/
>
> 2) Private-DNS: https://datatracker.ietf.org/doc/draft-hallambaker-privatedns/
>
> 3) TLS for DNS: Initiation and Performance Considerations:
> http://datatracker.ietf.org/doc/draft-hzhwm-dprive-start-tls-for-dns/
>
>
> This call for adoption will be wrapping up on April 30th.
> At that point we will decide on one or multiple of the documents....
>
> W
>
> --
> I don't think the execution is relevant when it was obviously a bad
> idea in the first place.
> This is like putting rabid weasels in your pants, and later expressing
> regret at having chosen those particular rabid weasels and that pair
> of pants.
>    ---maf

-- 
I don't think the execution is relevant when it was obviously a bad
idea in the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair
of pants.
   ---maf

---

From: Ted Hardie <[email-masked]>
Date: Fri, 17 Apr 2015 14:37:08 -0700

> A reminder that this is underway -- we'd like lots of responses, so

​I support adoption of draft-hzhwm-dprive-start-tls-for-dns-02.  With the
indulgence of the chairs, I will not actually state anything about the
other two drafts.

regards,

Ted

​

> > 2) Private-DNS:
> https://datatracker.ietf.org/doc/draft-hallambaker-privatedns/
> >
> _______________________________________________
> dns-privacy mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dns-privacy
>

---

From: Warren Kumari <[email-masked]>
Date: Fri, 17 Apr 2015 19:08:50 -0400

On Friday, April 17, 2015, Ted Hardie <[email-masked]> wrote:

> On Fri, Apr 17, 2015 at 11:48 AM, Warren Kumari <[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
>

Cool. Thanks.

W

> regards,
>
> Ted
>
> ​
>
>
>> On Wed, Apr 15, 2015 at 9:08 AM, Warren Kumari <[email-masked]
>> <javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
>> > Hi all,
>> >
>> <javascript:_e(%7B%7D,'cvml',[email-masked]');>

-- 
I don't think the execution is relevant when it was obviously a bad idea in
the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair of
pants.
   ---maf

---

From: "Christian Huitema" <[email-masked]>
Date: Fri, 17 Apr 2015 20:57:38 -0700

> A reminder that this is underway -- we'd like lots of responses, so

I support adoption of draft-hzhwm-dprive-start-tls-for-dns.

-- Christian Huitema

---

From: "Mankin, Allison" <[email-masked]>
Date: Sun, 19 Apr 2015 13:17:17 +0000

I support adoption of draft-hzhwm-dprive-start-tls-for-dns. It is well along, as is work recommending manageable TCP implementation choices for DNS, in draft-dnsop-rfc5966bis.

I support continued review of draft-wijngaards- for later consideration.

> On Apr 17, 2015, at 14:48, Warren Kumari <[email-masked]> wrote:
>

---

From: Benno Overeinder <[email-masked]>
Date: Mon, 20 Apr 2015 13:01:50 +0200

> I support continued review of draft-wijngaards- for later consideration.

I second that.

If at a later moment sufficient interest in confidential-dns appears in
the WG, we (NLnet Labs) can consider a prototype/reference
implementation of the proposed protocol.

-- Benno

-- 
Benno J. Overeinder
NLnet Labs
http://www.nlnetlabs.nl/

---

From: Sara Dickinson <[email-masked]>
Date: Wed, 22 Apr 2015 13:20:52 +0100

> On 17 Apr 2015, at 19:48, Warren Kumari <[email-masked]> wrote:
> 

I support adoption of this draft because it proposes using existing, well understood technologies to provide privacy with minimal change to the DNS protocol.

>> 1) Confidential DNS:
>> https://datatracker.ietf.org/doc/draft-wijngaards-dnsop-confidentialdns/ <https://datatracker.ietf.org/doc/draft-wijngaards-dnsop-confidentialdns/>

I think this draft is worthy of further review by the working group.

Sara Dickinson

---

From: John Heidemann <[email-masked]>
Date: Thu, 23 Apr 2015 08:24:33 -0700

>> http://datatracker.ietf.org/doc/draft-hzhwm-dprive-start-tls-for-dns/

I recommend 3) draft-hzhwm-dprive-start-tls-for-dns for adoption.
With the 02 revision I think it reflects all specification questions
that have been raised.

In my view 2) draft-hallambaker-privatedns and 1)
draft-wijngaards-dnsop-confidentialdns are not ready for adoption at
this time.  I will send more detailed comments about each separately.

Adopting one document should not rule out adopting others later
(either the others here, or others that may arise).

   -John Heidemann