Subject: [dns-privacy] Stephen Farrell's Yes on draft-ietf-dprive-edns0-padding-02: (with COMMENT)

From: "Stephen Farrell" <[email-masked]>
Date: Tue, 01 Mar 2016 02:07:05 -0800

Stephen Farrell has entered the following ballot position for
draft-ietf-dprive-edns0-padding-02: Yes

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-dprive-edns0-padding/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

- intro: "significantly hampering" is over-stated, even though you
do limit that to size-based correlation as a form of traffic
analysis. This is a basic mechanism (a fine thing) but by itself
does not counter traffic analysis that much. See e.g. [1] for a
relevant study.  Referencing [1] and/or [2] and saying that this
mechanism isn't itself enough would be a good improvement.  ([2] is
a colleague's work btw, but I think is good:-). Neither [1] nor [2]
are DNS-specific, not sure if there are publications that cover
that.  Without such a caveat, people might over-claim and not do the
right things.  Happy to help craft words for that if you want.

   [1] http://kpdyer.com/publications/oakland2012-peekaboo.pdf
   [2] http://arxiv.org/pdf/1410.2087v2.pdf

- typo: "meta data of could still"

---

From: Alexander Mayrhofer <[email-masked]>
Date: Wed, 2 Mar 2016 10:16:37 +0100

Stephen,

thanks for the COMMENT. What about simply removing "significantly" from the
sentence above? Would that address your concerns? I do admit English is not
my first language, so i'm open for suggestions :)

Alex

On Tue, Mar 1, 2016 at 11:07 AM, Stephen Farrell <[email-masked]>
wrote:

> _______________________________________________
> dns-privacy mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dns-privacy
>

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 2 Mar 2016 09:41:39 +0000

> my first language, so i'm open for suggestions :)

That's better yes.

Cheers,
S.