Subject: [dns-privacy] Benoit Claise's No Objection on draft-ietf-dprive-dnsodtls-13: (with COMMENT)

From: "Benoit Claise" <[email-masked]>
Date: Mon, 12 Dec 2016 14:11:34 -0800

Benoit Claise has entered the following ballot position for
draft-ietf-dprive-dnsodtls-13: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-dprive-dnsodtls/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Under which conditions do we know that this experiment will be
successful?
Anything worth nothing?
As an example of a similar RFC, see
https://tools.ietf.org/html/rfc7360#section-1.3

---

From: "Tirumaleswar Reddy (tireddy)" <[email-masked]>
Date: Tue, 13 Dec 2016 05:52:59 +0000

> -----Original Message-----
> From: Benoit Claise (bclaise)
> Sent: Tuesday, December 13, 2016 3:42 AM
> To: The IESG <[email-masked]>
> Cc: [email-masked]; Tim Wicinski <[email-masked]>;
> [email-masked]; [email-masked]; [email-masked]; Eric Vyncke
> (evyncke) <[email-masked]>
> Subject: Benoit Claise's No Objection on draft-ietf-dprive-dnsodtls-13: (with
> COMMENT)
> 
> When responding, please keep the subject line intact and reply to all email
> addresses included in the To and CC lines. (Feel free to cut this introductory
> paragraph, however.)
> 
> 
> Under which conditions do we know that this experiment will be successful?

If there are DNS-over-(D)TLS implementations then the experiment will be successful. Multiple DNS-over-TLS implementations are already available (see https://portal.sinodun.com/wiki/display/TDNS/DNS-over-TLS+implementations).

-Tiru

---

From: Benoit Claise <[email-masked]>
Date: Tue, 13 Dec 2016 08:20:27 +0100

Hi Tiru,
> If there are DNS-over-(D)TLS implementations then the experiment will be successful. Multiple DNS-over-TLS implementations are already available (see https://portal.sinodun.com/wiki/display/TDNS/DN…
At first glance, that is useful.
Looking through it, I don't see DTLS in there.
So you expect to track the DNS over DTLS implementation progress on that 
page, correct?
A few words about this would be welcome, along with this URL.
We always try to have static URLs in RFCs. Even if this one is more of a 
WIKI, I personally believe this is fine and useful for an experimental 
RFC, the goal being to know how to evaluate when an experiment is 
successful.

Regards, Benoit

---

From: Sara Dickinson <[email-masked]>
Date: Tue, 13 Dec 2016 14:45:26 +0000

> On 13 Dec 2016, at 07:20, Benoit Claise <[email-masked]> wrote:

> At first glance, that is useful.

Hi, 

Just a note as I am currently maintaining that website. 

> Looking through it, I don't see DTLS in there.

I am not aware of any implementations of DTLS at the current time - happy to update if incorrect. 

> So you expect to track the DNS over DTLS implementation progress on that page, correct?

I do intend to keep the information up to date but I think a better alternative is to list the (newly acquired)  dnsprivacy.org <http://dnsprivacy.org/> and/or dnsprivay.net <http://dnsprivay.net/> if it is decided a link is useful. 

The websites here are under construction so as a short term measure both sites re-direct to the homepage of the above wiki. However the intension is that these sites will detail the current implementation and deployment status of DNS Privacy solutions (.org will be focussed on end users and .net on service providers). 

Regards

Sara.

---

From: "Tirumaleswar Reddy (tireddy)" <[email-masked]>
Date: Tue, 13 Dec 2016 15:10:27 +0000

> Sent: Tuesday, December 13, 2016 12:50 PM
> To: Tirumaleswar Reddy (tireddy) <[email-masked]>; The IESG
> <[email-masked]>
> [email-masked]; [email-masked]; Eric Vyncke (evyncke)
> <[email-masked]>
> Subject: Re: Benoit Claise's No Objection on draft-ietf-dprive-dnsodtls-13:
> (with COMMENT)
> 
> Hi Tiru,
> >> Cc: [email-masked]; Tim Wicinski
> >> <[email-masked]>; [email-masked]; [email-masked];
> >> [email-masked]; Eric Vyncke
> >> email addresses included in the To and CC lines. (Feel free to cut
> >> this introductory paragraph, however.)
> >>
> >>
> >> Please refer to
> >> https://www.ietf.org/iesg/statement/discuss-criteria.html
> > If there are DNS-over-(D)TLS implementations then the experiment will be
> successful. Multiple DNS-over-TLS implementations are already available (see
> https://portal.sinodun.com/wiki/display/TDNS/DNS-over-
> TLS+implementations).

Yes.

> We always try to have static URLs in RFCs. Even if this one is more of a WIKI, I
> personally believe this is fine and useful for an experimental RFC, the goal
> being to know how to evaluate when an experiment is successful.

Sure, will update draft.

-Tiru