Subject: [dns-privacy] Android getting “DNS over TLS” support to stop ISPs from knowing what websites you visit

From: Stephane Bortzmeyer <[email-masked]>
Date: Mon, 23 Oct 2017 21:47:37 +0200

[There was a demo at the Bits-n-Bites in the last meeting, Prague.]

https://www.xda-developers.com/android-dns-over-tls-website-privacy/amp/

---

From: Tom Pusateri <[email-masked]>
Date: Mon, 23 Oct 2017 20:40:21 -0400

> On Oct 23, 2017, at 3:47 PM, Stephane Bortzmeyer <[email-masked]> wrote:
> 
> https://www.xda-developers.com/android-dns-over-tls-website-privacy/amp/ <https://www.xda-developers.com/android-dns-over-tls-website-privacy/amp/>

For those of you wondering about iOS DNS privacy, Apple added a new DNS Proxy Network Extension in iOS 11 that should allow all DNS requests to be proxied through a network extension app. I began work on a TLS over DNS Proxy and soon discovered that the network extension currently requires the device to be supervised or use a specific type of Mobile Device Management (MDM). I have requested that they lift this restriction (radar

---

From: Tom Pusateri <[email-masked]>
Date: Mon, 23 Oct 2017 20:43:10 -0400

> On Oct 23, 2017, at 8:40 PM, Tom Pusateri <[email-masked]> wrote:
> 
> 
>> On Oct 23, 2017, at 3:47 PM, Stephane Bortzmeyer <[email-masked] <mailto:[email-masked]>> wrote:
>> 

Sorry, sent that one too soon… continuing...

radar 34843801) and if you have an Apple Developer account and would like to see this functionality (NEDNSProxyManager), I encourage you to submit your own bug report at

https://developer.apple.com/bug-reporting/ <https://developer.apple.com/bug-reporting/>

since they are more likely to take action if there are more requests to do so.

Thanks,
Tom