Subject: Re: [dns-privacy] Implementer Perspective

From: Brian Haberman <[email-masked]>
Date: Mon, 15 Oct 2018 08:20:24 -0400

All,
     This week (10/15 - 10/21) let's focus on the implementer's
perspective on DNS privacy between recursive resolvers and authoritative
servers.

     This topic does not appear to have any previously stated views, so
let's work through any impacts on the code bases.

Regards,
Brian

On 7/19/18 2:24 PM, Brian Haberman wrote:
> This thread is for discussion of the implementer perspective of DNS
> privacy between the recursive resolver and authoritative servers.
> 
>     - Focus on *what* is needed.
>     - Avoid *how* to achieve it.
>     - Consider both ends of DNS the exchange.
>     - Scenarios will frame the discussion.
> 
> 
> 
> _______________________________________________
> dns-privacy mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dns-privacy
>

---

From: manu tman <[email-masked]>
Date: Mon, 15 Oct 2018 11:26:14 -0700

>From authoritative server perspective, but really the question can be
flipped over and would apply to recursive server.

- how to signal to a recursive resolver availability of privacy channel.
- how to let recursive resolver authenticate authoritative servers.

Manu

---

From: Tony Finch <[email-masked]>
Date: Tue, 16 Oct 2018 08:52:45 +0100

> perspective on DNS privacy between recursive resolvers and authoritative

Olafur's RIPE talk discusses this to some degree, advocating the
advantages of better transport protocol engineering ...
https://ripe77.ripe.net/programme/meeting-plan/bcop-tf/

Tony.
-- 
f.anthony.n.finch  <[email-masked]>  http://dotat.at/
Thames: Variable 3 or 4, becoming southwest 4 or 5 later. Slight. Mainly fair.
Good, occasionally poor.