Subject: Re: [dnsext] root DNSKEY response is 1749 bytes

From: Chris Thompson <[email-masked]>
Date: 01 Sep 2009 12:48:26 +0100

On Aug 31 2009, Tony Finch wrote:

>On Mon, 31 Aug 2009, Alex Bligh wrote:
>>
>> Question: do stub resolvers on popular operating systems actually
>> fall back to TCP, and if so, do they pipeline?
>
>The usual high-level resolver APIs don't allow pipelining, but GNU adns
>(for example) makes it easy. You can pipeline using the low-level
>resolver API but it's much more fiddly.

Olaf Kolkman's Perl module Net::DNS supports a "persistent_tcp" option:

| Get or set the persistent TCP setting.  If set to true, Net::DNS
| will keep a TCP socket open for each host:port to which it connects.
| This is useful if you're using TCP and need to make a lot of queries
| or updates to the same nameserver.
| 
| This option defaults to false unless you're running under a
| SOCKSified Perl, in which case it defaults to true.

I have used this in some local applications.

-- 
Chris Thompson               University of Cambridge Computing Service,
Email: [email-masked]    New Museums Site, Cambridge CB2 3QH,
Phone: +44 1223 334715       United Kingdom.

---

From: Tony Finch <[email-masked]>
Date: Tue, 1 Sep 2009 14:47:04 +0100

On Mon, 31 Aug 2009, bert hubert wrote:
>
> I would not even be very surprised if it turns out the default Windows
> stub can't do it.

My friends with windows boxes (of various kinds) get the right result from
running nslookup big.dotat.at (response size 617 bytes).

Tony.
-- 
f.anthony.n.finch  <[email-masked]>  http://dotat.at/
GERMAN BIGHT HUMBER: SOUTHWEST 5 TO 7. MODERATE OR ROUGH. SQUALLY SHOWERS.
MODERATE OR GOOD.