Subject: [dnsext] draft-kaplan-dnsext-enum-sip-source-ref-opt-code-01.txt

From: Hadriel Kaplan <[email-masked]>
Date: Tue, 9 Nov 2010 10:24:41 -0500

Howdy,
We've submitted a draft to ask for an EDNS Option-code to be reserved for a private use-case involving SIP/PSTN call traffic in closed networks, but where there are multiple vendors involved in the private network and thus need a known option-code number, and which will not collide with others.  We've been delaying officially asking for this for a couple of years, as it's not appropriate for the public Internet... but there're more than just a couple vendors implementing this now, so we'd really like an option-code reserved.

The details of how to use the mechanism are documented separately in draft-kaplan-enum-sip-routing-01 (http://tools.ietf.org/html/draft-kaplan-enum-sip-routing-01).
The link below is for the draft asking to register the option-code.

Any comments/flames/feedback appreciated, of course.

-hadriel

A New Internet-Draft is available from the on-line Internet-Drafts directories.

	Title           : EDNS Option Code for SIP and PSTN Source Reference Info
	Author(s)       : H. Kaplan, et al.
	Filename        : draft-kaplan-dnsext-enum-sip-source-ref-opt-code-01.txt
	Pages           : 5
	Date            : 2010-11-07

This document requests an IANA allocation for an EDNS0 Option-Code, 
per [RFC2671], for a UTF-8 encoded string field containing a URI for 
private use.  The intended use of this field is for providing SIP 
and PSTN-type source information for ENUM-resolution DNS queries, in 
private DNS server environments such as Private ENUM.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-kaplan-dnsext-enum-sip-source-ref-opt-code-01.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Hadriel Kaplan <[email-masked]>
Date: Tue, 9 Nov 2010 10:35:12 -0500

Ugh, wrong version typo - I mean the details of how to use it are documented in draft-kaplan-enum-sip-routing-02:
http://tools.ietf.org/html/draft-kaplan-enum-sip-routing-02

-hadriel