Subject: Re: Comments on draft-koerber-dnsind-glue-00.txt

From: Mathias Koerber <[email-masked]>
Date: Wed, 1 Dec 1999 14:25:01 +0800 (SGT)

On Wed, 1 Dec 1999, Rahmat M. Samik-Ibrahim wrote:

| Date: Wed, 01 Dec 1999 13:52:20 +0800
| From: Rahmat M. Samik-Ibrahim <[email-masked]>
| To: [email-masked]
| Cc: [email-masked], [email-masked]
| Subject: Comments on draft-koerber-dnsind-glue-00.txt
| 
| Hello:
| 
| > This draft, file name draft-koerber-dnsind-glue-00.txt, is intended
| > to be become a Proposed Standard RFC.  Distribution of this document
| > is unlimited. Comments should be sent to <[email-masked]>
| > or to the author.
| 
| Here are some comments about 
| http://www.ietf.org/internet-drafts/draft-koerber-dnsind-glue-00.txt
| 
| First of all, explaining the "glue" concept to someone else is really a 
| "pain in the backplane". Therefore, IMHO, the document should be as clear 
| as possible. There are simple too many clueless fellows out there :^).
| 

Any suggestions?
However it is not the intent of this draft to explain the concept of glue itself
in a style that the uninitiated can understand, but to provide the technical definition
for a method to more clearly separate addresses used as glue from normal A records.

| 
| > 8.  Recursion Considerations
| >
| > A nameserver receiving queries for GLUEA4, GLUEAAAA or GLUEA6 records
| > (or the GLUE query-type) must not recurse to find those elsewhere.
| 
| Do you mean using CNAME RRs ? Why "must not" instead of "is not recommended" ?

I don't see what CNAMEs have to do with this. This paragraph simply says
that any nameserver being explicitly queries for any of the GLUE* records,
it should only ever reply with matching GLUE records in its authoritative
zones, but not attempt to resurse. QUerying for GLUE* records should only 
be required for debugging purposes, so asking the nameserver that should have
them can be expected. There should never be any need for any application
to ask for GLUE records itself.

|  
| > 12.  Y2K Considerations
| > None. The GLUEA4, GLUEAAAA and GLUEA6 RRs do not carry any time or
| > date information.
| 
| You must be kidding. You might want to change it to "Y10K Consideration" :^).

We haven't passed Y2K yet ... :-(

| 
| 
| >  (Example of section 6)
| >  Parent Zone with traditional glue records
| >  $ORIGIN parent.example.
| > @          IN SOA       ...
| >            IN NS        p1.parent.example.
| >            IN NS        p2.parent.example.
| >            [...]
| > sub        IN NS        s3.sub.parent.example.
| > s1.sub     IN A         10.2.1.1
| > s2.sub     IN A         10.2.2.2
| > s2.sub     IN AAAA      1::1
| > s2.sub     IN A6        1::1
| > s3.sub     IN A6        1::2
| >            [...]
| 
| What are s1.sub and s2.sub doing there in the first place?

Completeness of the example, they all show consistent zones.
If it is really distracting I can take those out.. (others?)

| 
| tabe,
| 
| -- 
| --- Rahmat M. Samik-Ibrahim -- School of Computing -- NUS -----------
| --- http://go.to/grounded-theory ------------------------------------
| 

Mathias Koerber   | Tel: +65 / 471 9820    |   [email-masked]
SingNet NOC       | Fax: +65 / 475 3273    |            [email-masked]
Q'town Tel. Exch. | PGP: Keyid: 768/25E082BD, finger [email-masked]
2 Stirling Rd     |      1A 8B FC D4 93 F1 9A FC BD 98 A3 1A 0E 73 01 65
S'pore 148943     | Disclaimer: I speak only for myself
* Eifersucht ist eine Leidenschaft, die mit Eifer sucht, was Leiden schafft *

---

From: "Rahmat M. Samik-Ibrahim" <[email-masked]>
Date: Wed, 01 Dec 1999 13:52:20 +0800

Hello:

> This draft, file name draft-koerber-dnsind-glue-00.txt, is intended
> to be become a Proposed Standard RFC.  Distribution of this document
> is unlimited. Comments should be sent to <[email-masked]>
> or to the author.

Here are some comments about 
http://www.ietf.org/internet-drafts/draft-koerber-dnsind-glue-00.txt

First of all, explaining the "glue" concept to someone else is really a 
"pain in the backplane". Therefore, IMHO, the document should be as clear 
as possible. There are simple too many clueless fellows out there :^).

> 8.  Recursion Considerations
>
> A nameserver receiving queries for GLUEA4, GLUEAAAA or GLUEA6 records
> (or the GLUE query-type) must not recurse to find those elsewhere.

Do you mean using CNAME RRs ? Why "must not" instead of "is not recommended" ?
 
> 12.  Y2K Considerations
> None. The GLUEA4, GLUEAAAA and GLUEA6 RRs do not carry any time or
> date information.

You must be kidding. You might want to change it to "Y10K Consideration" :^).

>  (Example of section 6)
>  Parent Zone with traditional glue records
>  $ORIGIN parent.example.
> @          IN SOA       ...
>            IN NS        p1.parent.example.
>            IN NS        p2.parent.example.
>            [...]
> sub        IN NS        s3.sub.parent.example.
> s1.sub     IN A         10.2.1.1
> s2.sub     IN A         10.2.2.2
> s2.sub     IN AAAA      1::1
> s2.sub     IN A6        1::1
> s3.sub     IN A6        1::2
>            [...]

What are s1.sub and s2.sub doing there in the first place?

tabe,

-- 
--- Rahmat M. Samik-Ibrahim -- School of Computing -- NUS -----------
--- http://go.to/grounded-theory ------------------------------------