Subject: lame CNAME -> SERVFAIL

From: "D. J. Bernstein" <[email-masked]>
Date: 8 Dec 1999 21:23:31 -0000

Check out the dig results shown below. I thought that this bug---which
makes CNAME queries practically useless---was eliminated in BIND 4.9.4.

---Dan

% dig chaos txt version.bind @dns3.register.com

;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 47987
;; flags: qr aa rd; Ques: 1, Ans: 1, Auth: 0, Addit: 0
;; QUESTIONS:
;;	version.bind, type = TXT, class = CHAOS

;; ANSWERS:
VERSION.BIND.	0	TXT	"8.2.2-P3"

% dig cname emt-p.org @dns3.register.com

;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 37120
;; flags: qr rd; Ques: 1, Ans: 0, Auth: 0, Addit: 0
;; QUESTIONS:
;;	emt-p.org, type = CNAME, class = IN

% dig any emt-p.org @dns3.register.com

;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 65125
;; flags: qr rd; Ques: 1, Ans: 5, Auth: 0, Addit: 3
;; QUESTIONS:
;;	emt-p.org, type = ANY, class = IN

;; ANSWERS:
emt-p.org.	3600	A	205.218.58.195
emt-p.org.	3600	NS	dns3.register.com.
emt-p.org.	3600	NS	dns4.register.com.
emt-p.org.	3600	SOA	dns3.register.com. root.register.com. (
			1999082706	; serial
			10800	; refresh (3 hours)
			86400	; retry (1 day)
			604800	; expire (7 days)
			3600 )	; minimum (1 hour)
emt-p.org.	3600	MX	10 mail.emt-p.org.

;; ADDITIONAL RECORDS:
dns3.register.com.	60	A	209.67.50.253
dns4.register.com.	60	A	209.67.50.254
mail.emt-p.org.	3600	A	205.218.58.195

---

From: [email-masked]
Date: Thu, 09 Dec 1999 16:12:46 +1100

I supose we really should just discard the zone data and
	behave like we don't have the zone configured rather than
	providing a best effort service when we get an error loading
	the zone file.

	Perhaps then people will actually pay attention to the
	errors logged when a zone is loaded.

	However as we are performing best effort we cannot
	authoritavely say that a given type does not exist.

	Mark

--
Mark Andrews, Internet Engines Inc. / Internet Software Consortium
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]