Subject: RE : [dnsop] Re: IPv6 Host Configuration of Recursive DNS Server

From: "BELOEIL Luc FTRD/DMI/CAE" <[email-masked]>
Date: Fri, 11 Jun 2004 18:40:08 +0200

This document is really interesting  and is a good overview of solutions being proposed.

Anyway may I suggest some comments that may clarify or precise that good work ?

Editorial suggestions :

Page 3 - section 3.1 : "configura-tion" -> "configuration"

Page 6 - section 3.2.1 : so as to facilitate comparison with section 3.1.1, could you precise in advantage number 5 "such as NTP server address, SIP servers addresses, ..."

Page 7 - section 3.2.2 : is disadvantage number 1 a real one ? It seems the point explains that it is currently an issue but that could not be if [10]... To my mind if there any one solution proposal, there is no more disadvantage (RA and well-known approaches are also draft proposal).

Page 8 - Section 3.3 : last point deals with DNSSEC. It seems to me that RA and DHCPv6 solution encounter the same issue. Thus I guess if that point should be maintained here.

Page 8 - section 4 : I feel ill-at-ease with the "last resort" point. I remember that the point was already discussed but anyway it is till not clear. Should we understand that the first option of anycast interworking approach means that such anycast address MUST always be configured in any host ? (Note : ok this point is not only editorial but also for my understanding)

Page 9 - section 5 : the Note about guideline and enforcement may also be mentioned in section 4, may not it ?

Page 9-16 - sections 5.1 and 5.4 : it seems the same hierarchy as IETF v6ops wg scenarios have been chosen. But I have the feeling that sections 5.1 and 5.4 concentrate around the same issue "how to handle RDNSS information between PE and CPE ?". Could section 5.1 be clarified and subdivised in : 
- how to handle RDNSS information within ISP network
- how to exchange RDNSS information (if applicable) between PE and CPE
- how to handle RDNSS information in CPE
- how to handle RDNSS information in customer network (what may be a good introduction to enterprise scenario, unmanaged scenario and home/SOHO subscribers scenario) ?

Page 10 - section 5.1.2 : please clarify "so that DHCPv6 can be may applied for the current ..." ?

Page 11 - section 5.1.4 : the points of the two last paragraphs are not clear, and the first one is already described in section 5.1.2

Page 11 - section 5.2 : I do not think that any reference to UNIX should be mentioned, or please define or propose a reference for the term "UNIX".

Page 12 - section 5.2.1 : Sorry, I do no understand the point....especially it is not clear if each level is configured through DHCPv6... and what configures what ? Is that exist in any enterprise ?

Page 15 - section 5.3.4 : I suggest to add "Note : history" before the second paragraph.

My 0.02 %
Luc 

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Jaehoon Paul Jeong
Envoyé : lundi 7 juin 2004 05:57
À : [email-masked]
Cc : DHC WG; V6OPS WG; IPv6 WG; IPv6 DNS Configuration
Objet : [dnsop] Re: IPv6 Host Configuration of Recursive DNS Server

Hi all,

For 1 week, there have been no comments on our IPv6 DNS Configuraion.
  http://www.adhoc.6ants.net/~paul/publications/ietf-internet-draft/draft-ietf-dnsop-ipv6-dns-configuration-00.txt

Does it mean that there is no problem about this draft and it is ok to request WGLC? :-)

Paul

----- Original Message ----- 
From: "Jaehoon Paul Jeong" <[email-masked]>
To: <[email-masked]>
Cc: "IPv6 DNS Configuration" <[email-masked]>
Sent: Thursday, June 03, 2004 2:38 PM
Subject: Re: IPv6 Host Configuration of Recursive DNS Server

> There is some problem of  column alignment at our draft.
> You can find a fixed version at the following site:  
> http://www.adhoc.6ants.net/~paul/publications/ietf-internet-draft/draf
> t-ietf-dnsop-ipv6-dns-configuration-00.txt
> 
> Thanks.
> 
> Paul
> 
> ----- Original Message -----
> From: "Jaehoon Paul Jeong" <[email-masked]>
> To: <[email-masked]>
> Cc: "IPv6 DNS Configuration" <[email-masked]>
> Sent: Thursday, June 03, 2004 10:10 AM
> Subject: IPv6 Host Configuration of Recursive DNS Server
> 
> 
> > Hello DNSOP members,
> > 
> > As you know, a new draft has been published for IPv6 Host 
> > Configuration of DNS Server Information Approaches:  
> > http://www.ietf.org/internet-drafts/draft-ietf-dnsop-ipv6-dns-config
> > uration-00.txt
> > 
> > For a long time, DNS Discovery has been discussed at both IPv6 and 
> > DNSOP working groups. The long discussion seems to be resolved 
> > through this draft.
> > 
> > In this draft, three approaches are suggested: (a) RA option, (b) 
> > DHCPv6 option, and
> > (c) Well-known anycast addresses for Recursive DNS Servers.
> > We, authors, used "DNS Configuration" instead of "DNS Discovery" because recursive DNS server address is 
> > only configured in IPv6 host, not generating DNS server address like in IPv6 address autoconfiguration.
> > 
> > This draft focuses on describing the attributes of three approaches 
> > and suggesting four applicable scenarios:
> > (a) ISP network, (b) Enterprise network, (c) 3GPP network, (d) Unmanaged network.
> > 
> > Through your review and comments, this will be published as 
> > Informational RFC according to our milestones. IMHO, if necessary, 
> > the drafts of two other approaches except DHCPv6 option will be 
> > developed into separate RFCs.
> > 
> > Thanks.
> > 
> > Paul,
> > IPv6 DNS Configuration Design Team.
> > 
> > ------------------------------------------------------
> > Jaehoon Paul Jeong (Research Engineer)
> > TEL. +82-42-860-1664
> > Mobile +82-16-711-1765
> > 161 Gajeong-dong Yuseong-gu, Daejeon 305-350, Korea
> > NGI Standardization Research Team/PEC/ETRI
> > Homepage: http://www.adhoc.6ants.net/~paul
> > 
> 

.
dnsop resources:_____________________________________________________
web user interface: http://darkwing.uoregon.edu/~llynch/dnsop.html
mhonarc archive: http://darkwing.uoregon.edu/~llynch/dnsop/index.html

.
dnsop resources:_____________________________________________________
web user interface: http://darkwing.uoregon.edu/~llynch/dnsop.html
mhonarc archive: http://darkwing.uoregon.edu/~llynch/dnsop/index.html

---

From: "Jaehoon Paul Jeong" <[email-masked]>
Date: Thu, 17 Jun 2004 13:34:23 +0900

Hi Luc,

First of all, thanks for your kind comments.
During the last call of our draft, we'll reflect others' comments and suggestions on it,
including yours. :-)

Paul

----- Original Message ----- 
From: "BELOEIL Luc FTRD/DMI/CAE" <[email-masked]>
To: "Jaehoon Paul Jeong" <[email-masked]>; <[email-masked]>
Cc: "IPv6 DNS Configuration" <[email-masked]>
Sent: Saturday, June 12, 2004 1:40 AM
Subject: RE : [dnsop] Re: IPv6 Host Configuration of Recursive DNS Server

.