Subject: [DNSOP] rfc 952, rfc 1123 and 25 years of .com

From: João Damas <[email-masked]>
Date: Tue, 16 Mar 2010 09:39:43 +0100

casually looking through what seems to be a list of the oldest .com registration still around, I came across 3com.com, registered, according to whois on 11-dec-1986. Been a while :)
Thing is I had this vague impression that domain names weren't allowed to begin with a number until later than that. Upon checking, RFC 952, published in October 1985 had the starting-number restriction and it wasn't until RFC 1123 (Oct 1989) that this got relaxed. Anyone around remember how 3com.com got registered ahead of it seemingly being a valid domain name (and again, this is in itself a bit confusing as RFC 952 introduces the restriction for hostnames and domain names, and RFC 1123 only seems to lift the restriction for hostnames)

Anyway just curious

Joao

---

From: Andrew Sullivan <[email-masked]>
Date: Tue, 16 Mar 2010 06:42:21 -0400

On Tue, Mar 16, 2010 at 09:39:43AM +0100, João Damas wrote:

> Thing is I had this vague impression that domain names weren't
> allowed to begin with a number until later than that. Upon checking,
> RFC 952, published in October 1985 had the starting-number
> restriction and it wasn't until RFC 1123 (Oct 1989) that this got
> relaxed. Anyone around remember how 3com.com got registered ahead of
> it seemingly being a valid domain name (and again, this is in itself
> a bit confusing as RFC 952 introduces the restriction for hostnames
> and domain names, and RFC 1123 only seems to lift the restriction
> for hostnames)

I can't answer this question exactly, but I had occasion to ask Bob
Braden directly about the context of the "always alphabetic" text in
1123 at one of the meetings last year, because that text in 1123
remains problematic (depending how you read it, it may prohibit TLDs
of the form xn--[something], which would be bad given that there are
such TLDs in the root zone today).  

He brightened up and immediately recognized the text in 1123 as "the
3com rule".  This makes me think that he might be able to answer your
question.  

Another place to ask might be the Internet history list, where people
who remember some of the early decisions tend to hang out.

Best,

A

-- 
Andrew Sullivan
[email-masked]
Shinkuro, Inc.

---

From: Dr Eberhard W Lisse <[email-masked]>
Date: Tue, 16 Mar 2010 11:55:50 +0100

Andrew,

can you perhaps email me the address of that list?

el

---

From: Andrew Sullivan <[email-masked]>
Date: Tue, 16 Mar 2010 07:15:18 -0400

> can you perhaps email me the address of that list?

Since that is already one of two requests I've had:

List-Subscribe: <http://mailman.postel.org/mailman/listinfo/internet-history>,  
        <mailto:[email-masked]?subject=subscribe>

A

-- 
Andrew Sullivan
[email-masked]
Shinkuro, Inc.

---

From: Mark Andrews <[email-masked]>
Date: Wed, 17 Mar 2010 08:04:26 +1100

In message <[email-masked]>, =?iso-8859-1?Q?Jo
=E3o_Damas?= writes:
> casually looking through what seems to be a list of the oldest .com registrat
> ion still around, I came across 3com.com, registered, according to whois on 1
> 1-dec-1986. Been a while :)
> Thing is I had this vague impression that domain names weren't allowed to beg
> in with a number until later than that. Upon checking, RFC 952, published in 
> October 1985 had the starting-number restriction and it wasn't until RFC 1123
>  (Oct 1989) that this got relaxed. Anyone around remember how 3com.com got re
> gistered ahead of it seemingly being a valid domain name (and again, this is 
> in itself a bit confusing as RFC 952 introduces the restriction for hostnames
>  and domain names, and RFC 1123 only seems to lift the restriction for hostna
> mes)

	The need to support 3com lead to the change which was codified in
	RFC 1123.

> Anyway just curious
> 
> Joao
> _______________________________________________
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop
-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]