Subject: [DNSOP] Ugly Hack, Step 2: Detection of Problem

From: Jason Livingood <[email-masked]>
Date: Thu, 01 Apr 2010 10:51:44 -0400

2 - Describe all the various methods and tactics by which end user
"brokenness" can be detected.  This may include website-based detection,
DNS-query-based detection, or a variety of other methods.

Suggestions: (Nick Weaver I think had one  pasted below)

Also, you can make an EASY in-browser Javascript check.

Load 3 images in a hidden DIV.  These images should ideally be set to be
non-cached and have a cache-buster in the URL (akin to how Google Analytic's
hidden GIF is loaded: it contains a cache-buster in the URL).

One is hosted on an IPv4 only site, one on a IPv4/IPv6 dual stack, and one
on a IPv6 only site, and bind onload/onerror to Javascript for reporting.

If the first two load, the host is a successful V4 host.

If only the first loads, the host has the described problem with a link
local V6, and needs to be patched: have the Javascript notify the user.

If only the second and third loads, the host is V6 only (HA!).

---

From: Nicholas Weaver <[email-masked]>
Date: Thu, 1 Apr 2010 07:55:46 -0700

On Apr 1, 2010, at 7:51 AM, Jason Livingood wrote:

> 2 - Describe all the various methods and tactics by which end user "brokenness" can be detected.  This may include website-based detection, DNS-query-based detection, or a variety of other methods.
> 
> Suggestions: (Nick Weaver I think had one – pasted below)
> 
> Load 3 images in a hidden DIV.  These images should ideally be set to be non-cached and have a cache-buster in the URL (akin to how Google Analytic's hidden GIF is loaded: it contains a cache-buster in the URL).
> 
> One is hosted on an IPv4 only site, one on a IPv4/IPv6 dual stack, and one on a IPv6 only site, and bind onload/onerror to Javascript for reporting.
> 
> If only the first loads, the host has the described problem with a link local V6, and needs to be patched: have the Javascript notify the user.

Addition I just realized:

Additionally, if the first loads immediately but the second loads delayed by 1-2+ seconds, (can be measured by the server if not directly in Javascript alone) then it is a timeout problem rather than a complete failure problem, and should also be reported.