Subject: [DNSOP] draft-ietf-dnsop-default-local-zones and the former IP6.INT.

From: Alfred Hönes <[email-masked]>
Date: Tue, 6 Apr 2010 15:22:59 +0200 (MESZ)

Folks,
skimming over your most recent "Locally-served DNS Zones I-D",
draft-ietf-dnsop-default-local-zones-11, I got stuck in section 5.

The 4th paragraph of that section in the draft says:

|  This document also ignores IP6.INT.  IP6.INT has been wound up with
|  only legacy resolvers now generating reverse queries under IP6.INT
|  [RFC4159].

I had some vague recollection that IP6.INT had gone out of service
quite some time ago, and started over to verify that.
A copy of the INT zone is no more made available online via FTP,
but I have checked all authoritative name servers for INT., and they
indeed all consistently respond with NXDOMAIN to any query for IP6.INT.

Recollection starts to leak after >4 years, and for an uninitiated
reader, the phrase "has been wound up" seems to be rather ambiguous.
I'd prefer the draft to state the facts more precisely so that the
conclusion drawn can be better understood.

Proposed strawman replacement for above clause:

|    This document also ignores IP6.INT, which initially hosted the IPv6
|    reverse DNS tree but does not exist any more, after it had been
|    demissed by [RFC4159].  IP6.INT has been wound up with only legacy
|    resolvers now generating reverse queries under IP6.INT.

Kind regards,
  Alfred.

---

From: Jim Reid <[email-masked]>
Date: Tue, 6 Apr 2010 14:32:36 +0100

IMO the original text is fine. It's clearer and simpler.

---

From: Joe Abley <[email-masked]>
Date: Tue, 6 Apr 2010 09:53:32 -0400

> |  only legacy resolvers now generating reverse queries under IP6.INT

I also think the text above could be improved: "wound up" is an ambiguous phrase, and the bare reference to 4159 does not make it obvious to readers that the name (and its use in the v6 reverse tree) has been deprecated unless the reader is in the habit of jumping for footnotes.

> |    resolvers now generating reverse queries under IP6.INT.

"IP6.INT was once used to provide reverse mapping for IPv6. IP6.INT was deprecated in [RFC4159] and the delegation removed from the INT zone in June 2006. While it is possible that legacy software continues to send queries for names under the IP6.INT domain, this document does not specify that IP6.INT be considered a local zone."

Joe

---

From: Andrew Sullivan <[email-masked]>
Date: Tue, 6 Apr 2010 10:27:32 -0400

> "IP6.INT was once used to provide reverse mapping for IPv6. IP6.INT was deprecated in [RFC4159] and the delegation removed from the INT zone in June 2006. While it is possible that legacy software…

I like this text the best of the three.

A

-- 
Andrew Sullivan
[email-masked]
Shinkuro, Inc.

---

From: [email-masked]
Date: Tue, 6 Apr 2010 16:28:33 +0000

as the admin for ip6.int.  the IPv6 wg declared that ip6.int
 should be terminated on 6/6/06 - along with the 6bone.  David
 Conrad removed the delegation shortly there after, even though
 there are still resolvers which look for that delegation instead
 of the ip6.arpa zone - which functions as its replacement.  I had
 proposed using the "DNAME" construct to allow the 10+ years of 
 resolver code that was/is using ip6.int to continue to function
 well ... but this idea was rejected by the IANA.

--bill

On Tue, Apr 06, 2010 at 03:22:59PM +0200, Alfred Hvnes wrote:
> _______________________________________________
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop

---

From: David Conrad <[email-masked]>
Date: Tue, 6 Apr 2010 06:39:30 -1000

"It's dead, Jim." -- Dr. Leonard "Bones" McCoy