Subject: Re: [DNSOP] Ugly DNS ack

From: John Payne <[email-masked]>
Date: Thu, 1 Apr 2010 01:09:14 -0400

On Apr 1, 2010, at 12:29 AM, John Jason Brzozowski <[email-masked] 
 > wrote:

> Not necessarily, if a dual stack hosts communicates with a recursive  
> name
> server over both IPv4 and IPv6 and other conditions are met then I  
> believe
> it would be fine based on what was presented.

Oh... So instead of the google "this is a whitelist of nameservers of  
ISPs who promise to fix brokenness" this is a proposal to give ISPs a  
tool to then build a whitelist of ISPs who promise to only ask for  
AAAA if the end user asked over ipv6.

Seems to me like the first whitelist will lead to problems actually  
getting fixed and the second will lead to a small whitelist :/

I really do get the concern about losing eyeballs... I'm just afraid  
of too many whitelists founded on broken promises :)

>
> John
>
>
> On 3/31/10 5:12 PM, "John Payne" <[email-masked]> wrote:
>
>>
>>
>> On Mar 31, 2010, at 3:19 PM, Dan Wing wrote:
>>
>>> Any host that sends its AAAA queries over IPv4 would lose
>>> IPv6 connectivity.
>>
>>
>> Isn't this a misdirection?
>>
>> I suspect it's more like: any (address family agnostic) clients of  
>> a dual
>> stacked nameserver will (non?) deterministically lose IPv6  
>> connectivity to
>> DNS-determined destinations.
>>
>> ie, even if I only send DNS over IPv6 to my recursive nameserver,  
>> if it is
>> dual stacked (often beyond my control), and for this specific query  
>> it prefers
>> IPv4, then I will not get an answer for my AAAA under this proposal.
>>
>>
>
> =========================================
> John Jason Brzozowski
> Comcast Cable
> e) mailto:[email-masked]
> o) 609-377-6594
> m) 484-962-0060
> w) http://www.comcast6.net
> =========================================
>

---

From: John Jason Brzozowski <[email-masked]>
Date: Thu, 01 Apr 2010 07:49:08 -0400

The intention is not signal the recursive name server to use a specific
transport with authoritative name servers.  The intention is to use the
transport to determine how the recursive name server responds to the
original query.

On 4/1/10 1:41 AM, "Patrick W. Gilmore" <[email-masked]> wrote:

> On Apr 1, 2010, at 12:29 AM, John Jason Brzozowski wrote:
> 
>> Not necessarily, if a dual stack hosts communicates with a recursive name
>> server over both IPv4 and IPv6 and other conditions are met then I believe
> What other conditions need to be met?
> 
> I did not think there was any way for a host to signal a recursive NS to use
> v6 or v4 transport.
> 
> --
> TTFN,
> patrick
> 
> 
>>> I suspect it's more like: any (address family agnostic) clients of a dual
>>> stacked nameserver will (non?) deterministically lose IPv6 connectivity to
>>> ie, even if I only send DNS over IPv6 to my recursive nameserver, if it is
>>> dual stacked (often beyond my control), and for this specific query it
>>> prefers
>> _______________________________________________
>> DNSOP mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/dnsop
>> 
>