Subject: [DNSOP] Further observationon AS112 ipv4 cull

From: "William F. Maton Sotomayor" <[email-masked]>
Date: Tue, 26 Jul 2011 13:48:29 -0400 (EDT)

All,
 	As a data point, the original draft of -00 really started life as 
a straight copy of George's and Geoff's draft.  I was looking for a way to 
establish a procedure for sending instructions to IANA for new delegations 
to AS112 nodes, so they paved the way.  That said, I also don't have a 
problem with splitting my draft into 2:  One with the original set of 
instructions and another that could possibly either lead to a 'bis' for 
6303 or become another document in a series of AS112 RFCs - much like RFC 
6305 seems to be.

(I'm more pragmatic in the sense that I'd like to see the instructions go 
forward faster than another Informational RFC/bis. :-) )

Thanks,

wfms

---

From: George Michaelson <[email-masked]>
Date: Tue, 26 Jul 2011 13:53:07 -0400

On 26/07/2011, at 1:48 PM, William F. Maton Sotomayor wrote:

> 
> All,
> 	As a data point, the original draft of -00 really started life as a straight copy of George's and Geoff's draft.  I was looking for a way to establish a procedure for sending instructions to IANA for new delegations to AS112 nodes, so they paved the way.  That said, I also don't have a problem with splitting my draft into 2:  One with the original set of instructions and another that could possibly either lead to a 'bis' for 6303 or become another document in a series of AS112 RFCs - much like RFC 6305 seems to be.
> 
> (I'm more pragmatic in the sense that I'd like to see the instructions go forward faster than another Informational RFC/bis. :-) )
> 
> Thanks,
> 
> wfms

I would support this latter approach William: I think we should seek WG adoption of three drafts

1) the michaelson as112-ipv6 draft, aiming for at least one 01 spin to a small set of non-controversial V6 delegations, moving to WGLC and IANA asap.

2) your as112-ipv4-cull draft, but shorn of the operational aspects, likewise rapid movement to WGLC and IANA

3) an AS112 operational draft more in the nature of 6304/5/bis

I would like to ask for WG adoption of AS112-IPv6 on that basis.

cheers

-George

---

From: George Michaelson <[email-masked]>
Date: Tue, 26 Jul 2011 13:52:46 -0400

cheers

-George

---

From: "William F. Maton Sotomayor" <[email-masked]>
Date: Wed, 27 Jul 2011 22:08:14 -0400 (EDT)

> 2) your as112-ipv4-cull draft, but shorn of the operational aspects, likewise rapid movement to WGLC and IANA

For the consideration of members of DNSOP to adopt as a working group 
item, -01 of my draft has been submitted.

> 3) an AS112 operational draft more in the nature of 6304/5/bis

This one will follow a little later, I suspect more expanded than before.

> I would like to ask for WG adoption of AS112-IPv6 on that basis.

+1, especially since some as112 natives are getting restless.

Thanks,

wfms

---

From: Warren Kumari <[email-masked]>
Date: Thu, 28 Jul 2011 14:11:41 -0400

On Jul 27, 2011, at 10:08 PM, William F. Maton Sotomayor wrote:

> For the consideration of members of DNSOP to adopt as a working group item, -01 of my draft has been submitted.
> 

I made a suggestion at the mic in the f2f meeting, and then on the as112 operators list -- there seems to be some support for it there, so I'm now doing it onlist…

How about simply making AS112 omniscient (know the answers for *all* space)? As decisions to have AS112 answer / not answer for zones get made, delegations can simply be added and removed. 

Obviously this would require synthesizing answers[0], and these servers cannot be used for answering recursive queries (and a few other minor issues) but this will (as far as I can see) solve the lameness / coordination issues...

W

[0]: Yes, yes i *did* feel dirty writing that….

> Thanks,
> 
> wfms
> _______________________________________________
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop
>

---

From: [email-masked]
Date: Thu, 28 Jul 2011 18:29:09 +0000

On Thu, Jul 28, 2011 at 02:11:41PM -0400, Warren Kumari wrote:
> I made a suggestion at the mic in the f2f meeting, and then on the as112 operators list -- there seems to be some support for it there, so I'm now doing it onlistb&
> 
> [0]: Yes, yes i *did* feel dirty writing thatb&.
> 
> 
> > Thanks,
> > 
> > wfms

	been there, done that.  before ICANN existed, I ran the RFC 1918 auth servers.
	put in a wild card TXT "Please read RFC 1918" to any/every query.  20min later
	after the university pres had fielded calls fm industry about being hacked- we removed
	the wildcard...  until leaking DNS queris fm private netsinto the Internetcan
be stopped, you can't reliably anwer the queries.

/bill