Subject: Re: [DNSOP] CDS and/or CDNSKEY

From: Mark Andrews <[email-masked]>
Date: Wed, 09 Oct 2013 10:13:53 +1100

Mark Andrews writes:
> 
> The DNS has more than one opcode.  Why don't we just use one of
> them to discover the registrar for <qname,qtype,qclass>?  If you
> get back NOTIMP you fallback to traditional UPDATE to the parent.
> The response to the query would be PTR record(s) to the UPDATE
> server(s).
 
I would use whois for this discovery but the response is free form
text and you have the whole whois server discovery problem to deal
with.

Registrars already trust the registry to supply this information
over whois.

> Mark
> 
> In message <[email-masked]>, Paul Hoffman writ
> es
> :
> > On Oct 8, 2013, at 1:10 PM, Doug Barton <[email-masked]> wrote:
> > 
> > >> That is the opposite of the feeling that I got from the DNSOP meeting in
>  B
> > erlin.
> > > 
> > > ... and yet, there is a larger world outside the select few able to atten
> d 
> > the meetings. :)  One could even reasonably argue that the opinion of those
>  w
> > ho do attend the meetings is of questionable statistical validity due to vo
> lu
> > nteer bias.
> > 
> > If your view is that the only way to write a standard is after you have hea
> rd
> >  from a majority of everyone who would be affected by it, that's fine, but 
> it
> >  is not the model that is used standards bodies like the IETF.
> > 
> > --Paul Hoffman
> > _______________________________________________
> > DNSOP mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/dnsop
> -- 
> Mark Andrews, ISC
> 1 Seymour St., Dundas Valley, NSW 2117, Australia
> PHONE: +61 2 9871 4742                 INTERNET: [email-masked]
-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]

---

From: Andrew Sullivan <[email-masked]>
Date: Tue, 8 Oct 2013 19:57:21 -0400

> text and you have the whole whois server discovery problem to deal

This sounds like an excellent reason to contribute to the rapid
specification and deployment of WEIRDS.

A

-- 
Andrew Sullivan
[email-masked]

---

From: "Guangqing Deng" <[email-masked]>
Date: Wed, 9 Oct 2013 08:29:41 +0800

>From: Andrew Sullivan
>Date: 2013-10-09 07:57
>To: dnsop
>Subject: Re: [DNSOP] CDS and/or CDNSKEY

>specification and deployment of WEIRDS.

Agree, maybe it is time to think more about whether the WEIRDS protocol needs to be extended to support query of CDS and/or CDNSKEY and how to do that. 

Guangqing Deng
CNNIC

---

From: Mark Andrews <[email-masked]>
Date: Wed, 09 Oct 2013 13:06:38 +1100

In message <[email-masked]>, "Guangqing Deng" writes:
>
> >From: Andrew Sullivan
> >Date: 2013-10-09 07:57
> >To: dnsop
> >Subject: Re: DNSOP CDS and/or CDNSKEY
> Agree, maybe it is time to think more about whether the WEIRDS protocol 
> needs to be extended to support query of CDS and/or CDNSKEY and how to do 
> that. 

Weirds still has the weirds server discovery problem.