Subject: [DNSOP] reverse DNS for IPv4 and IPv6 multicast address assignments

From: Joe Abley <[email-masked]>
Date: Fri, 18 Oct 2013 17:19:57 -0400

Hi all,

For your weekend reading pleasure, see below.

I am suggesting that we normalise the way in which MCAST.NET names are provisioned and maintained, shift them to MCAST.ARPA, and instantiate an equivalent MCAST6.NET naming scheme for IPv6 multicast (for which there is nothing, currently).

Any comments on the naming scheme (or anything else) would be most welcome.

Happy to present briefly on this in Vancouver if anybody is interested.

Joe

Begin forwarded message:

> From: [email-masked]
> Subject: New Version Notification for draft-jabley-multicast-ptr-00.txt
> Date: 18 October 2013 15:50:37 EDT
> To: Joe Abley <[email-masked]>
> 
> 
> A new version of I-D, draft-jabley-multicast-ptr-00.txt
> has been successfully submitted by Joe Abley and posted to the
> IETF repository.
> 
> Filename:	 draft-jabley-multicast-ptr
> Revision:	 00
> Title:		 DNS Reverse Mapping for Multicast Addresses
> Creation date:	 2013-10-18
> Group:		 Individual Submission
> Number of pages: 17
> URL:             http://www.ietf.org/internet-drafts/draft-jabley-multicast-ptr-00.txt
> Status:          http://datatracker.ietf.org/doc/draft-jabley-multicast-ptr
> Htmlized:        http://tools.ietf.org/html/draft-jabley-multicast-ptr-00
> 
> 
> Abstract:
>   The mapping of IPv4 and IPv6 addresses to names using the Domain Name
>   System (DNS) is colloquially known as "Reverse Mapping".  Reverse
>   Mapping support for registered multicast address assignments in IPv4
>   is currently incomplete and ad-hoc; in IPv6 there is no support at
>   all.
> 
>   This document describes procedures to be followed that will result in
>   more systematic and predictable support for Reverse Mapping for IPv4
>   multicast address assignments, and introduces analogous support for
>   IPv6.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
>

---

From: Joe Abley <[email-masked]>
Date: Sat, 19 Oct 2013 10:27:32 -0400

> I am suggesting that we normalise the way in which MCAST.NET names are provisioned and maintained, shift them to MCAST.ARPA, and instantiate an equivalent MCAST6.NET naming scheme for IPv6 multicas…

I meant MCAST6.ARPA, above. Whoops! The text in the draft is right, however.

Joe

---

From: "William F. Maton Sotomayor" <[email-masked]>
Date: Mon, 21 Oct 2013 21:46:13 -0400 (EDT)

Hi Joe, et al.

I have read this and support this work.  It's good to see a proposal for 
consolidating and making the namespace consistent. Given that MCAST.NET 
use has been around a lot longer than IPV6.INT it will be interesting to 
see for how long the names in the MCAST.NET zone will persist should this 
document become published.

Another registry.  Ugh.  But what other way is there?

I think it would be a good idea for Len and Greg over in mboned to have a 
look at this as I believe they had some inputs to provide on unrelated 
drafts to this one (namely subsequent AS112 drafts) and may want to 
comment on this one in particular.

I like the use of DNAME in section 6.5. :)

On Fri, 18 Oct 2013, Joe Abley wrote:

> _______________________________________________
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop
>

wfms