Subject: [DNSOP] hong kong workshop, day 2, live link

From: Paul Vixie <[email-masked]>
Date: Mon, 08 Dec 2014 17:16:39 -0800

stream:

https://www.youtube.com/watch?v=cMKvI-Hk7Uw

draft agenda:

https://docs.google.com/spreadsheets/d/1ssXQE5gGoWC93oFHquY2oZL4pDOv1bPDVjPoGYGdeSs

-- 
Paul Vixie

---

From: Rubens Kuhl <[email-masked]>
Date: Tue, 9 Dec 2014 13:29:09 -0200

Paul,

Complementing what Edmon Chung mentioned that root-servers was already reserved in the last new gTLD round, here follows the complete list of reserved names:

AFRINIC
IANA-SERVERS
NRO
ALAC
ICANN
RFC-EDITOR
APNIC
IESG
RIPE
ARIN
IETF
ROOT-SERVERS
ASO
INTERNIC
RSSAC
CCNSO
INVALID
SSAC
EXAMPLE
IRTF
TEST
GAC
ISTF
GNSO
LACNIC
WHOIS
GTLD-SERVERS
LOCAL
WWW
IAB
LOCALHOST
IANA
NIC

So, it could be a good option for using instead of the delegated and at times poisoned root-servers.net ... 

BTW, are there archives of the workshop available ? 

Rubens

> Em 08/12/2014, à(s) 23:16:000, Paul Vixie <[email-masked]> escreveu:
> 
> stream:
> 
> _______________________________________________
> dns-operations mailing list
> [email-masked]
> https://lists.dns-oarc.net/mailman/listinfo/dns-operations
> dns-jobs mailing list
> https://lists.dns-oarc.net/mailman/listinfo/dns-jobs

---

From: Eric Brunner-Williams <[email-masked]>
Date: Tue, 09 Dec 2014 08:03:20 -0800

On 12/9/14 7:29 AM, Rubens Kuhl wrote:
> ...

Is "NIC" reserved because that's what Jake Feinler's shop at SRI (on the 
floor below my shop) was called, or is "NIC" reserved because it is the 
alpha-3 code point assigned to Nicaragua by the ISO-3166-MA?

Eric

---

From: Rubens Kuhl <[email-masked]>
Date: Tue, 9 Dec 2014 14:09:32 -0200

> Em 09/12/2014, à(s) 14:03:000, Eric Brunner-Williams <[email-masked]> escreveu:
> 
> Is "NIC" reserved because that's what Jake Feinler's shop at SRI (on the floor below my shop) was called, or is "NIC" reserved because it is the alpha-3 code point assigned to Nicaragua by the ISO-3166-MA?

alpha-3 codes are not reserved. 

Rubens

---

From: Rubens Kuhl <[email-masked]>
Date: Tue, 9 Dec 2014 14:13:45 -0200

> Em 09/12/2014, à(s) 14:09:000, Rubens Kuhl <[email-masked]> escreveu:
> 
>> 

I mean, alpha-3 codes are not listed on the AGB part I copied. alpha-3 codes are reserved, but not listed. 

Rubens

---

From: Randy Bush <[email-masked]>
Date: Wed, 10 Dec 2014 02:12:46 +0900

> Complementing what Edmon Chung mentioned that root-servers was already
> reserved in the last new gTLD round, here follows the complete list of
> reserved names:
> 
> AFRINIC
> IANA-SERVERS
> NRO
> ALAC
> ICANN
> RFC-EDITOR
> APNIC
> IESG
> RIPE
> ARIN
> IETF
> ROOT-SERVERS
> ASO
> INTERNIC
> RSSAC
> CCNSO
> INVALID
> SSAC
> EXAMPLE
> IRTF
> TEST
> GAC
> ISTF
> GNSO
> LACNIC
> WHOIS
> GTLD-SERVERS
> LOCAL
> WWW
> IAB
> LOCALHOST
> IANA
> NIC

this is an amusing list.  i can understand EXAMPLE, LOCALHOST, and TEST.
maybe even WHOIS and WWW.  but the rest sure look as if lawyers wanted
and got what is in effect a super trademark.

randy

---

From: Nicholas Weaver <[email-masked]>
Date: Tue, 9 Dec 2014 09:20:59 -0800

> On Dec 9, 2014, at 9:12 AM, Randy Bush <[email-masked]> wrote:
> 
...
> and got what is in effect a super trademark.

Its also missing one thats actually really important to be reserved: .onion.

--
Nicholas Weaver                  it is a tale, told by an idiot,
[email-masked]                full of sound and fury,
510-666-2903                                 .signifying nothing
PGP: http://www1.icsi.berkeley.edu/~nweaver/data/nweaver_pub.asc

---

From: Christopher Morrow <[email-masked]>
Date: Tue, 9 Dec 2014 12:24:25 -0500

> and got what is in effect a super trademark.

I am shocked that there are lawyers in the naming business. When did
this happen? Who let them in the door/process?

---

From: Jim Reid <[email-masked]>
Date: Tue, 9 Dec 2014 17:36:32 +0000

> and got what is in effect a super trademark.

Who cares? The names were ring-fenced some years ago and no doubt now have long had special powers or magic pixie dust associated with them. Whatever the intentions were at the time these strings were put on a reserved list or who put them there doesn't matter. IMO it's beyond pointless discussing that fact further.

AFAIK this list of reserved names has been in every gTLD contract ICANN issued: Appendix 6 IIRC. Anyone wanting to get that list modified is welcome to use the full weight of ICANN's policy making machinery. Knock yourself out. Feel free to form an orderly queue.

I'm somewhat taken aback Randy that you seem surprised that lawyers have somehow got involved in the business of domain name registrations. :-)

---

From: Randy Bush <[email-masked]>
Date: Wed, 10 Dec 2014 02:42:30 +0900

> Its also missing one thats actually really important to be reserved:

very much agree

randy

---

From: Joe Abley <[email-masked]>
Date: Wed, 10 Dec 2014 11:40:38 -0500

> On 9 Dec 2014, at 12:42, Randy Bush <[email-masked]> wrote:
> 

That one was proposed in the IETF, and sunk in a muddy no-mans-land between the IAB and ICANN of "who defines technical policy? and what the hell is technical policy anyway?".

For a green-fields namespace, given the prevalence of the DNS and the quantitative certainty that queries for other naming systems will leak to the DNS (and leak often), I think it's reasonable advice to suggest not using .ONION and instead use something that is a registered, unique name in the DNS (e.g. ONION.TLD). But that's of little interest to people who have running code depending on an existing namespace that wasn't designed with that in mind.

I think it's fair to say that an application for the ONION TLD in the DNS would fail on technical grounds of disruption to deployed systems though, and the ICANN process accommodates that. I don't think we will ever see HOME or CORP delegated either.

Joe