Subject: [DNSOP] RFC 2181 - reconsiderations

From: manning <[email-masked]>
Date: Mon, 8 Jun 2015 12:11:23 -0700

Morning y’all.    RFC 2181 is a “grab bag” of eight independent items that, 17 years ago, were not considered “large” enough
to warrant dedicated RFCs.   Quoting from the abstract of the RFC:

"Eight separate issues are considered:

     + IP packet header address usage from multi-homed servers,
     + TTLs in sets of records with the same name, class, and type,
     + correct handling of zone cuts,
     + three minor issues concerning SOA records and their use,
     + the precise definition of the Time to Live (TTL)
     + Use of the TC (truncated) header bit
     + the issue of what is an authoritative, or canonical, name,
     + and the issue of what makes a valid DNS label.

   The first six of these are areas where the correct behaviour has been
   somewhat unclear, we seek to rectify that.  The other two are already
   adequately specified, however the specifications seem to be sometimes
   ignored.  We seek to reinforce the existing specifications.”

It has become unwieldy to try and work on any specific item here without an effect on this base document.
There are eight drafts (currently individual submissions), one for each of these eight issues.  I’ve read the 
drafts and they have extracted the RFC2181 text for each specific issue, verbatim and placed each into 
a dedicated document.   This suggests that as a strictly process issue, that the WG could choose to adopt
and fast track these eight IDs to RFC status.   That way work could proceed independently on each of the
issues and RFC 2181 could be moved to Historic status.  

What do you think?   Is there a reason to not do this?

manning
[email-masked]
PO Box 12317
Marina del Rey, CA 90295
310.322.8102

---

From: Jared Mauch <[email-masked]>
Date: Mon, 8 Jun 2015 15:17:43 -0400

> On Jun 8, 2015, at 3:11 PM, manning <[email-masked]> wrote:
> 

DNS implementation details are much cleaner than others (e.g.: BGP) in finding the root documents and all the additive parts.

In other words, I support pushing these out.

- Jared