Subject: [DNSOP] we already have a new version of this problem

From: George Michaelson <[email-masked]>
Date: Thu, 5 Nov 2015 10:11:31 +0900

So can somebody explain to me what we are meant to do with a possible
emerging homenet desire for .home?

https://datatracker.ietf.org/doc/draft-cheshire-homenet-dot-home/

because I believe this isn't just the tail of odd requests from the tor
people for various hash based names.. its another WG inside the IETF
process thinking "oh.. .onion worked, so lets go do one"

-G

---

From: Tim WIcinski <[email-masked]>
Date: Thu, 5 Nov 2015 10:16:19 +0900

I believe the IESG guidance given to us is that no Special Use Domain 
Names will be addressed until the 6761 "scaling issue" has a direction.

On 11/5/15 10:11 AM, George Michaelson wrote:
> because I believe this isn't just the tail of odd requests from the 
> tor people for various hash based names.. its another WG inside the 
> IETF process thinking "oh.. .onion worked, so lets go do one"
>
> -G
>
>
> _______________________________________________
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop

---

From: George Michaelson <[email-masked]>
Date: Thu, 5 Nov 2015 10:19:05 +0900

Which demands pretty direct pushback on the AD and WG chairs, because
otherwise, we're just building a huge queue of pent-up demand for names.
Names we might decide we don't think should happen, or happen a different
way.

If we allow WG adoption in another WG of something which heads into an
active disputed area in here, I think we're making a huge rod for our own
backs. I understand why people want things like .HOME, but I am very unkeen
to have parallel discussions of the social utility of these names, while we
are actively discussing process and external body roles.

So.. cross-WG and AD discussion time? please?

-G

On Thu, Nov 5, 2015 at 10:16 AM, Tim WIcinski <[email-masked]> wrote:

> DNSOP mailing [email-masked]://www.ietf.org/mailman/listinfo/dnsop
>
>
>

---

From: Tim WIcinski <[email-masked]>
Date: Thu, 5 Nov 2015 10:31:48 +0900

The authors of this draft was alerted when -00 was initially submitted 
that this approval needed to pass through DNSOP.

On 11/5/15 10:19 AM, George Michaelson wrote:
> otherwise, we're just building a huge queue of pent-up demand for 
> names. Names we might decide we don't think should happen, or happen a 
> different way.
>
> active disputed area in here, I think we're making a huge rod for our 
> own backs. I understand why people want things like .HOME, but I am 
> very unkeen to have parallel discussions of the social utility of 
> these names, while we are actively discussing process and external 
> body roles.
>
> On Thu, Nov 5, 2015 at 10:16 AM, Tim WIcinski <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     I believe the IESG guidance given to us is that no Special Use
>     Domain Names will be addressed until the 6761 "scaling issue" has
>     a direction.
>
>>     So can somebody explain to me what we are meant to do with a
>>     possible emerging homenet desire for .home?
>>
>>     because I believe this isn't just the tail of odd requests from
>>     the tor people for various hash based names.. its another WG
>>     inside the IETF process thinking "oh.. .onion worked, so lets go
>>     do one"
>>
>>     -G
>>
>>
>>     [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>

---

From: Paul Vixie <[email-masked]>
Date: Wed, 04 Nov 2015 17:25:41 -0800

> Names will be addressed until the 6761 "scaling issue" has a direction.

tellingly, the technologies that will surround "homenet" will also be relevant 
to SOHO and even SMB, not just residential. so, the IESG is showing wisdom 
here. let the scope of the need be known, and let the context of the naming be 
known, before any more defacto allocations occur.

vixie

-- 
P. Vixie

---

From: Tony Finch <[email-masked]>
Date: Thu, 5 Nov 2015 11:26:45 +0000

> https://datatracker.ietf.org/doc/draft-cheshire-homenet-dot-home/

(I can't see any discussion of this draft on the homenet list so I don't
know if this question has been answered...)

Has anyone done a survey of where the leaked .home queries come from?

One big source is the BT Home Hub CPE which uses .home for private names;
there must be millions of these devices out there. (My mail servers leak
queries for these names because they appear in message submission EHLO
commands and my mail servers do EHLO domain verification; the name servers
they use are only configured to sink names required by RFC 6761: invalid,
local, localhost, onion, test.)

Are there other big deployments of similarly configured CPE devices?

Tony.
-- 
f.anthony.n.finch  <[email-masked]>  http://dotat.at/
Viking, North Utsire, South Utsire, Northeast Forties: Southeasterly 5 or 6,
increasing 7 at times. Slight or moderate, occasionally rough. Occasional
rain, fog patches. Moderate or good, occasionally very poor.

---

From: Ray Bellis <[email-masked]>
Date: Thu, 5 Nov 2015 22:24:11 +0900

> https://datatracker.ietf.org/doc/draft-cheshire-homenet-dot-home/

This particular proposal was being discussed long before any of the
.onion et al proposals existed, but didn't get put into draft form until
slightly after.

> process thinking "oh.. .onion worked, so lets go do one"

Without my Homenet co-chair hat on, but as an interested party, my view
is that I'd like to see ".home" formally blocked from registration as a
new TLD [*] by putting it into the "locally served zones" list, and
perhaps sunk to AS112 to catch those queries that aren't caught via
locally served zones.

Ray

[*] AFAICR, ICANN have said that's their plan, but it's also the case
that ICANN plans and policies can change.

---

From: "Wessels, Duane" <[email-masked]>
Date: Fri, 6 Nov 2015 19:32:36 +0000

> On Nov 5, 2015, at 3:26 AM, Tony Finch <[email-masked]> wrote:
> 

In the spirit of Measurement-Driven Protocol Engineering here are some recent data points from root servers:

Over the past 7 days Verisign observed an average of 200,000,000 ".home" queries per day from 120,000 distinct source addresses (per day).  These are queries sent to A-root and J-root.

Based on Geo-IP data we see queries from essentially every known country, with ~70% of total queries coming from the top 10 countries listed below:

US	14.27%
BR	9.69%
ES	9.19%
GB	7.41%
RU	6.60%
CN	6.47%
NL	5.45%
CA	4.85%
DE	2.88%
TW	2.34%

The top 10 queriers average queries per day by AS# are below:

17,522,505	AS15169	Google Inc.
13,810,209	AS12715	Jazz Telecom S.A.
9,419,213	AS5607	Sky UK Limited
9,102,663	AS209	Qwest Communications Company, LLC
8,505,847	AS4134	Chinanet
6,721,443	AS7738	Telemar Norte Leste S.A.
6,206,409	AS2856	BT Public Internet Service
5,752,171	AS31334	Kabel Deutschland Vertrieb und Service GmbH
5,511,280	AS18881	Global Village Telecom
4,898,146	AS577	Bell Canada

Thanks to Matt Thomas of Verisign for pulling these numbers together quickly.

DW

---

From: Tony Finch <[email-masked]>
Date: Mon, 9 Nov 2015 09:49:50 +0000

> recent data points from root servers:

Wow, cool, and totally not what I guessed. Thanks!

Tony.
-- 
f.anthony.n.finch  <[email-masked]>  http://dotat.at/
Trafalgar: Easterly 5 to 7 in southeast, otherwise variable 3 or 4. Moderate,
occasionally rough in southeast. Fair. Moderate or good.

---

From: "Wessels, Duane" <[email-masked]>
Date: Mon, 9 Nov 2015 17:43:04 +0000

> On Nov 6, 2015, at 12:10 PM, Joe Abley <[email-masked]> wrote:
> 
> Hi Duane,
> 
> On 6 Nov 2015, at 14:32, Wessels, Duane wrote:
> 
> It might be interesting to also rank the top ten countries originating any kind of query received at A and J. If that list is the same as the one above, that might help confirm or deny whether this is an effect more prevalent in some places than other, or whether it's just a function of how many people in each country are using the DNS.

Joe,

Here's that data:

US	27.40%
CN	14.86%
BR	6.23%
KR	5.35%
RU	3.61%
TW	3.04%
NL	3.03%
GB	2.50%
DE	2.10%
IT	1.67%

DW

---

From: Tony Finch <[email-masked]>
Date: Tue, 10 Nov 2015 10:49:19 +0000

Wessels, Duane <[email-masked]> wrote:
> 	all	.home
> US	27.40%	14.27%
> CN	14.86%	6.47%
> BR	6.23%	9.69%	<-
> RU	3.61%	6.60%	<-
> TW	3.04%	2.34%
> NL	3.03%	5.45%	<-
> GB	2.50%	7.41% 	<-

So .home queries are disproportionately high in Brazil, Russia, NL, and
(by a factor of three) the UK.

Tony.
-- 
f.anthony.n.finch  <[email-masked]>  http://dotat.at/
Biscay, Southeast Fitzroy: Southwesterly 5 in north, otherwise variable 3 or
4. Moderate or rough. Fog patches in south, occasional drizzle in north.
Moderate or good, occasionally very poor in south.