Subject: Re: [DNSOP] Terry Manderson's Discuss on draft-ietf-dnsop-dnssec-roadblock-avoidance-04: (with DISCUSS and COMMENT)

From: Wes Hardaker <[email-masked]>
Date: Wed, 03 Aug 2016 15:53:08 -0700

Terry Manderson <[email-masked]> writes:

> Hi Spencer,
>
> On 14/07/2016, 12:57 PM, "Spencer Dawkins at IETF"
> <[email-masked]> wrote:
>>
>>Terry, I like where you're headed, but just to ask the obvious question,
>>are you thinking the draft would, or would not, also contain something
>>like "at the time this document was approved, a domain used for this test
>>was $someactualworkingdomain.com <http://someactualworkingdomain.com>"?
>
> Sorry I didn't make it obvious, yes I would like to see text like this,
> and I think it makes an easy path for the less adventurous in addition to
> supplying more in depth guidance.

How does this text work to be dropped into the end of the
"Implementation experiences" section (1.3):

      <section title="Test Zone Implementation">
	      <t>In this document, the "test.example.com" domain is
	      used to refer to DNS records which contain test records
	      that have known DNSSEC properties associated with them.
	      For example, the "badsign-a.test.example.com" domain is
	      used below to refer to a DNS A record where the
	      signatures published for it are invalid (i.e., they are
	      "bad signatures" that should cause a validation
	      failure).</t>

	      <t>At the time of this publication, the
	      "test.dnssec-tools.org" domain implements all of these
	      test records.  Thus, it may be possible to replace
	      "test.example.com" in this document with
	      "test.dnssec-tools.org" when performing real-world
	      tests.</t>
      </section>

And then everywhere that test.dnssec-tools.org exists in the document,
I'll replace it with "test.example.com".
-- 
Wes Hardaker
Parsons

---

From: Terry Manderson <[email-masked]>
Date: Thu, 4 Aug 2016 04:19:00 +0000

That works for me.

Cheers
Terry