Subject: [DNSOP] my chromecast ultra would not start until i began answering 8.8.8.8

From: Paul Vixie <[email-masked]>
Date: Wed, 13 Feb 2019 12:22:51 -0800

google, this is bogus as hell. my dhcp server gives you dns servers to 
use. please don't make me route and answer 8.8.8.8 just to watch youtube.

> [71] 2019-02-13 16:39:40.548137 [#68 vtnet0 4095] \
>         [24.104.150.186].56915 [8.8.8.8].53  \
>         dns QUERY,NOERROR,7357,rd \
>         1 lh3.googleusercontent.com,IN,A 0 0 0
> [71] 2019-02-13 16:39:40.548210 [#69 vtnet0 4095] \
>         [24.104.150.186].56915 [8.8.8.8].53  \
>         dns QUERY,NOERROR,49247,rd \
>         1 lh3.googleusercontent.com,IN,AAAA 0 0 0

(no, this device i've paid for, will NOT be allowed to send you any 
information, other than what i personally approve, which will never 
include DNS traffic. if you don't like that deal, buy it back from me 
and i'll find some other video appliance that doesn't twist my arm.)

-- 
P Vixie

---

From: Robert Edmonds <[email-masked]>
Date: Wed, 13 Feb 2019 15:39:36 -0500

Paul Vixie wrote:
> google, this is bogus as hell. my dhcp server gives you dns servers to use.
> please don't make me route and answer 8.8.8.8 just to watch youtube.
> 
> information, other than what i personally approve, which will never include
> DNS traffic. if you don't like that deal, buy it back from me and i'll find
> some other video appliance that doesn't twist my arm.)

Are you looking for https://support.google.com/chromecast/contactflow ?

-- 
Robert Edmonds

---

From: Paul Vixie <[email-masked]>
Date: Wed, 13 Feb 2019 13:14:39 -0800

> Are you looking for https://support.google.com/chromecast/contactflow ?

no. they know exactly what they're doing, and it's not an accident. 
reporting it to their support team will waste their time and mine.

however, i don't know yet whether they're ready to own their sh*t in 
public, or whether they'll enjoy being named and shamed. so, here i am.

-- 
P Vixie

---

From: Jared Mauch <[email-masked]>
Date: Wed, 13 Feb 2019 16:16:40 -0500

> On Feb 13, 2019, at 4:14 PM, Paul Vixie <[email-masked]> wrote:
> 
> no. they know exactly what they're doing, and it's not an accident. reporting it to their support team will waste their time and mine.
> 
> however, i don't know yet whether they're ready to own their sh*t in public, or whether they'll enjoy being named and shamed. so, here i am.

And ours as well.

- Jared