Subject: [DNSOP] inputs on NAT64/464XLAT Deployment Guidelines in Operator and Enterprise Networks draft-ietf-v6ops-nat64-deployment

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Thu, 21 Feb 2019 14:58:36 +0900

Hi all,

(dnsop copied because DNS64)

I'm working in a new version of this document.

Link to the document:

https://datatracker.ietf.org/doc/draft-ietf-v6ops-nat64-deployment/

It will be great if we can get some new inputs.

Thanks!

Regards,
Jordi

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.theipv6company.com
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.

---

From: Alejandro D'Egidio <[email-masked]>
Date: Mon, 25 Feb 2019 12:22:54 -0300 (ART)

Hello Jordi,
I like 464XLAT and this is something I would like to implement in DOCSIS networks.
As Deployment Guidelines maybe you can include/consider the next case, if not please forget it or we can include it on another document.

Today we still have many devices that don't support IPv6 or some applications on it don't support it, this is the case of SMART TVs and set top boxes.
There is a common scenario where big public CDNs support deliver content to private IPv4 destinations (usually CGN prefixes) directly without going through a CGN.
In that scenario, CPEs (with eRouter) that have IPv4 of CGN (ie 100.64.x.x) can connect receive traffic from CDNs directly without having any CGN in the middle.

So I see three points in this case:
1- Traffic avoids a point of failure (CGN), obviously it should be redundant but the point of failure exists.
2- Traffic is more "transparent" avoiding another translation for CDN.
3- This traffic doesn't impact in CGN sizing.

As I said, I like 464XLAT and I would like to have a IPv6-Only access network but this is a real case where ISPs can consider to continue provisioning IPv4 to customers.

Regards,
Alejandro

----- Mensaje original -----
De: "JORDI PALET MARTINEZ" <jordi.palet=[email-masked]>
Para: "[email-masked] list" <[email-masked]>, "dnsop" <[email-masked]>
Enviados: Jueves, 21 de Febrero 2019 2:58:36
Asunto: [v6ops] inputs on NAT64/464XLAT Deployment Guidelines in Operator and Enterprise Networks draft-ietf-v6ops-nat64-deployment

Hi all,

Link to the document:

Thanks!

Regards,
Jordi

_______________________________________________
v6ops mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/v6ops