Subject: [DNSOP] Call for Adoption: draft-wessels-dns-zone-digest

From: Tim Wicinski <[email-masked]>
Date: Sun, 10 Mar 2019 10:31:15 -0400

The chairs feel the document has been updated to address
several issues raised from the last meeting, including
some implementations.

If there is pushback during this call for adoption, we can
take the topic up in Prague.

This starts a Call for Adoption for draft-wessels-dns-zone-digest

The draft is available here:
https://datatracker.ietf.org/doc/draft-wessels-dns-zone-digest/

Please review this draft to see if you think it is suitable for adoption by
DNSOP, and comments to the list, clearly stating your view.

Please also indicate if you are willing to contribute text, review, etc.

This call for adoption ends: 24 March 2019

Thanks,
tim wicinski
DNSOP co-chair

---

From: "A. Schulze" <[email-masked]>
Date: Mon, 11 Mar 2019 18:06:09 +0100

Am 10.03.19 um 15:31 schrieb Tim Wicinski:
> Please review this draft to see if you think it is suitable for adoption by DNSOP, and comments to the list, clearly stating your view.

Hello,

The document itself is written clearly.
As a user of the mentioned LDNS implementation I find it useful to be able to verify a zone file as it is :-)

Andreas

---

From: Shumon Huque <[email-masked]>
Date: Sun, 24 Mar 2019 00:02:45 +0100

On Sun, Mar 10, 2019 at 3:32 PM Tim Wicinski <[email-masked]> wrote:

> Please review this draft to see if you think it is suitable for adoption
> by DNSOP, and comments to the list, clearly stating your view.
>

I support adoption.

> Please also indicate if you are willing to contribute text, review, etc.

Yes (and I have previously reviewed this draft on this list a number of
times).

Shumon.

---

From: Olli Vanhoja <[email-masked]>
Date: Sun, 24 Mar 2019 01:04:50 +0100

I support adoption. I can see some good use cases for this and I have
previously worked on a proprietary implementation achieving similar goals
to those that are mentioned in the draft.

On Sun, Mar 10, 2019 at 3:32 PM Tim Wicinski <[email-masked]> wrote:

> _______________________________________________
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop
>

---

From: George Michaelson <[email-masked]>
Date: Sun, 24 Mar 2019 06:31:25 +0100

Support adoption. This is a mechanism which I think is useful and
which permits out-of-dns provisioning mechanisms to have high trust in
the specific state of a zone being fetched. It is complementary to
DNSSEC and not antagonistic.

-George

On Sun, Mar 10, 2019 at 3:31 PM Tim Wicinski <[email-masked]> wrote:
> The draft is available here: https://datatracker.ietf.org/doc/draft-wessels-dns-zone-digest/
>

---

From: Joe Abley <[email-masked]>
Date: Sun, 24 Mar 2019 01:44:33 -0700

Hi Tim,

> Please review this draft to see if you think it is suitable for adoption by DNSOP, and comments to the list, clearly stating your view.

I support adoption of this draft by dnsop.

> Please also indicate if you are willing to contribute text, review, etc.

I am willing to do all of those things.

> This call for adoption ends: 24 March 2019

Joe

---

From: Brian Dickson <[email-masked]>
Date: Sun, 24 Mar 2019 03:27:30 -0700

> by DNSOP, and comments to the list, clearly stating your view.
I am in favor of adoption of this draft by DNSOP WG.

> Please also indicate if you are willing to contribute text, review, etc.

I am willing to review and contribute text.

Brian Dickson

---

From: Paul Wouters <[email-masked]>
Date: Sun, 24 Mar 2019 14:21:29 +0100

I support adoption and note that since the draft already has an early code point allocation there really isn’t any strong argument for not adopting it anymore. The code point is lost, so we might as well make it as good as possible :)

Sent from mobile device

---

From: Matthew Pounsett <[email-masked]>
Date: Sun, 24 Mar 2019 22:30:21 +0100

> This starts a Call for Adoption for draft-wessels-dns-zone-digest

I believe DNSOP should adopt this draft.

---

From: Willem Toorop <[email-masked]>
Date: Tue, 26 Mar 2019 09:50:10 +0100

I support adoption too and have (the version in this draft) of ZONEMD
provisioned already in the net-dns.org. zone.
Dick Franks worked on a ZONEMD verifier for Net::DNS during the
Hackathon last Saturday/Sunday (remotely).

---

From: Dick Franks <[email-masked]>
Date: Thu, 28 Mar 2019 12:04:40 +0000

Assuming that the draft is adopted, I am willing to work on it and
contribute new text.

Dick
________________________

---

From: Tim Wicinski <[email-masked]>
Date: Sat, 30 Mar 2019 07:47:30 +0100

The Meeting has concluded, and there has been sufficient positive consensus
to adopt this draft into DNSOP..
Authors, you are free to upload the newer draft name.

Thanks to all for their comments and offers to review. We will hold each
and every one of you to these offers.

Tim