Subject: [DNSOP] Proposal for a side-meeting on services centralization at IETF 104 Prague

From: Stephane Bortzmeyer <[email-masked]>
Date: Mon, 11 Mar 2019 17:58:13 +0100

[Sorry for the long list of working groups but the discussion already
started in different places.]

There are been some discussion about DoH (DNS-over-HTTPS, RFC 8484)
deployment and the risk of centralization of Internet services. (See
for instance drafts [this is not an endorsement]
draft-bertola-bcp-doh-clients, draft-reid-doh-operator and
draft-livingood-doh-implementation-risks-issues.)

It was suggested <wikipedia>Reference necessary</wikipedia> to have a
side meeting in Prague at IETF 104. I propose monday, 1400-1600 in
Tyrolka. The proposal is at
<https://trac.ietf.org/trac/ietf/meeting/wiki/104sidemeetings>. You
are welcome to agree/disagree/meet in a bar instead.

---

From: Ted Hardie <[email-masked]>
Date: Mon, 11 Mar 2019 10:06:21 -0700

Hi Stephane,

This conflicts with SECDISPATCH, which will have a pretty serious impact on
who might attend.  Scheduling these things is very hard, obviously. Given
this topic, you may have to move outside the normal agenda time to get a
reasonable shot at avoiding conflict.

Ted

On Mon, Mar 11, 2019 at 9:58 AM Stephane Bortzmeyer <[email-masked]>
wrote:

> _______________________________________________
> Doh mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/doh
>

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Mon, 11 Mar 2019 18:13:38 +0100

On Mon, Mar 11, 2019 at 10:06:21AM -0700,
 Ted Hardie <[email-masked]> wrote 

> reasonable shot at avoiding conflict.

I avoided conflicts with doh, dprive, dnsop and hrpc but avoiding all
conflicts is close-to-impossible. In the evening, people have
meetings, too.

I admit I'm not sure that Secdispatch is so important here. The
subject of the side meeting is not security-specific.

---

From: Ted Hardie <[email-masked]>
Date: Mon, 11 Mar 2019 10:18:21 -0700

> subject of the side meeting is not security-specific.

It is certainly not only about security, but there are several important
security trade-offs in play with these choices.  Secdispatch pulls pretty
much the entire Security Area, and a conflict seems to me personally very
unfortunate in its scope.

regards,

Ted

---

From: Melinda Shore <[email-masked]>
Date: Mon, 11 Mar 2019 11:22:05 -0600

> subject of the side meeting is not security-specific.

It also conflicts with irtfopen, which may impact the
availability of pearg people, hrpc folk, etc.

Melinda

-- 
Software longa, hardware brevis

PGP key fingerprint  4F68 2D93 2A17 96F8 20F2
                     34C0 DFB8 9172 9A76 DB8F

---

From: Allison Mankin <[email-masked]>
Date: Mon, 11 Mar 2019 13:32:20 -0400

I'd appreciate it not conflicting with IRTFOPEN.  The ANRP topics include
how Facebook manipulates routing and a big study on QUIC, and I think there
should be participant overlap.

On Mon, 11 Mar 2019 at 13:22, Melinda Shore <[email-masked]>
wrote:

> dns-privacy mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dns-privacy
>

---

From: Warren Kumari <[email-masked]>
Date: Tue, 12 Mar 2019 15:45:24 +0900

On Tue, Mar 12, 2019 at 1:58 AM Stephane Bortzmeyer <[email-masked]>
wrote:

> deployment and the risk of centralization of Internet services.

(See
> are welcome to agree/disagree/meet in a bar instead.

[ Replying here instead of bottom of thread ]

Thank you for proposing / organizing this - there has been a lot of
discussions, but (as demonstrated by the list of WGs in the To: line) it is
somewhat unclear where the discussions should happen -- I'm planning on
asking the secretariat to please make us a mailing list to better focus the
discussions -- does anyone have a strong objection to this?

(also, a good suggestion for a name would be helpful :-))

W

-- 
I don't think the execution is relevant when it was obviously a bad idea in
the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair of
pants.
   ---maf

---

From: Eliot Lear <[email-masked]>
Date: Tue, 12 Mar 2019 08:19:37 +0100

Warren,

I would suggest that you wait on creating a new list.

I think Stephane was proposing an *in person* meeting, using the 104sidemeetings Wiki, and I’d like to see that happen first.  That also gives time for the dust from the release of these new drafts to settle a bit, so that the contours of what can be reasonably accomplished becomes more clear.

Eliot

> On 12 Mar 2019, at 07:45, Warren Kumari <[email-masked]> wrote:
> 
> 
> On Tue, Mar 12, 2019 at 1:58 AM Stephane Bortzmeyer <[email-masked] <mailto:[email-masked]>> wrote:
> <https://trac.ietf.org/trac/ietf/meeting/wiki/104sidemeetings <https://trac.ietf.org/trac/ietf/meeting/wiki/104sidemeetings>>. You
> Thank you for proposing / organizing this - there has been a lot of discussions, but (as demonstrated by the list of WGs in the To: line) it is somewhat unclear where the discussions should happen -- I'm planning on asking the secretariat to please make us a mailing list to better focus the discussions -- does anyone have a strong objection to this?
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/doh <https://www.ietf.org/mailman/listinfo/doh>
> 
> 
> --
> I don't think the execution is relevant when it was obviously a bad idea in the first place.
> This is like putting rabid weasels in your pants, and later expressing regret at having chosen those particular rabid weasels and that pair of pants.
>    ---maf
> hrpc mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/hrpc

---

From: Töma Gavrichenkov <[email-masked]>
Date: Tue, 12 Mar 2019 12:05:12 +0300

On Tue, Mar 12, 2019 at 9:46 AM Warren Kumari <[email-masked]> wrote:
> also, a good suggestion for a name would be helpful :-)

That is, aside from "scent" which is as obvious, as it is weird?

--
Töma

---

From: Amelia Andersdotter <[email-masked]>
Date: Thu, 14 Mar 2019 05:31:31 +0100

Dear all,

+1 on Eliot and thank you Stephane. My deepest appreciation for Tömas
suggestion that really made my evening.

An in-person meeting might be conducive to fleshing out a topic for this
meeting, but at least to me "services centralization" rings like it
might also concern detnet, quic and perhaps other groups that I cannot
immediately think of.

Probably we mean "DNS service centralization"?

best regards,

Amelia

On 2019-03-12 08:19, Eliot Lear wrote:
> I think Stephane was proposing an *in person* meeting, using the
> 104sidemeetings Wiki, and I’d like to see that happen first.  That
> also gives time for the dust from the release of these new drafts to
> settle a bit, so that the contours of what can be reasonably
> accomplished becomes more clear.
>
> Eliot
>
>
>> On 12 Mar 2019, at 07:45, Warren Kumari <[email-masked]
>> <mailto:[email-masked]>> wrote:
>>
>>
>> On Tue, Mar 12, 2019 at 1:58 AM Stephane Bortzmeyer
>> <[email-masked] <mailto:[email-masked]>> wrote:
>>
>> discussions, but (as demonstrated by the list of WGs in the To: line)
>> it is somewhat unclear where the discussions should happen -- I'm
>> planning on asking the secretariat to please make us a mailing list
>> to better focus the discussions -- does anyone have a strong
>> objection to this? 
>>
>> This is like putting rabid weasels in your pants, and later
>> expressing regret at having chosen those particular rabid weasels and
>> that pair of pants.
>>    ---maf
>> [email-masked] <mailto:[email-masked]>

-- 
Amelia Andersdotter
Technical Consultant, Digital Programme

ARTICLE19
www.article19.org

PGP: 3D5D B6CA B852 B988 055A 6A6F FEF1 C294 B4E8 0B55

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Wed, 20 Mar 2019 08:29:21 +0100

On Mon, Mar 11, 2019 at 05:58:13PM +0100,
 Stephane Bortzmeyer <[email-masked]> wrote 

> started in different places.]
...
> It was suggested to have a side meeting in Prague at IETF 104. I
> propose monday, 1400-1600 in Tyrolka. The proposal is at

I modified the title of the meeting
<https://trac.ietf.org/trac/ietf/meeting/wiki/104sidemeetings> because
there is obviously no consensus on the problem or on the
agenda. Anyway, a room is reserved if people want to meet on
wednesday.

---

From: Vittorio Bertola <[email-masked]>
Date: Thu, 21 Mar 2019 09:09:46 +0100 (CET)

> Il 20 marzo 2019 alle 8.29 Stephane Bortzmeyer <[email-masked]> ha scritto:
> 

Given that this is not going to happen in the doh session on Tuesday, perhaps the meeting on Wednesday could start with the presentation of the three drafts. If the meeting on Tuesday gets to some preliminary ideas on work to do, we could then work out some plans among those that want to contribute.

Regards,
-- 

Vittorio Bertola | Head of Policy & Innovation, Open-Xchange
[email-masked]
Office @ Via Treviso 12, 10144 Torino, Italy

---

From: "Livingood, Jason" <[email-masked]>
Date: Thu, 21 Mar 2019 15:13:37 +0000

Last week I did a draft agenda at https://github.com/jlivingood/IETF-104-SideMtg/blob/master/draft-agenda.txt but to some extent large parts may have been overcome by events and need major changes. Maybe it is sufficient to have the various drafts presented and let discussion flow from that? It could be helpful to have an IAB or IESG member as a moderator of sorts to facilitate.

Please suggests changes (or better still, do so via GitHib) - and note this is not a binding agenda - just a suggestion for one to try to help bring together an interesting discussion.

JL

    
    
    Regards,
    -- 

    _______________________________________________
    DNSOP mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/dnsop

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Wed, 27 Mar 2019 18:48:55 +0100

On Wed, Mar 20, 2019 at 08:29:21AM +0100,
 Stephane Bortzmeyer <[email-masked]> wrote 
 a message of 22 lines which said:

> <https://trac.ietf.org/trac/ietf/meeting/wiki/104sidemeetings>
> because there is obviously no consensus on the problem or on the

I swear this is the last time I send an email to the four mailing
lists together. One of the goals of the side meeting was precisely to
discuss the proper venue.

The side meeting had around 100 participants (room was full), and
lasted 1.75 hours. Shane Kerr was nice enough to take notes, they are
attached here. Also, I send the two set of slides that were shown at
the beginning of the meeting.