Subject: Re: [DNSOP] Adding more example configurations to draft-ietf-dnsop-7706bis

From: Wes Hardaker <[email-masked]>
Date: Fri, 01 Mar 2019 22:17:56 -0800

Michał Kępień <[email-masked]> writes:

>     zone "." {
>         type mirror;
>     };

Cool feature, and thanks for adding it.  It'll certainly make writing
LocalRoot config updates easier.

Questions though:

1) In this state, does it accept notifications for triggering zone
refreshing (which is one of the features in LocalRoot)

2) How does it know where to mirror from?  IE, many NS don't respond to
AXFR (only ~half do in the root zone).  Is it just trying to pester them all?
-- 
Wes Hardaker
USC/ISI

---

From: Joe Abley <[email-masked]>
Date: Sat, 2 Mar 2019 09:59:12 -0500

> LocalRoot config updates easier.

https://ftp.isc.org/isc/bind9/cur/9.13/doc/arm/Bv9ARM.ch05.html#zone_statement_grammar

The zone grammar specifies an allow-notify stanza for zone/type mirror:

> zone string [ class ] {
> 	type mirror;
> 	allow-notify { address_match_element; ... };

Zones can be transferred from an explicit set of transfer masters, but there is also a default:

> A default list of primary servers for the IANA root zone is built into named and thus its mirroring can be enabled using the following configuration:
> 
> zone "." {
>         type mirror;
> };
> 
> In order to set up mirroring of any other zone, an explicit list of primary servers needs to be provided using the masters option (see the section called “masters Statement Grammar” for details).

Joe