Subject: [DNSOP] Call for Adoption: draft-nygren-dnsop-svcb-httpssvc

From: Tim Wicinski <[email-masked]>
Date: Mon, 7 Oct 2019 10:37:03 -0400

All

We want to thank the authors for working on this.  The chairs
feel that part of the discussion around this document would be to
resolve:
  - ANAME/HTTPSSVC possible overlaps
  - The RR Type Name (no one seems to be in love with current names)

This starts a Call for Adoption for draft-nygren-dnsop-svcb-httpssvc

The draft is available here:
https://datatracker.ietf.org/doc/draft-nygren-dnsop-svcb-httpssvc/

Please review this draft to see if you think it is suitable for adoption
by DNSOP, and comments to the list, clearly stating your view.

Please also indicate if you are willing to contribute text, review, etc.

This call for adoption ends: 21 October 2019

Thanks,
tim wicinski
DNSOP co-chair

---

From: Stephen Farrell <[email-masked]>
Date: Mon, 7 Oct 2019 15:52:04 +0100

Hiya,

> Please also indicate if you are willing to contribute text, review, etc.

I support adoption. If it looks like it'll be accepted
by browsers for ESNI purposes, then I'll be implementing
too.

If the WG do adopt this, then we really have to sort out
(with the TLS WG) whether or not this will be the one
and only way of publishing ESNIKeys. I hope the answer
will be: "yes, this is *the* way to do that" but that'd
mean we'd also need to get it right for other uses of TLS
with ESNI and not just HTTPS. (Should be doable though.)

The main caveat for me is I don't know if it'd be worth
publishing an RFC if this doesn't end up getting deployed
in browsers. So getting clarity there as early as poss
would be good if we can.

Cheers,
S.

> _______________________________________________
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop
>

---

From: Vladimír Čunát <[email-masked]>
Date: Mon, 7 Oct 2019 17:34:07 +0200

Hello; I do support adoption.

> in browsers. So getting clarity there as early as poss

I agree, but I wouldn't block *adoption* on that.  The "browsers" 
(client implementers) may have some comments on the contents of the text 
etc. and it seems much better to have one particular WG (and text) to 
discuss.  My understanding is that the authors had discussed with 
(some?) major implementers and they seemed inclined to like the 
approach.  (I heard that on some recent IETF presentations of HTTPSSVC 
plans, IIRC.)

--Vladimir

---

From: Loganaden Velvindron <[email-masked]>
Date: Mon, 7 Oct 2019 19:40:44 +0400

On Mon, Oct 7, 2019 at 6:37 PM Tim Wicinski <[email-masked]> wrote:
> The draft is available here: https://datatracker.ietf.org/doc/draft-nygren-dnsop-svcb-httpssvc/
>
I support adoption of this document.

---

From: Tommy Pauly <[email-masked]>
Date: Mon, 07 Oct 2019 08:50:33 -0700

I support adoption of this document—although I agree that the names do need some bike shedding if/when it is adopted! This is a good mechanism to use for ESNI keys and Alt-Svc. I also think that the extensibility it provides is important property (for example, I am proposing to use it for designating encrypted DNS servers in https://tools.ietf.org/html/draft-pauly-dprive-adaptive-dns-privacy). 

I am also willing to contribute text and review the document.

Thanks,
Tommy

> On Oct 7, 2019, at 7:37 AM, Tim Wicinski <[email-masked]> wrote:
> 
> 
> All
> 
> The draft is available here: https://datatracker.ietf.org/doc/draft-nygren-dnsop-svcb-httpssvc/ <https://datatracker.ietf.org/doc/draft-nygren-dnsop-svcb-httpssvc/>
>

---

From: Ted Lemon <[email-masked]>
Date: Mon, 7 Oct 2019 10:51:06 -0500

> by DNSOP, and comments to the list, clearly stating your view.

I think this is important work, and support adoption.

---

From: Joe Abley <[email-masked]>
Date: Mon, 7 Oct 2019 13:06:33 -0400

> Please also indicate if you are willing to contribute text, review, etc.

I am willing to contribute text, review, etc.

> This call for adoption ends: 21 October 2019

Joe

---

From: "Christopher Wood" <[email-masked]>
Date: Mon, 07 Oct 2019 10:20:13 -0700

> Please also indicate if you are willing to contribute text, review, etc.

I have reviewed the document and think it should be adopted. It addresses several shortcomings of the currently specified ESNI record. I'm also willing to review it again as we go forward. 

Thanks to the authors for their work!

Best,
Chris

---

From: "John Levine" <[email-masked]>
Date: 7 Oct 2019 13:45:57 -0400

>Please also indicate if you are willing to contribute text, review, etc.

I think we should adopt and will review, but I would also like some
indication from browser makers that they're interested so we're not
wasting our time.

---

From: Tim Wicinski <[email-masked]>
Date: Mon, 7 Oct 2019 14:02:16 -0400

John

I believe the browser vendors have made such an agreement. We should get
confirmation.

Stephen

I agree with you on solving the larger ESNI problem. The chairs will put
that on our list for the authors.

Thanks

---

From: Tim Wicinski <[email-masked]>
Date: Mon, 7 Oct 2019 14:02:59 -0400

Also, for folks who supported adoption in the other thread, we're counting
them.

Tim

---

From: "John R Levine" <[email-masked]>
Date: 7 Oct 2019 14:15:05 -0400

> I believe the browser vendors have made such an agreement. We should get

That's about 2/3 of it, but I hope they stay engaged to avoid an outcome 
where we make changes that seem OK to us and they come back at the end and 
say no, we're not going to do THAT.

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
Please consider the environment before reading this e-mail. https://jl.ly

---

From: Eric Orth <[email-masked]>
Date: Mon, 7 Oct 2019 14:34:46 -0400

On behalf of Chrome DNS, I support adoption and plan to stay engaged on
this.  While I don't think the draft is perfect yet, we like the general
approach and are interested in exploring it further.

---

From: Tim Wicinski <[email-masked]>
Date: Sun, 20 Oct 2019 19:01:13 -0400

All

The call for adoption period has drawn to a close, and there was strong
consensus to adopt this document
and begin working on the details.  The chairs look forward to working on
this document in the near future

Tim