Subject: Re: [DNSOP] SVCB wire format (draft-ietf-dnsop-svcb-httpssvc-01)

From: Ben Schwartz <[email-masked]>
Date: Thu, 2 Jan 2020 13:09:10 -0500

Hi Miek,

The wire format is the same for AliasForm and ServiceForm, exactly as you
describe.  What do you think is different?

Note that the wire format is definitely not yet final.  For example,
there's still some active discussion about precisely how to represent the
contents of the SvcFieldValue (in ServiceForm).

On Sun, Dec 29, 2019 at 4:18 AM Miek Gieben <[email-masked]> wrote:

> Hello,
>
> I'm looking into implementing the SVCB RR, and I'm wondering about the
> rational
> to make the wire format different between AliasForm and ServiceForm?
>
> Wouldn't it be simpler to always use the ServiceForm's wire format, but
> have a
> zero key and zero value? I.e. 0 0, these MUST then be ignored for the
> presentation format (handwaving the actual text for the draft here a bit).
>
> /Miek
>
> --
> Miek Gieben
>
> _______________________________________________
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop
>

---

From: Miek Gieben <[email-masked]>
Date: Fri, 3 Jan 2020 08:46:44 +0100

[ Quoting <bemasc=40google.com@dmarc> in "Re: [DNSOP] SVCB wire format (draft..." ]
>describe.  What do you think is different?

Because of this text:

  o the SvcFieldValue byte string, consuming the remainder of the
    record (so smaller than 65535 octets and constrained by the RDATA
    and DNS message sizes).

vs:

   o  a 2 octet field containing the SvcParamKey as an integer in
      network byte order.

   o  a 2 octet field containing the length of the SvcParamValue as an
      integer between 0 and 65535 in network byte order (but constrained
      by the RDATA and DNS message sizes).

   o  an octet string of the length defined by the previous field.

My reading of this is that for ServiceForm there will always be 4 octets and for AliasForm
it may just be empty.

>contents of the SvcFieldValue (in ServiceForm).

What's the reason behind not reusing the TXT record? To free-form? Other issues?

/Miek

--
Miek Gieben

---

From: Mark Andrews <[email-masked]>
Date: Fri, 3 Jan 2020 19:20:05 +1100

There are 0 or more sub TLV fields. 

-- 
Mark Andrews

> On 3 Jan 2020, at 18:47, Miek Gieben <[email-masked]> wrote:
>

---

From: Miek Gieben <[email-masked]>
Date: Wed, 8 Jan 2020 09:52:30 +0100

[ Quoting <[email-masked]> in "Re: [DNSOP] SVCB wire format (draft..." ]
>There are 0 or more sub TLV fields.

so, there equal when not specified and then diverge? I think the draft can be more clear
in this regard. And maybe some text on why the TXT encoding wasn't choosen as that seemed
to worked for SPF.