Subject: Re: [DNSOP] I-D Action: draft-ietf-dnsop-iana-class-type-yang-00.txt

From: Normen Kowalewski <[email-masked]>
Date: Thu, 16 Jan 2020 10:01:14 +0100

Dear WG, Ladislav, Paul,

after the reworked draft seems to address the main point that Paul had raised (Thanks for the work to Lada and Petr), I’d propose to positively revisit WG adoption, and fix remaining details as part of working on it?

BR, Normen Kowalewski

> On 17. Dec 2019, at 17:34, Ladislav Lhotka <[email-masked]> wrote:
> 
> On Tue, 2019-12-17 at 11:06 -0500, Paul Wouters wrote:
>> On Tue, 17 Dec 2019, Ladislav Lhotka wrote:
>> 
>>> this draft replaces draft-lhotka-dnsop-iana-class-type-yang-02.
>> 
>> Although it seems to have no defined that yet in the datatracker. I
>> think you can still do it afterwards.
> 
> I tried to enter it in the submission form, but the system couldn't find the
> individual draft, I don't know why. May I ask our friendly chairs for help?
> 
>> 
>>> We addressed the previous concerns in that the initial revision of the YANG
>>> module is no more included in the document. Instead, the document contains
>>> an
>>> XSLT 1.0 stysheet that IANA is expected to use for generating the YANG
>>> module
>>> directly from the DNS Parameters registry.
>> 
>> This is excellent! Thank you very much for doing this. It prevents
>> outdated enumeration in RFCs and links to the IANA registries properly
>> and can be used as another example of how to do this properly for other
>> IANA registries.
> 
> Right. And even if somebody happens to use the stylesheet again in the future,
> the result should still correspond to the most recent update of the registry -
> except that the revision history won't be present. 
> 
>> 
>> Some nits:
>> 
>> 	This document is a first step in translating DNS-related IANA registries
>> to YANG.
>> 
>> If this is only a "first step", what is the second step? That is what is
>> missing here and why is it missing?
> 
> There is a bunch of other registries on the DNS Parameters page, and more are
> elsewhere, such as Domain Name System Security (DNSSEC) Algorithm Numbers.
> 
> We would appreciate advice from the DNSOP WG regarding what to do next. For some
> registries the conversion to YANG probably makes no sense at all.
> 
>> 
>> 	The other type, "rr-type-name", is exactly analogical.
>> 
>> I'm not sure if "analogical" is a common word to use and might be a bit
>> confusing to non-native speakers like me. I'm also confused about
>> "exactly analogical". What would inexactly analogical be? :)
> 
> Being another non-native speaker, I am open to suggestions.
> 
>> 
>> 
>> and "AAAA" type as "TYPE28" -> and the "AAAA" type can be written as "TYPE28"
>> 
>> they can be used only via their decimal codes -> these can only be specified
>> in their decimal values
> 
> OK, noted.
> 
> Thanks, Ladislav
> 
>> 
>> Paul
> -- 
> Ladislav Lhotka
> Head, CZ.NIC Labs
> PGP Key ID: 0xB8F92B08A9F76C67
> 
> _______________________________________________
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop

---

From: Normen Kowalewski <[email-masked]>
Date: Thu, 16 Jan 2020 10:31:48 +0100

Paul, Lada,

On the comment for the wording in the line after the example in  3 <https://datatracker.ietf.org/doc/html/draft-ietf-dnsop-iana-class-type-yang-00#section-3>. YANG Design Considerations
     typedef dns-class-name {
       type enumeration {
         enum IN {
           value 1;
           description
             "Internet (IN)";
           reference
             "RFC 1035 <https://datatracker.ietf.org/doc/html/rfc1035>";
         }
         ...
       }
     }

Maybe we could use the wording 

   The definitions for the other basic type, "rr-type-name” are derived in analogy to this structure, except that the IANA registry "Resource Record (RR) TYPEs” is the respective underlying data source.

BR, Normen

> Being another non-native speaker, I am open to suggestions

---

From: Bob Harold <[email-masked]>
Date: Thu, 16 Jan 2020 09:57:45 -0500

On Thu, Jan 16, 2020 at 4:32 AM Normen Kowalewski <[email-masked]>
wrote:

> Paul, Lada,
>
>
> On the comment for the wording in the line after the example in  3
> <https://datatracker.ietf.org/doc/html/draft-ietf-dnsop-iana-class-type-yang-00#section-3>.
> YANG Design Considerations
>
>      typedef dns-class-name {
>        type enumeration {
>          enum IN {
>            value 1;
>            description
>              "Internet (IN)";
>            reference
"analogous" is a more common form of the word, and could be used.  Or a
synonym like "parallel" or "similarly".

-- 
Bob Harold