Subject: [DNSOP] using type65 for https with a non-default port

From: Stephen Farrell <[email-masked]>
Date: Sat, 3 Apr 2021 17:54:36 +0100

Hiya,

I had a quick look at the draft I'm not sure if I know
for sure what qname/qtype is supposed to be used for
e.g. https://foo.eample.com:8410/ - can anyone say off
the top of their head?

The options I can imagine are:

qname: foo.example.com, qytpe: type65
qname: _8410._https.foo.example.com, qytpe: type64

I guess some other combos might also exist but I'm not
quite sure which to query nor which to publish.

Thanks,
S.

---

From: Ben Schwartz <[email-masked]>
Date: Sat, 3 Apr 2021 13:07:45 -0400

It's supposed to be _8410._https.foo.example.com, qtype=65

On Sat, Apr 3, 2021 at 12:55 PM Stephen Farrell <[email-masked]>
wrote:

> _______________________________________________
> DNSOP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnsop
>

---

From: Stephen Farrell <[email-masked]>
Date: Sat, 3 Apr 2021 19:44:40 +0100

> It's supposed to be _8410._https.foo.example.com, qtype=65

Thanks. That'd work for me. Probably no harm to add an
example or explicit statement to that effect.

Cheers,
S.

---

From: Ben Schwartz <[email-masked]>
Date: Tue, 6 Apr 2021 16:00:55 -0400

Here's a proposal to add an example as you suggest:
https://github.com/MikeBishop/dns-alt-svc/pull/311/files

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 6 Apr 2021 21:18:02 +0100

Hiya,

> https://github.com/MikeBishop/dns-alt-svc/pull/311/files

LGTM, thanks,
S.