Subject: [DNSOP] Roman Danyliw's No Objection on draft-ietf-dnsop-iana-class-type-yang-03: (with COMMENT)

From: Roman Danyliw via Datatracker <[email-masked]>
Date: Wed, 02 Jun 2021 11:39:52 -0700

Roman Danyliw has entered the following ballot position for
draft-ietf-dnsop-iana-class-type-yang-03: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-dnsop-iana-class-type-yang/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Thank you to Valery Smyslov for the SECDIR review.

I applaud the clever use of XSLT to autogenerate and keep the YANG module up to
date.

** Section 5.  Recommend refining the security considerations to defer security
issues to the modules that use import the data types defined in this document. 
Roughly:

OLD
This documents translates two IANA registries into YANG data types
   and otherwise introduces no technology or protocol.  Consequently,
   there are no security issues to be considered for this document.

NEW

This document translates two IANA registries into YANG data types for use by
other YANG modules.  When imported and used, the resultant module schema will
have data nodes that can be writable or readable via a network management
protocol.  Access or modification to such data nodes may be considered
sensitive in some network environments, and this risk should be evaluated by
the importing module.

---

From: Ladislav Lhotka <[email-masked]>
Date: Fri, 04 Jun 2021 09:20:01 +0200

Hi Roman,

thanks for your comments, please see below.

Roman Danyliw via Datatracker <[email-masked]> writes:

...

The iana-dns-class-rr-type module only defines data types, so it doesn't contribute any data nodes when imported or used. I suggest to use the following formulation, adopted from RFC 6991:

NEW
  This documents translates two IANA registries into YANG data types and
  otherwise introduces no technology or protocol. The definitions themselves
  have no security impact on the Internet, but their use in concrete YANG
  modules might have. The security considerations spelled out in the YANG
  specification [RFC7950] apply for this document as well.

Is it sufficient?

Thanks, Lada

-- 
Ladislav Lhotka
Head, CZ.NIC Labs
PGP Key ID: 0xB8F92B08A9F76C67

---

From: Roman Danyliw <[email-masked]>
Date: Fri, 4 Jun 2021 12:23:06 +0000

Hi Lada!

> -----Original Message-----
> From: Ladislav Lhotka <[email-masked]>
> Sent: Friday, June 4, 2021 3:20 AM
> To: Roman Danyliw <[email-masked]>; The IESG <[email-masked]>
> Cc: [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked]
> Subject: Re: Roman Danyliw's No Objection on draft-ietf-dnsop-iana-class-type-
> yang-03: (with COMMENT)
> 
> Hi Roman,
> 
> > I applaud the clever use of XSLT to autogenerate and keep the YANG
> > module up to date.
> >
> > ** Section 5.  Recommend refining the security considerations to defer
> > security issues to the modules that use import the data types defined in this
> document.
> > Roughly:
> >
> > OLD
> > This document translates two IANA registries into YANG data types for
> > use by other YANG modules.  When imported and used, the resultant
> > module schema will have data nodes that can be writable or readable
> > via a network management protocol.  Access or modification to such
> > data nodes may be considered sensitive in some network environments,
> > and this risk should be evaluated by the importing module.
> >
> 
> The iana-dns-class-rr-type module only defines data types, so it doesn't
> contribute any data nodes when imported or used. I suggest to use the
> following formulation, adopted from RFC 6991:
> 
> NEW

Works for me!  Thanks for the improvement.

Regards,
Roman