Subject: [DNSOP] Working Group Last Call for draft-ietf-dnsop-nsec3-guidance

From: Tim Wicinski <[email-masked]>
Date: Wed, 23 Mar 2022 19:45:46 -0400

All,

With the authors feeling there are no outstanding changes and most people
are happy with the current version.  So this means it's time:

This starts a Working Group Last Call for draft-ietf-dnsop-nsec3-guidance-

Current versions of the draft is available here:
https://datatracker.ietf.org/doc/draft-ietf-dnsop-nsec3-guidance/

The Current Intended Status of this document is: Best Current Practice

Please review the draft and offer relevant comments.
If this does not seem appropriate please speak out.
If someone feels the document is *not* ready for publication, please speak
out with your reasons.

This starts a two week Working Group Last Call process, and ends on: 7
April 2022

thanks
tim

---

From: Wes Hardaker <[email-masked]>
Date: Thu, 24 Mar 2022 15:50:41 -0700

Tim Wicinski <[email-masked]> writes:

> With the authors feeling there are no outstanding changes and most people are happy with the current
> version.  So this means it's time:

Note that two small changes have been introduced since -06 were
published, which were just wording related changes.  Here are the diffs:

<    zone owners about good values to select.  Recent in academic studies
<    have shown that NSEC3 hashing provides only provides moderate
<    protection [GPUNSEC3][ZONEENUM].
---
>    zone owners about good values to select.  Recent academic studies
>    have shown that NSEC3 hashing provides only moderate protection
>    [GPUNSEC3][ZONEENUM].

and

<    iteration counts greater than 0, which will likely resulting in
<    returning a SERVFAIL to the client when no processed responses are
---
>    iteration counts greater than 0, which will likely result in
>    returning a SERVFAIL to the client when no acceptable responses are

-- 
Wes Hardaker
USC/ISI

---

From: Paul Hoffman <[email-masked]>
Date: Fri, 25 Mar 2022 16:19:27 +0000

I have re-read this document after not reading it for a long time. It is in excellent shape and should be sent to the IETF to become a BCP.

One note: the first paragraph in Section 2.4 is misplaced. Section 2 is about considerations while Section 3 is about recommendations. The first paragraph of Section 2.4 should be moved to Section 3.1, probably as the second paragraph there.

I'm sending the authors some strictly-editorial proposals in the repo.

--Paul Hoffman

---

From: Wes Hardaker <[email-masked]>
Date: Thu, 31 Mar 2022 15:49:04 -0700

Paul Hoffman <[email-masked]> writes:

> One note: the first paragraph in Section 2.4 is misplaced. Section 2
> is about considerations while Section 3 is about recommendations. The
> first paragraph of Section 2.4 should be moved to Section 3.1,
> probably as the second paragraph there.

Moved to the end of the 3.1 section, fyi, and integrated with other salt
discussions there.
-- 
Wes Hardaker
USC/ISI