Subject: [Doh] Implementations

From: Stephane Bortzmeyer <[email-masked]>
Date: Sun, 1 Oct 2017 14:05:11 +0200

What are the public implementations of the DNS-over-HTTPS concept? I
know Google's one:

% curl -s 'https://dns.google.com/resolve?name=ietf.org&type=MX' | jq . 
{
  "Status": 0,
  "TC": false,
  "RD": true,
  "RA": true,
  "AD": true,
  "CD": false,
  "Question": [
    {
      "name": "ietf.org.",
      "type": 15
    }
  ],
  "Answer": [
    {
      "name": "ietf.org.",
      "type": 15,
      "TTL": 700,
      "data": "0 mail.ietf.org."
    }
  ]
}

Or mine <http://www.bortzmeyer.org/dns-lg-usage.html>:

%  curl -s -H 'Accept: application/json' https://dns.bortzmeyer.org/ietf.org/MX
{
...
"AnswerSection": [
  {
   "MailExchanger": "mail.ietf.org.", 
   "Name": "ietf.org.", 
   "Type": "MX", 
   "Preference": 0, 
   "TTL": 1800
  }
 ], 
 "ReturnCode": "NOERROR", 
...

Any others?

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Wed, 11 Oct 2017 11:46:23 +0200

On Sun, Oct 01, 2017 at 02:05:11PM +0200,
 Stephane Bortzmeyer <[email-masked]> wrote 

...
> Or mine <http://www.bortzmeyer.org/dns-lg-usage.html>:

Both return JSON. Anyone knows an implementation with DNS wire format?

Could it be an interesting project for the next hackathon? There are
currently few DNS projects
<https://www.ietf.org/registration/MeetingWiki/wiki/100hackathon>. Any
volunteer?

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Thu, 26 Oct 2017 16:57:09 +0200

On Wed, Oct 11, 2017 at 11:46:23AM +0200,
 Stephane Bortzmeyer <[email-masked]> wrote 
 a message of 20 lines which said:

> Anyone knows an implementation with DNS wire format?
> 

Pinging again because there was no interest at first. May be now?