Subject: [Doh] I-D Action: draft-ietf-doh-dns-over-https-14.txt

From: [email-masked]
Date: Thu, 16 Aug 2018 10:23:42 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the DNS Over HTTPS WG of the IETF.

        Title           : DNS Queries over HTTPS (DoH)
        Authors         : Paul Hoffman
                          Patrick McManus
	Filename        : draft-ietf-doh-dns-over-https-14.txt
	Pages           : 20
	Date            : 2018-08-16

Abstract:
   This document defines a protocol for sending DNS queries and getting
   DNS responses over HTTPS.  Each DNS query-response pair is mapped
   into an HTTP exchange.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-doh-dns-over-https/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-doh-dns-over-https-14
https://datatracker.ietf.org/doc/html/draft-ietf-doh-dns-over-https-14

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-doh-dns-over-https-14

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Star Brilliant <[email-masked]>
Date: Thu, 16 Aug 2018 18:22:41 +0000

On Fri, Aug 17, 2018 at 3:24 AM <[email-masked]> wrote:
> _______________________________________________
> Doh mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/doh

Hi,

I would like to refine the document by pointing out several spelling issues.

On Page 6, Paragraph 2, Section 4.2:

[...] The amount and type of information that a media type gives is solely up to the format, and not defined in this protocol.

s/is/are/

On Page 8, Paragraph 3, Section 5.1:

[...] This requirement helps prevent exipred RRsets in messages in an HTTP cache from unintentionally being served.

s/exipred/expired/

On Page 4, Paragraph 5, Section 4.1:

[...] When using the POST method the DNS query is included as the message body [...]

(Minor issue) I suggest a comma (,) followed by "method". But okay if keep untouched.

Best regards,
Star Brilliant