Subject: [Dots] WGLC signal-18 ack-timeout Nits

From: "Jon Shallow" <[email-masked]>
Date: Mon, 26 Mar 2018 13:27:02 +0100

Hi there,

a)

         "ack-timeout": {

           "max-value-decimal": 30,

           "min-value-decimal": 1,

           "current-value-decimal": 2

         },

b)

ack-timeout (2 seconds)

c)

           "ack-timeout": {

             "current-value-decimal": 5

           },

Should really read (for clarity as they are now decimal numbers) in various
places

         "ack-timeout": {

           "max-value-decimal": 30.0,

           "min-value-decimal": 1.0,

           "current-value-decimal": 2.0

         },

ack-timeout (2.0 seconds)

           "ack-timeout": {

             "current-value-decimal": 5.0

           },

[I would prefer this to be 2.0, not 5.0 as it should not normally be changed
and people are known to slavishly copy examples, and Figure 20: is really
about changing the heartbeat interval.  Likewise, max-transmit should really
be 3, not 7 in Figure 20:]

Regards

Jon

---

From: <[email-masked]>
Date: Tue, 27 Mar 2018 08:34:00 +0000

Hi Jon,

Fixed to avoid misinterpreting the spec through the examples.

Cheers,
Med

De : Dots [mailto:[email-masked]] De la part de Jon Shallow
Envoyé : lundi 26 mars 2018 14:27
À : [email-masked]
Objet : [Dots] WGLC signal-18 ack-timeout Nits

Hi there,

a)
         "ack-timeout": {
           "max-value-decimal": 30,
           "min-value-decimal": 1,

c)
           "ack-timeout": {

Should really read (for clarity as they are now decimal numbers) in various places

         "ack-timeout": {

           "ack-timeout": {
             "current-value-decimal": 5.0
           },
[I would prefer this to be 2.0, not 5.0 as it should not normally be changed and people are known to slavishly copy examples, and Figure 20: is really about changing the heartbeat interval.  Likewise, max-transmit should really be 3, not 7 in Figure 20:]

Regards

Jon

---

From: "Jon Shallow" <[email-masked]>
Date: Tue, 27 Mar 2018 11:38:07 +0100

Thanks

From: Dots [mailto: [email-masked]] On Behalf Of
[email-masked]
Sent: 27 March 2018 09:34
To: Jon Shallow; [email-masked]
Subject: Re: [Dots] WGLC signal-18 ack-timeout Nits

Hi Jon,

Cheers,

Med

Hi there,

a)

         "ack-timeout": {

           "max-value-decimal": 30,

           "min-value-decimal": 1,

         },

b)

ack-timeout (2 seconds)

c)

           "ack-timeout": {

           },

         "ack-timeout": {

         },

           "ack-timeout": {

           },

Regards

Jon