Subject: Re: [Dots] [boucadair/draft-ietf-dots-data-channel] What gets returned for ?content=nonconfig (#4)

From: <[email-masked]>
Date: Mon, 16 Jul 2018 19:29:18 +0000

Re-,

The answer is the second one as per RFC8048 (see example 3 with nonconfig).

No change is needed to the draft.

Cheers,
Med

De : mrdeep1 [mailto:[email-masked]]
Envoyé : samedi 14 juillet 2018 16:13
À : boucadair/draft-ietf-dots-data-channel
Cc : Subscribed
Objet : [boucadair/draft-ietf-dots-data-channel] What gets returned for ?content=nonconfig (#4)

GET /restconf/data/ietf-dots-data-channel:dots-data/dots-client=sGI0F_6BMVsoz91ssmLpVw/aliases?content=nonconfig

Which of the following 2 responses is valid?
[name is a configuration item]

{"ietf-dots-data-channel:aliases":{"alias":[{"pending-lifetime":10043},{"pending-lifetime":10043},{"pending-lifetime":10043},{"pending-lifetime":10043},{"pending-lifetime":10043}]}}

or

{"ietf-dots-data-channel:aliases":{"alias":[{"name":"C1-target_ip-01","pending-lifetime":10043},{"name":"test-target-ip1","pending-lifetime"10043},{"name":"test1","pending-lifetime":10043},{"name":"test2","pending-lifetime":10043},{"name":"test4","pending-lifetime":10043}]}}

—
You are receiving this because you are subscribed to this thread.
Reply to this email directly, view it on GitHub<https://github.com/boucadair/draft-ietf-dots-data-channel/issues/4>, or mute the thread<https://github.com/notifications/unsubscribe-auth/AO8fVzKeW5-4-6bDtJmWB2eFMXUs1Jkwks5uGlDegaJpZM4VP_Rh>.

---

From: "Konda, Tirumaleswar Reddy" <[email-masked]>
Date: Tue, 17 Jul 2018 06:58:46 +0000

Example 3 in https://tools.ietf.org/html/rfc8040

-Tiru

From: Dots [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, July 17, 2018 12:59 AM
To: [email-masked]
Subject: Re: [Dots] [boucadair/draft-ietf-dots-data-channel] What gets returned for ?content=nonconfig (#4)

CAUTION: External email. Do not click links or open attachments unless you recognize the sender and know the content is safe.

________________________________
Re-,

Cheers,
Med

or

—