Subject: [Dots] Erik Kline's No Objection on draft-ietf-dots-signal-call-home-11: (with COMMENT)

From: Erik Kline via Datatracker <[email-masked]>
Date: Wed, 16 Dec 2020 23:57:07 -0800

Erik Kline has entered the following ballot position for
draft-ietf-dots-signal-call-home-11: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-dots-signal-call-home/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

[[ questions ]]

[ section 5.3.1 ]

* Can the source-prefix include IPv4/IPv6 link-local prefixes?

  Can the server and client be on the same link (and therefore
  link-local addresses might have some discernable meaning)?

---

From: <[email-masked]>
Date: Thu, 17 Dec 2020 08:21:06 +0000

Hi Erik, 

> * Can the source-prefix include IPv4/IPv6 link-local prefixes?

Yes. Only multicast/broadcast/loopback addresses are not allowed. 

>   link-local addresses might have some discernable meaning)?

Yeah. A DOTS gateway may be embedded in the access router. That’s said, we need to distinguish between the @es to reach the DOTS agents vs. the ones signaled in the DOTS messages (which belong to the attack sources).

An example of the use of link-local @ses is what is hinted in Éric's review: "if the CPE is a layer-2 node".

Cheers,
Med

> -----Message d'origine-----
> De : Erik Kline via Datatracker [mailto:[email-masked]]
> Envoyé : jeudi 17 décembre 2020 08:57
> À : The IESG <[email-masked]>
> Cc : [email-masked]; dots-
> [email-masked]; [email-masked]; Valery Smyslov <[email-masked]>;
> [email-masked]
> Objet : Erik Kline's No Objection on draft-ietf-dots-signal-call-
> home-11: (with COMMENT)
> 
> When responding, please keep the subject line intact and reply to
> all email addresses included in the To and CC lines. (Feel free to
> cut this introductory paragraph, however.)
> 
> 

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.