Subject: [Dots] Barry Leiba's No Objection on draft-ietf-dots-signal-call-home-11: (with COMMENT)

From: Barry Leiba via Datatracker <[email-masked]>
Date: Tue, 15 Dec 2020 20:15:25 -0800

Barry Leiba has entered the following ballot position for
draft-ietf-dots-signal-call-home-11: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-dots-signal-call-home/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Thanks for an easy-to-read document.  I understand Roman’s points, but conclude
that while a primary use case is for home networks, it’s expected that the
server for this will be a router that’s managed by the home user’s ISP, not by
the average home user.  That setup is increasingly common, at least in the
U.S., and it’s enabled many such functions that were not practical when users
had to provide and manage their own routers.

I just have a few very minor comments:

— Section 1.1 —

   Such misbehaviors will have both a collateral
   damage that affects end users, and can harm the reputation of an
   Internet Service Provider (ISP) for being a source of attack traffic.

Nit: This sentence isn’t properly formed, as the two pieces of the “both”
construction aren’t parallel.  I suggest this:

NEW
   Such misbehaviors can cause collateral damage
   that will affect end users, and can also harm the reputation of an
   Internet Service Provider (ISP) for being a source of attack traffic.
END

— Section 5.1 —

   enabling means for automating the
   provisioning of credentials on Call Home DOTS servers to authenticate
   to the Call Home DOTS client are encouraged.

Nit: the subject of this is the singular “enabling”, so “enabling <stuff> is
encouraged,” not “are”.

— Section 7 —
Throughout the IANA Considerations, please make the contact points and change
controller be “IETF” (not IESG nor IETF Chair), and use the email address
<[email-masked]>.  That’s what the IESG considers the best way to refer to items
where the IETF has change control.

---

From: <[email-masked]>
Date: Wed, 16 Dec 2020 06:18:29 +0000

Hi Barry, 

Thank you for the review. 

All good points. Fixed at: https://tinyurl.com/dots-call-home-latest. 

Cheers,
Med

> -----Message d'origine-----
> De : Barry Leiba via Datatracker [mailto:[email-masked]]
> Envoyé : mercredi 16 décembre 2020 05:15
> À : The IESG <[email-masked]>
> Cc : [email-masked]; dots-
> [email-masked]; [email-masked]; Valery Smyslov <[email-masked]>;
> [email-masked]
> Objet : Barry Leiba's No Objection on draft-ietf-dots-signal-call-
> home-11: (with COMMENT)
> 
> When responding, please keep the subject line intact and reply to
> all email addresses included in the To and CC lines. (Feel free to
> cut this introductory paragraph, however.)
> 
> 
> Thanks for an easy-to-read document.  I understand Roman’s points,
> but conclude that while a primary use case is for home networks,
> it’s expected that the server for this will be a router that’s
> managed by the home user’s ISP, not by the average home user.  That
> setup is increasingly common, at least in the U.S., and it’s enabled
> many such functions that were not practical when users had to
> provide and manage their own routers.
> 
> Nit: the subject of this is the singular “enabling”, so “enabling
> <stuff> is encouraged,” not “are”.
> 
> — Section 7 —
> Throughout the IANA Considerations, please make the contact points
> and change controller be “IETF” (not IESG nor IETF Chair), and use
> the email address <[email-masked]>.  That’s what the IESG considers
> the best way to refer to items where the IETF has change control.
> 
> 

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Barry Leiba <[email-masked]>
Date: Wed, 16 Dec 2020 10:29:52 -0500

Thanks, Med, for the quick response, as always.

Barry