Subject: [Dots] I-D Action: draft-ietf-dots-telemetry-use-cases-02.txt

From: [email-masked]
Date: Thu, 01 Jul 2021 21:05:58 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the DDoS Open Threat Signaling WG of the IETF.

        Title           : Use Cases for DDoS Open Threat Signaling (DOTS) Telemetry
        Authors         : Yuhei Hayashi
                          Meiling Chen
                          Li Su
	Filename        : draft-ietf-dots-telemetry-use-cases-02.txt
	Pages           : 27
	Date            : 2021-07-01

Abstract:
   Denial-of-service Open Threat Signaling (DOTS) Telemetry enriches the
   base DOTS protocols to assist the mitigator in using efficient DDoS-
   attack-mitigation techniques in a network.  This document presents
   sample use cases for DOTS Telemetry: what components are deployed in
   the network, how they cooperate, and what information is exchanged to
   effectively use these techniques.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dots-telemetry-use-cases/

There is also an htmlized version available at:
https://datatracker.ietf.org/doc/html/draft-ietf-dots-telemetry-use-cases-02

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dots-telemetry-use-cases-02

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: H Y <[email-masked]>
Date: Fri, 2 Jul 2021 13:11:15 +0900

Hi all,

I made draft-ietf-dots-telemetry-use-cases-02 based on your comments.
I'm sorry for being late to update it.

Major change point is as below.
- extract use cases already included in the telemetry I-D
- include message bodies with the attributes.

Git is here.
https://github.com/yuheihayashi/dotstelemetryusecase

Comments or questions are welcome.

Thanks,
Yuhei

2021年7月2日(金) 13:06 <[email-masked]>:
> _______________________________________________
> Dots mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dots

-- 
----------------------------------
Yuuhei HAYASHI
08065300884
[email-masked]
[email-masked]
----------------------------------

---

From: <[email-masked]>
Date: Fri, 2 Jul 2021 06:35:32 +0000

Hi Yuhei, all,

Thank you for the update. 

I have one comment: please remove all "total-pipe-capacity" items from the examples as these ones do not appear during the attack signaling, but during the telemetry setup. You may also reword the following accordingly: 

   The aim of this use case is to enable transit providers to select an
   optimal path for redirecting attack traffic to a DMS according to the
   bandwidth of the attack traffic, total traffic, and total pipe
   capability.

And some very minor nits and suggestions: 

* Please use draft-ietf-dots-rfc8782-bis instead of RFC8782
* s/Figure 2 gives an example of message body of DOTS telemetry/Figure 2 provides an example of a DOTS telemetry message body that is used to signal top-talkers. 
* s/Figure 2: Example of Message Body/Figure 2: Example of Message Body to Signal Top-Talkers
* s/Figure 4 gives an example of message body of DOTS telemetry/Figure 4 provides an example of a DOTS telemetry message body that is used to signal various attack traffic percentiles.
* s/Figure 4: Example of Message Body/Figure 4: Example of Message Body with Total Attack Traffic
* (you can follow the same approach for fixing the other captions)
* s/network managements system/network management system
* s/volume from transit provider/volume from the transit provider
* s/when DDoS attacks occurs/when DDoS attacks occur

Other than that, the document is more and more stable and even ready for the WGLC.  

Cheers,
Med

> -----Message d'origine-----
> De : Dots [mailto:[email-masked]] De la part de H Y
> Envoyé : vendredi 2 juillet 2021 06:11
> À : dots <[email-masked]>
> Objet : Re: [Dots] I-D Action: draft-ietf-dots-telemetry-use-cases-
> 02.txt
> 
> Hi all,
> 

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.