Subject: Re: [Dtls-iot] draft-ietf-dice-profile-12.txt - A minor typo error!

From: Jayaraghavendran k <[email-masked]>
Date: Fri, 5 Jun 2015 13:29:41 +0000

Hi Hannes,

Thanks for a very a comprehensive dice-profile specification. 

Looks like a small typo error has crept in the section "Appendix B: DTLS Record Layer Per-Packet Overhead".

The third paragraph in Appendix B says:
" The "nonce" input to the AEAD algorithm is exactly that of [RFC5288],
   i.e., 12 bytes long.  It consists of a 4 octet salt and an 8 octet
   nonce.  The salt is the "implicit" part of the nonce and is not sent
   in the packet.  Since the nonce_explicit may be the 8 octet sequence
   number and, in DTLS, it is the 8 octet epoch concatenated with the 6
   octet sequence number."

Shouldn't it be "2 octet epoch" instead of "8 octet epoch" in the last statement?

Thanks.

Regards,
Jay

***************************************************************************************
This e-mail and attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the information contained herein in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient's) is prohibited. If you receive this e-mail in error, please notify the sender by phone or email immediately and delete it!
***************************************************************************************

-----Original Message-----
From: dtls-iot [mailto:[email-masked]] On Behalf Of Hannes Tschofenig
Sent: 28 May 2015 16:07
To: [email-masked]
Subject: [Dtls-iot] draft-ietf-dice-profile-12.txt

I submitted version -12 to correct references.

Ciao
Hannes

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 10 Jun 2015 19:22:29 +0200

Hi Jay,

good catch.

I updated the text.

Ciao
Hannes

On 06/05/2015 03:29 PM, Jayaraghavendran k wrote:
> _______________________________________________
> dtls-iot mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dtls-iot
>