Subject: [dtn-users] DTN has non standard dir in var

From: Leo Iannacone <[email-masked]>
Date: Fri, 11 Nov 2011 18:14:12 +0100

By default, dtn uses /var/dtn to store bundles and db, but it isn't
the standard way.

The FHS says "Applications should generally not add directories to the
top level of /var. Such directories should only be added if they have
some system-wide implication, and in consultation with the FHS mailing
list."

Refer to Filesystem Hierarchy Standard(1) (The /var Hierarchy (2)) for details.

I suggest to move all in /var/cache/dtn/

Is it possible do it editing code?

Best regards,
Leo.

REF:
1 - http://www.pathname.com/fhs/pub/fhs-2.3.html
2 - http://www.pathname.com/fhs/pub/fhs-2.3.html#THEVARHIERARCHY

---

From: Leo Iannacone <[email-masked]>
Date: Fri, 11 Nov 2011 18:57:31 +0100

On 11 November 2011 18:44, Elwyn Davies <[email-masked]> wrote:
> Hi, Leo.

Hi Elwyn,

> The location of the data is controlled by the dtn.conf configuration
> file.
>
> If you would prefer not to use /var/dtn tweak the dbdir value being
> used.

I know, what I'm asking is: Is it possible change it by default?. In
other words: "could it be changed in the DTN branch?"

This is just to make things in "standard way".

Moreover, consider that in some files you have this reference to
/var/dtn, to be more precious:

~/DTN2 $ grep -r '/var/dtn' * | cut -d':' -f1 | uniq

apps/dtnperf/dtnperf-client.c
apps/dtnperf/dtnperf-server.c
apps/dtnperf/dtnperf-details.txt
daemon/dtn.conf
debian/dtn.postinst
debian/dtn.init.d
debian/dtn.logrotate
debian/dtn.postrm
doc/manual/configuration.html
doc/manual/man_dtncpd.html
servlib/cmd/StorageCommand.cc
tools/uninstall.sh

> Actually there is an issue with the example dtn.conf in the current
> SourceForge distribution.  A hard coded dbdir has crept in at chanegset
> 3523.
> Line 86: set dbdir /home/user/workspace/hg_10_10_11/dbdir
>
> This should not be there.

Right...

> Regards,
> Elwyn

Regards,

Leo.

> On Fri, 2011-11-11 at 18:14 +0100, Leo Iannacone wrote:
>> _______________________________________________
>> dtn-users mailing list
>> [email-masked]
>> https://www.irtf.org/mailman/listinfo/dtn-users
>
>