Subject: [dtn-users] Oasys - checking for right version of Xerces-C++ library

From: Elwyn Davies <[email-masked]>
Date: Sat, 03 Dec 2011 16:46:11 +0000

Hi.

It appears that the Oasys configure system does not barf if given an
installation of Xerces-C++ Verion 3.x.  Since Oasys requires 
Version 2.x.y of Xerces-C++ where x >= 6, but will not compile/link with
version 3.x, aclocal/xerces-c.ac should detect versions equal to or
higher than 3.0.0 and throw an error.

A suitable patch is attached.  If you apply this to
oasys/aclocal/xerces-c.ac, it is necessary to run
oasys/build-configure.sh to remake oasys/aclocal.m4 and the configure
script.  This in turn assumes that you have the autoconf tools package
installed.

The Sourceforge repository normally contains updated versions of
aclocal.m4, the configure script, etc.

Commiserations to Gokul Nath who has been struggling with this problem
today.

Regards,
Elwyn 
diff -r 9caed1be9383 aclocal/xerces-c.ac
--- a/aclocal/xerces-c.ac	Sun Nov 27 21:53:06 2011 +0000
+++ b/aclocal/xerces-c.ac	Sat Dec 03 14:32:34 2011 +0000
@@ -63,7 +63,7 @@
     ac_save_LDFLAGS="$LDFLAGS"
     ac_save_LIBS="$LIBS"
 
-    AC_MSG_CHECKING([whether xerces-c (>= v2.6.0) was found])
+    AC_MSG_CHECKING([whether xerces-c (>= v2.6.0 and < v3.0.0) was found])
     AC_CACHE_VAL(oasys_cv_path_xerces_c,
     [
         for ac_xerces_inst_dir in $ac_xerces_inst_dirs; do
@@ -82,18 +82,22 @@
                         ],
     
                         [
-                            #if _XERCES_VERSION >= 20600
+			    #if _XERCES_VERSION >= 30000
+				#error
+			    #else
+				#if _XERCES_VERSION >= 20600
 
-                            xercesc::XMLPlatformUtils::Initialize();
-                            {
-                                xercesc::DOMImplementation* impl
-                                    = xercesc::DOMImplementationRegistry::getDOMImplementation
-                                        (xercesc::XMLString::transcode("XML 1.0"));
-                            }
-                            xercesc::XMLPlatformUtils::Terminate();
+				xercesc::XMLPlatformUtils::Initialize();
+				{
+				    xercesc::DOMImplementation* impl
+					= xercesc::DOMImplementationRegistry::getDOMImplementation
+							(xercesc::XMLString::transcode("XML 1.0"));
+				}
+				xercesc::XMLPlatformUtils::Terminate();
 
-                            #else
-                                #error
+				#else
+					#error
+				#endif
                             #endif
                         ]),
                     [

---

From: gokul nath <[email-masked]>
Date: Tue, 6 Dec 2011 14:04:57 +0530

Hello sir,

Summarising my problem on DTN2.8.0 installation,

There are 2 scenarios:

1. Home environment
2. Work environment

In home environment, we have installed DTN2.8.0 in Linuxmint12. By making
use of synaptic package manager, we have installed all the pre-requisites
required to install oasys/DTN. That problem is solved.

In work environment, we are using fedora version 3 and there is no internet
access. So we can't use any software package manager to download and
install automatically.

So to summarise the problem,
       # we have installed xerces 2.8.0 successfully.But while compiling
oasys1.5.0, I am getting the* serialize-error* as seen in
http://i.imgur.com/AVGaI.png

So, I am still hanging with that problem. How to proceed?...
Thank for being patient with us.

Regards,
Gokulnath

On Sat, Dec 3, 2011 at 10:16 PM, Elwyn Davies <[email-masked]> wrote:

> version 3.x, aclocal/xerces-c.ac
>
> should detect versions equal to or
> oasys/aclocal/xerces-c.ac
>
> , it is necessary to run
> _______________________________________________
> dtn-users mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/dtn-users
>
>
>
>

---

From: Ian Glennon <[email-masked]>
Date: Tue, 6 Dec 2011 08:39:15 +0000

It looks like you have the xerces package but not the development package.
You need that in order to compile oasys. It should be on your installation
media.
On Dec 6, 2011 8:35 AM, "gokul nath" <[email-masked]> wrote:

> In work environment, we are using fedora version 3 and there is no
> internet access. So we can't use any software package manager to download
> and install automatically.
>
> On Sat, Dec 3, 2011 at 10:16 PM, Elwyn Davies <[email-masked]>wrote:
>
>> Hi.
>>

---

From: Elwyn Davies <[email-masked]>
Date: Tue, 06 Dec 2011 11:58:47 +0000

On 06/12/11 08:39, Ian Glennon wrote:
>
> It looks like you have the xerces package but not the development 
> package. You need that in order to compile oasys. It should be on your 
> installation media.
>
Failing that you have three courses of action with increasing levels of 
irritation to you:
- try copying the <install prefix>/include/xerces directory tree onto 
the work machine by a suitable medium (CD,USB stick) assuming that you 
have lib/libxerces-c.so.28.0 and lib/libxerces-depdom.so.28.0 already on 
the work machine.  Tell the oasys 'configure' where you have this stuff 
installed (the libraries and the includes need a common directory 
prefix) but note that it is not essential that they are in 'system' 
filing system space if you don't have root access on the work machine.  
You can make links to the libraries if necessary so that this all works.
- if this doesn't work for some subtle problem with the headers, 
download the binary linux installation file for the work machine 
(...x86_linux_gcc_3_4 or ...x86_64_linux_gcc_3_4...) from 
http://xerces.apache.org/xerces-c/download.cgi
at home, copy it to some suitable medium and unpack it onto the work 
machine.  As i said this doesn't have to be it system space as long as 
you tell oasys/configure where to find it (./configure 
--with-xerces-c=<install path>)
- do as last case but do as last case but download the source 
distribution, install it on the work machine, and build it there.

Regards,
Elwyn
> On Dec 6, 2011 8:35 AM, "gokul nath" <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Hello sir,
>     In home environment, we have installed DTN2.8.0 in Linuxmint12. By
>     making use of synaptic package manager, we have installed all the
>     pre-requisites required to install oasys/DTN. That problem is solved.
>     internet access. So we can't use any software package manager to
>     download and install automatically.
>            # we have installed xerces 2.8.0 successfully.But while
>     compiling oasys1.5.0, I am getting the*serialize-error* as seen in
>     On Sat, Dec 3, 2011 at 10:16 PM, Elwyn Davies
>     <[email-masked] <mailto:[email-masked]>> wrote:
>
>         Hi.
>
>         version 3.x, aclocal/xerces-c.ac <http://xerces-c.ac>
>         oasys/aclocal/xerces-c.ac <http://xerces-c.ac>
>         , it is necessary to run
>         [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>