Subject: [dtn-users] dtn installation help

From: gokul nath <[email-masked]>
Date: Sat, 3 Dec 2011 09:28:46 +0530

Hi,

This is the current scenario:

We have to install dtn-2.8.0,

1) Since oasys-1.5.0 requires xerces, We have installed xerces-2.8.0.
Xerces has been configured using the "./runconfigure" command, made using
"make" command successfully.

2) While installing oasys-1.5.0,

If we give the "./configure" command, it configures successfully. But when
we give the "make" command, it throws an error as in the picture :

Please guide me on how to fix this error and procceed with the dtn
installation.

If you need any more logs or screenshots, we will provide it.

Thank you.

Regards,
Gokulnath

---

From: gokul nath <[email-masked]>
Date: Sat, 3 Dec 2011 14:30:47 +0530

Hi,

Thank you for the reply.

Here is the file entries

XERCES_VERSION_MAJOR 3
XERCES_VERSION_MINOR 1
XERCES_VERSION_REVISION 1

here is the picture of it http://i.imgur.com/keNj1.png

we don't know how to proceed.

thank you

On Sat, Dec 3, 2011 at 2:10 PM, Elwyn Davies <[email-masked]> wrote:

> Hi.
>
> The error line with xerces_3_1 in it (from
> xercesc/internal/XMLSerializeEngine.hpp) tells me that the compiler is
> finding the wrong set of xercesc headers.  I suspect that you have or
> have had an installation of version 3.1 of Xerces-C++ on this machine
> and the headers are left over from it.
>
> Check the include file xercesc/util/XercesVersion.hpp - the macros
> XERCES_VERSION_MAJOR/MINOR tell you which version they come from.
>
> Regards,
> Elwyn
>
> On Sat, 2011-12-03 at 09:28 +0530, gokul nath wrote:
> > Hi,
> >
> > Xerces has been configured using the "./runconfigure" command, made
> > using "make" command successfully.
> >
> > If we give the "./configure" command, it configures successfully. But
> > when we give the "make" command, it throws an error as in the
> > picture :
> >
> > 42geu.png
> >
> > _______________________________________________
> > dtn-users mailing list
> > [email-masked]
> > https://www.irtf.org/mailman/listinfo/dtn-users
>
>

---

From: gokul nath <[email-masked]>
Date: Sat, 3 Dec 2011 15:19:53 +0530

Sir,

I installed a fresh copy of linux mint and i am trying from first. I have
installed only 3.1.1. I have not installed version 2.6. Sorry for not
notifying you about that.

we have installed xerces properly. it throws no error. but oasys is the one
which is giving the error when give the make command.

thank you.

On Sat, Dec 3, 2011 at 3:21 PM, Elwyn Davies <[email-masked]> wrote:

> Hi.
>
> You stated that you installed v2.8.0 of Xerces-C++.. so where did  it
> get put? Check the installation scripts or just do a
> find / -name 'xercesc*'
>
> When you have found it, rerun the oasys configure command specifying
> where the (right, v2.8.0) Xerces installation is to be found, thus:
> ./configure --with-xerces-c=<top level install dir>
>
> This implies that the lib and include/xercesc directories under this top
> level install directory contain the right files.
>
> At present, in your case, the configure script has found the Xerces-C
> 3.1 version in /usr/local which is one of the two default places that
> configure looks if you don't tell it specifically.
>
> Suggestion:
> Spend a few minutes learning about GNU Autoconf.
> http://www.gnu.org/s/autoconf/
> and try to understand oasys/aclocal/xerces-c.ac
>
> Regards,
> Elwyn
>
> On Sat, 2011-12-03 at 14:30 +0530, gokul nath wrote:
> > Hi,
> >
> > Thank you for the reply.
> >
> > Here is the file entries
> >
> > XERCES_VERSION_MAJOR 3
> > XERCES_VERSION_MINOR 1

---

From: gokul nath <[email-masked]>
Date: Sat, 3 Dec 2011 17:32:04 +0530

Hi,

Thank you for your inputs.

We installed a fresh copy of linux mint 12 and installed all requirements
via synaptic and both oasys and dtn has been successfully installed.

We appreciate your help.

Thank you and have a good day/night.

Regards,
Gokulnath

On Sat, Dec 3, 2011 at 4:50 PM, Ian Glennon <[email-masked]> wrote:

> Linux Mint is based on Ubuntu Oneiric Ocelot.  Rather than installing
> Xerces from source, I would go with the pre-packaged version.  Try removing
> your xerces installation and then run the following command...
>
> sudo apt-get install libxerces-c2-dev libxerces-c28 libxerces-c3.1
> libxerces2-java
>
> That should install all the libraries you need (including the Dev
> libraries, which are essential for oasys).
>
> Hope this helps.
>
> Ian
>
>
> On 3 December 2011 09:49, gokul nath <[email-masked]> wrote:
>
>> Sir,
>>
>> we have installed xerces properly. it throws no error. but oasys is the
>> one which is giving the error when give the make command.
>>
>> thank you.
>>