Subject: Re: [dtn-users] DTN2 build failures on Debian Squeeze based distros on multiple architectures.

From: Darren Long <[email-masked]>
Date: Fri, 06 Sep 2013 14:29:16 +0100

Hi Lana,

Is there any news on this issue?

Should I add a bug report at sourceforge?

Cheers,

Darren

On 06/08/13 21:07, Darren Long wrote:
> Hi Lana,
>
> It is failing to build with gcc version 4.4.5 (Debian 4.4.5-8) on all
> three machines with issues.
>
> With gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5) and gcc version
> 4.7.2 (Ubuntu/Linaro 4.7.2-2ubuntu1) it is OK.
>
> Cheers,
>
> Darren
>
> On 06/08/13 21:03, Lana Black wrote:
>> On 14:57 Tue 06 Aug     , Darren Long wrote:
>>> Hi.
>>>
>>> I'm having a problem with building DTN2 from the repo tip on some
>>> machines. The sheevaplug (ARM) and the VPS(x86) are both running Debian
>>> Squeeze and the netbook is running Crunchbang Statler, a Squeeze
>>> derivative (x86). The DTN2 build fails on all three of them. Building
>>> succeeds on two other hosts, one running Ubuntu 12.04 LTS and the other
>>> on 12.10, both x86_64.
>>>
>>> The build fails like so:
>>> ----------
>>> make[1]: Entering directory `/home/darren/src/DTN2/servlib'
>>> g++ -g -fno-inline -fPIC -DPIC -MMD -MP -MT "security/cms_structs.o
>>> security/cms_structs.E" -DHAVE_CONFIG_H -D_LARGEFILE_SOURCE
>>> -D_FILE_OFFSET_BITS=64 -I.. -I.. -I/home/darren/src/DTN2/oasys/include
>>> -I/home/darren/src/DTN2/oasys/include/oasys/ext -I../servlib
>>> -I/usr/include/tcl8.5 -Wall -W -Wcast-align -c security/cms_structs.cc
>>> -o security/cms_structs.o
>>> In file included from security/cms_structs.cc:3:
>>> security/cms_structs.h:546: error: expected constructor, destructor, or
>>> type conversion before ‘}’ token
>>> security/cms_structs.cc:96: warning: unused parameter ‘it’
>>> security/cms_structs.cc:96: warning: unused parameter ‘exarg’
>>> security/cms_structs.cc:110: error: invalid conversion from ‘int
>>> (*)(int, ASN1_VALUE**, const ASN1_ITEM*, void*)’ to ‘int (*)(int,
>>> ASN1_VALUE**, const ASN1_ITEM*)’
>>> security/cms_structs.cc:223: warning: unused parameter ‘it’
>>> security/cms_structs.cc:223: warning: unused parameter ‘exarg’
>>> security/cms_structs.cc:250: error: invalid conversion from ‘int
>>> (*)(int, ASN1_VALUE**, const ASN1_ITEM*, void*)’ to ‘int (*)(int,
>>> ASN1_VALUE**, const ASN1_ITEM*)’
>>> security/cms_structs.cc:346: error: expected ‘,’ or ‘;’ before
>>> ‘ASN1_NDEF_SEQUENCE_END_cb’
>>> make[1]: *** [security/cms_structs.o] Error 1
>>> make[1]: Leaving directory `/home/darren/src/DTN2/servlib'
>>> make: *** [servlib] Error 2
>>> ----------
>>> Does anyone have any ideas what might be wrong? I can't see anything
>>> obvious.
>>>
>>> Cheers,
>>>
>>> Darren
>>> _______________________________________________
>>> dtn-users mailing list
>>> [email-masked]
>>> https://www.irtf.org/mailman/listinfo/dtn-users
>> Hi Darren,
>>
>> What gcc version do you use? I'll try to investigate this later this
>> week.
>>
>> With best regards.
>>
> _______________________________________________
> dtn-users mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/dtn-users

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 06 Sep 2013 14:32:14 +0100

I suspect that mail might not have gotten to its
To: recipient, unless via the list. [1]

S.

[1] https://lavabit.com/

---

From: Darren Long <[email-masked]>
Date: Fri, 06 Sep 2013 14:39:06 +0100

Hi Stephen,

Yeah, I just noticed Lana's email address at Lavabit and was going to 
send a follow up.

I'd like to express my admiration for Ladar's principled decision and 
hope that Bruce Schenier's call to take back the internet is heeded.

Cheers,

Darren

---

From: Lana Black <[email-masked]>
Date: Tue, 10 Sep 2013 15:31:34 +0000 (UTC)

> Should I add a bug report at sourceforge?

Hello Darren,

I'm sorry for the delay. Seems that debian squeeze has too old openssl
package (0.9.8). In fact, I've had to revert plenty of changes to get
dtn built on squeeze due to missing macros (IP_TRANSPARENT, e.g.). Try
updating to debian stable at least, should work fine.

With best regards.