Subject: [dtn-users] dtn lidb-5.3

From: Guillermo Wenceslao Zàrate segura <[email-masked]>
Date: Sun, 1 Jun 2014 21:32:18 -0500

hi i have a problem during compilling:
after i write:

 daemon/dtnd -c /home/fred/dtn/dtn.conf --init-db

guillermo@guillermo-X202E:~/DTNRG/DTN2/dtn-2.9.0$ daemon/dtnd -c
/home/guillermo/dtn/dtn.conf --init-db
daemon/dtnd: /usr/local/lib/libdb-5.3.so: no version information available
(required by /usr/lib/liboasys-1.6.0.so)
[1401676274.630165 /dtnd notice] random seed is 630159
[1401676274.630295 /dtnd notice] DTN daemon starting up... (pid 12458)
Must create /var/dtn or /var/tmp/dtn storage directory

plz help me
using dtn 2.9 and oasys 1.6

---

From: ccaini <[email-masked]>
Date: Mon, 02 Jun 2014 09:49:49 +0200

Dear Guillermo,
         I would suggest that you create the two directories first, then
you run dtnd as root (or give the user the permissions to write in those
directories. It is likely you have a problem with the libdb too. 
Yours,
   Carlo

---

From: "Yang, Yueli" <[email-masked]>
Date: Mon, 2 Jun 2014 15:56:38 +0000

Another fix is to assign an accessible dir to the dbdir in your /home/fred/dtn/dtn.conf.

-----Original Message-----
From: dtn-users [mailto:[email-masked]] On Behalf Of ccaini
Sent: Monday, June 02, 2014 12:50 AM
To: Guillermo Wenceslao Zàrate segura
Cc: [email-masked]
Subject: Re: [dtn-users] dtn lidb-5.3

Dear Guillermo,
         I would suggest that you create the two directories first, then you run dtnd as root (or give the user the permissions to write in those directories. It is likely you have a problem with the libdb too. 
Yours,
   Carlo

> using dtn 2.9 and oasys 1.6

_______________________________________________
dtn-users mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/dtn-users