Subject: [dtn-users] help for DTN routing

From: Nishikant Uikey <[email-masked]>
Date: Wed, 18 Feb 2015 23:34:31 +0530

i am doing a project in DTN routing and i have to propose a hybrid
routing algorithm.
i have understood the concept but i dont know how to start
implementing it in the ONE simulator.Can anybody provide me any
suggestion for writing algorithm and selecting the parameters. can
anybody tell me how should i start working on the ONE simulator....

---

From: "Ripplinger, David - 0665 - MITLL" <[email-masked]>
Date: Wed, 18 Feb 2015 18:13:03 +0000

>From what I'm reading online, it looks like ONE was created specifically
with DTN2 in mind. Perhaps locating a mailing list for ONE or contacting the
creators directly would be more fruitful than on this list. But if you get a
hit on this list, great. Best of luck. I'm sorry I'm not familiar with it.

David

-----Original Message-----
From: dtn-users [mailto:[email-masked]] On Behalf Of Nishikant
Uikey
Sent: Wednesday, February 18, 2015 1:05 PM
To: [email-masked]
Subject: [dtn-users] help for DTN routing

i am doing a project in DTN routing and i have to propose a hybrid routing
algorithm.
i have understood the concept but i dont know how to start implementing it
in the ONE simulator.Can anybody provide me any suggestion for writing
algorithm and selecting the parameters. can anybody tell me how should i
start working on the ONE simulator....

_______________________________________________
dtn-users mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/dtn-users

---

From: Elwyn Davies <[email-masked]>
Date: Thu, 19 Feb 2015 16:21:07 +0000

Check out one or other of the implementations of routing protocols that 
have been contributed to ONE.
There are several including RAPID and PRoPHET(v2).

Unless you already know your way round the DTN2 code I would not 
recommend  delving into the DTN2 router code.  However there is a 
functional specification of DTN2 at 
http://www.n4c.eu/Download/n4c-wp2-023-dtn-infrastructure-fs-12.pdf. 
Section 4.8 describes how the routing subsystem should work, but note 
that the implementation of PRoPHET in the current version of DTN2 
(2.9.0+) does not match the functional spec - it is the old version 
(Primarily intended for Bluetooth CL and using PRoPHETv1) as PRoPHET was 
not reimplemented by N4C unfortunately.

There several hundred theoretical proposals for DTN routing protocols 
and less then 10 have been implemented practically.  There are several 
surveys around.  This is a relatively recent one that covers maybe a 
fifth of the proposals:

Zhenxin Feng and Kwan-Wu Chin. 2012. /A Survey of Delay Tolerant 
Networks Routing Protocols/, Wollongong, Australia. (available from 
http://arxiv.org/pdf/1210.0965v1.pdf

Good luck,
Elwyn