Subject: [dtn] summary of work items

From: Marc Blanchet <[email-masked]>
Date: Thu, 11 Dec 2014 09:32:31 -0500

Hello,
 Brian and I have worked on a summary of the work items that were discussed during our interim meeting last week. We hope this reflects our discussion. We would like to make sure this summary is appropriate before sending it to our AD. So please review and confirm.  The intent of this email is _not_ to discuss each work items, but to review if the list is ok.

Regards, Marc&Brian

=====================
DTN Work Items

Phase 1
Header Integrity and Immutability
Status: DTN WG work item
Considerations:
payload integrity
e2e integrity
immutability of primary block
remove dictionary
Improved Security
Status: DTN WG work item
Considerations:
Determine if SBSP is starting point
Identify dependency on header changes driven by other work items
Addressing
Status: DTN WG work item
Considerations: 
develop requirements on addressing from use cases
narrow scope of work
Possible interim meeting
Node/Neighbor Discovery
Status: DTN WG work item
Considerations:
Investigate MANET discovery protocol model
Assess applicability of draft-irtf-dtnrg-ipnd
Static Routing
Status: DTN WG work item
Considerations:
Assess relationship to node/neighbor discovery
Avoid Routing Loops
Status: DTN WG work item
Time and bundle expiration
Status: DTN WG work item
Improve Specifications such as RFC 5050
Status: DTN WG work item
Considerations:
fix known specification bugs
constrained environments
default operations
simplify options
identify issues for incompatibilities with 5050
Registry of Service Identifier
Status: DTN WG work item.

Phase 2
(after phase 1 completed, potential work items below. list to be reviewed at that time)
Network Management
Network monitoring only, not configuration
Considerations:
Potentially interface with LIME WG
Move configuration to DTNRG?
Key management
Extended Class of Service
Multicast
Streaming Support
Bundle size

Non Work Items
Dynamic Routing
Status: suggesting DTNRG

---

From: "Templin, Fred L" <[email-masked]>
Date: Thu, 11 Dec 2014 16:22:11 +0000

Hi Marc,

The Phase 1 items look good, however it might be useful to also identify which document
or documents (if any) will be affected for each work item. For example, my understanding
is that Header Integrity and Immutability would be addressed in RFC5050(bis). Would it be
useful to add a bullet such as: "Documents Affected" under each work item?

Thanks - Fred
[email-masked]

From: dtn [mailto:[email-masked]] On Behalf Of Marc Blanchet
Sent: Thursday, December 11, 2014 6:33 AM
To: [email-masked]
Subject: [dtn] summary of work items

Hello,

Regards, Marc&Brian

=====================
DTN Work Items

Phase 1

  1.  Header Integrity and Immutability

     *   Status: DTN WG work item

     *   Considerations:

        *   payload integrity

        *   e2e integrity

        *   immutability of primary block

        *   remove dictionary

  1.  Improved Security

     *   Status: DTN WG work item

     *   Considerations:

        *   Determine if SBSP is starting point

        *   Identify dependency on header changes driven by other work items

  1.  Addressing

     *   Status: DTN WG work item

     *   Considerations:

        *   develop requirements on addressing from use cases

        *   narrow scope of work

        *   Possible interim meeting

  1.  Node/Neighbor Discovery

     *   Status: DTN WG work item

     *   Considerations:

        *   Investigate MANET discovery protocol model

        *   Assess applicability of draft-irtf-dtnrg-ipnd

  1.  Static Routing

     *   Status: DTN WG work item

     *   Considerations:

        *   Assess relationship to node/neighbor discovery

  1.  Avoid Routing Loops

     *   Status: DTN WG work item

  1.  Time and bundle expiration

     *   Status: DTN WG work item

  1.  Improve Specifications such as RFC 5050

     *   Status: DTN WG work item

     *   Considerations:

        *   fix known specification bugs

        *   constrained environments

        *   default operations

        *   simplify options

        *   identify issues for incompatibilities with 5050

  1.  Registry of Service Identifier

     *   Status: DTN WG work item.

Phase 2

  1.  Network Management

     *   Network monitoring only, not configuration

     *   Considerations:

        *   Potentially interface with LIME WG

        *   Move configuration to DTNRG?

  1.  Key management

  1.  Extended Class of Service

  1.  Multicast

  1.  Streaming Support

  1.  Bundle size

Non Work Items

  1.  Dynamic Routing

     *   Status: suggesting DTNRG

---

From: "Ivancic, William D. (GRC-LCA0)" <[email-masked]>
Date: Thu, 11 Dec 2014 16:54:43 +0000

I'm fine with these.

I think Payload Integrity and E2E Integrity should be book kept someplace other than Header Integrity and Immutability.

Will

From: <Templin>, Fred L <[email-masked]<mailto:[email-masked]>>
Date: Thursday, December 11, 2014 11:22 AM
To: Marc Blanchet <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [dtn] summary of work items

Hi Marc,

The Phase 1 items look good, however it might be useful to also identify which document
or documents (if any) will be affected for each work item. For example, my understanding
is that Header Integrity and Immutability would be addressed in RFC5050(bis). Would it be
useful to add a bullet such as: “Documents Affected” under each work item?

Thanks – Fred
[email-masked]<mailto:[email-masked]>

From: dtn [mailto:[email-masked]] On Behalf Of Marc Blanchet
Sent: Thursday, December 11, 2014 6:33 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [dtn] summary of work items

Hello,

Regards, Marc&Brian

=====================
DTN Work Items

Phase 1

     *   Considerations:

        *   payload integrity

        *   e2e integrity

        *   remove dictionary

  1.  Improved Security

     *   Considerations:

  1.  Addressing

     *   Considerations:

        *   narrow scope of work

     *   Considerations:

  1.  Static Routing

     *   Considerations:

  1.  Avoid Routing Loops

     *   Considerations:

        *   default operations

        *   simplify options

Phase 2

  1.  Network Management

     *   Considerations:

  1.  Key management

  1.  Multicast

  1.  Streaming Support

  1.  Bundle size

Non Work Items

  1.  Dynamic Routing

---

From: Marc Blanchet <[email-masked]>
Date: Thu, 11 Dec 2014 12:00:52 -0500

> Le 2014-12-11 à 11:22, Templin, Fred L <[email-masked]> a écrit :
> 
> Hi Marc,
>  

To me, yes, but not at this time. We first need to agree on the work items and have our AD/IESG blessing. Then, we would start digging into the document suite, etc…  But that is my take at the moment. 

Marc.

>  
> Thanks – Fred
> [email-masked] <mailto:[email-masked]>
>  
> From: dtn [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Marc Blanchet
> To: [email-masked] <mailto:[email-masked]>

---

From: "Burleigh, Scott C (312B)" <[email-masked]>
Date: Thu, 11 Dec 2014 18:00:16 +0000

Hi, Marc and Brian.  I agree this is a very good summary.  I will offer a couple of proposed tweaks, marked in <> brackets in-line below.

Scott

Hello,

Regards, Marc&Brian

=====================
DTN Work Items

Phase 1

  1.  Header Integrity and Immutability  <if "payload integrity" is included in this item then maybe the item title should be just "End-to-end Integrity" and item ii should be omitted?>

     *   Considerations:

        *   payload integrity

        *   e2e integrity

        *   remove dictionary
<I suggest that we add "bundle size" here, removing it from Phase 2.  I don't think bundle size is in fact an issue, but if it is an issue then it is fundamental and we need to address it at the beginning.  Will has linked it to the design of the integrity mechanisms, so I think this work item is the right place for it.>

  1.  Improved Security

     *   Considerations:

        *   Identify dependency on header changes driven by other work items  <maybe just "Identify dependency on header changes"?  Because the security improvements may themselves be the drivers for some of those changes.>

  1.  Addressing

     *   Considerations:

        *   develop requirements on addressing from use cases
<I suggest that we consider "constrained environments" here rather than in item 8.  So far in our conversations, I think constrained environments have had more impact on addressing than on any other topics.>

        *   narrow scope of work

     *   Considerations:

  1.  Static Routing

     *   Considerations:

  1.  Avoid Routing Loops

     *   Status: DTN WG work item
<suggested Considerations: assess applicability of draft-fall-dtnrg-schl-00>

     *   Status: DTN WG work item
<suggested Considerations: assess applicability of draft-irtf-dtnrg-bundle-age-block-01>

     *   Considerations:

        *   constrained environments  <as noted above, I suggest we relocate this topic>

        *   default operations

        *   simplify options

Phase 2

  1.  Network Management

     *   Considerations:

  1.  Key management

  1.  Multicast

  1.  Streaming Support

  1.  Bundle size  <as noted above, I suggest we relocate this topic>

Non Work Items

  1.  Dynamic Routing

---

From: "Sheehe, Charles J. (GRC-LCA0)" <[email-masked]>
Date: Thu, 11 Dec 2014 18:24:22 +0000

I  agree with your work plan.

My concerned with the security not being an afterthought.

Payload integrity and e2e integrity should be mindful of confidentiality / authentication and keys management.

Thanks
Chuck

Charles J. Sheehe III
Electronics Engineer
System Architectures and Networks Branch
21000 Brookpark Rd
Cleveland, OH 44135
[email-masked]
Office: 216-433-5179

-----Original Message-----
From: dtn [mailto:[email-masked]] On Behalf Of Burleigh, Scott C (312B)
Sent: Thursday, December 11, 2014 1:00 PM
To: Marc Blanchet; [email-masked]
Subject: Re: [dtn] summary of work items

Scott

Hello,

Regards, Marc&Brian

=====================

DTN Work Items

Phase 1

	*	Considerations:

		i.	payload integrity

		ii.	e2e integrity

		iii.	immutability of primary block

		iv.	remove dictionary

2.	Improved Security

	*	Considerations:

		0.	Determine if SBSP is starting point

		i.	Identify dependency on header changes driven by other work items  <maybe just "Identify dependency on header changes"?  Because the security improvements may themselves be the drivers for some of those changes.>

3.	Addressing

	*	Considerations: 

		0.	develop requirements on addressing from use cases

		i.	narrow scope of work

		ii.	Possible interim meeting

4.	Node/Neighbor Discovery

	*	Considerations:

		0.	Investigate MANET discovery protocol model

		i.	Assess applicability of draft-irtf-dtnrg-ipnd

5.	Static Routing

	*	Considerations:

		0.	Assess relationship to node/neighbor discovery

6.	Avoid Routing Loops

7.	Time and bundle expiration

8.	Improve Specifications such as RFC 5050

	*	Considerations:

		0.	fix known specification bugs

		i.	constrained environments  <as noted above, I suggest we relocate this topic>

		ii.	default operations

		iii.	simplify options

		iv.	identify issues for incompatibilities with 5050

9.	Registry of Service Identifier

Phase 2

1.	Network Management

	*	Considerations:

		i.	Potentially interface with LIME WG

		ii.	Move configuration to DTNRG?

2.	Key management

3.	Extended Class of Service

4.	Multicast

5.	Streaming Support

6.	Bundle size  <as noted above, I suggest we relocate this topic>

Non Work Items

1.	Dynamic Routing