Subject: Re: [dtn] DTN use cases

From: "Velt, R. (Ronald) in 't" <[email-masked]>
Date: Wed, 4 Mar 2015 17:25:53 +0000

Hi Fred, all,

The following use case also comprises what you might call "special-purpose" vehicles, but is not limited to vehicles. It was drafted on behalf of the consortium partners in the EDA (European Defence Agency) project MIDNET (MIlitary Disruption-tolerant NETworks).

Military Tactical, Terrestrial Networks 
-	Networks made up of vehicles, dismounted soldiers and soldiers operating on foot (i.e., without organic vehicles)
-	All nodes are mobile
-	Applications include Command and Control, Situational Awareness and others
-	Contacts between nodes are opportunistic
-	Transmission over (relatively) low capacity radio links
-	Disruptions caused by distance, terrain features (including urban), jamming

Needs
-	Prioritization of certain types of traffic over others, with respect to communication opportunities as well as storage use
-	Support for group communications
-	Improved Security
-	Security Key Management
-	Versatile naming/addressing based on URI-style EIDs
-	Opportunistic Routing
-	Neighbor Discovery
-	At least occasional connectivity to and interoperability with (semi-)static IP-based networks, in order to reach higher echelons and co-operation partners (including non-military)

Marc, Brian - we would like to see this use case added to the list if that is still possible. This one most certainly has industry backing.

Thanks,
Ronald in 't Velt

>-----Original Message-----
>From: dtn [mailto:[email-masked]] On Behalf Of Templin, Fred L
>Sent: vrijdag 27 februari 2015 19:35
>To: Gilbert Clark; [email-masked]
>Subject: Re: [dtn] DTN use cases
>
>Hi Gilbert,
>
>I consider my industry to be a stakeholder for special-purpose vehicular
>communications as indicated in my responses to Joerg. That said, I agree with
>you and Joerg that we should not list the general-purpose automotive use
>case since we do not have stakeholders from that industry; hence, my
>proposed rewording:
>
>OLD:
>---
>o Vehicles communicate with each other for road safety, traffic monitoring,
>navigation, etc.
>o Infreqenet transmission opportunities due to intermittent signals, sparse
>traffic conditions, terrain features etc.
>o Short contacts between vehicles passing
>---
>NEW:
>---
>o Vehicular communications in special-purpose applications, including public
>transportation,
>    commercial fleets, law enforcement, expeditionary forces, etc.
>o Vehicles communicate with each other for road safety, traffic monitoring,
>navigation, information sharing, etc.
>o Infrequent transmission opportunities due to intermittent signals, sparse
>traffic conditions, terrain features etc.
>o Short contacts between vehicles passing
>
>Does it work for you?
>
>Thanks - Fred
>[email-masked]
>
>PS Notice I substituted "special-purpose" for "limited-scale". Let me know if
>      that is not OK.
>
>> -----Original Message-----
>> From: dtn [mailto:[email-masked]] On Behalf Of Gilbert Clark
>> Sent: Friday, February 27, 2015 9:50 AM
>> To: [email-masked]
>> Subject: Re: [dtn] DTN use cases
>>
>>
>> >>> suggest that you look into mainstream vehicular communications.
>> >>
>> >> I don't think an exhaustive investigation of mainstream vehicular
>> >> communications is necessary in order to support this text going
>> >> forward - there are many other examples for vehicular comms as I
>> >> have noted.
>>
>> Why are we talking about *standardizing* a solution to a problem that
>> has not been completely explored by anyone represented in this group?
>>
>> Personally, I strongly believe that an exhaustive investigation into
>> vehicular communications would be a good idea *if* such is going to be
>> listed as a use case for this protocol.  The burden should be on *us*
>> ("us", in this case, being the individual stakeholder representing the
>> technology) to understand the applicability of a technology to a
>> problem
>> *before* it is included as a work item targeted by an engineering
>> standards body, I think.
>>
>> If there is no stakeholder present to champion a specific use case, I
>> would argue that it should not be listed (or even really considered)
>> at all.  We can worry about it if a stakeholder shows up.
>>
>> >>
>> >>> I don't mind doing this if we have the right industry expertise
>> >>> and backing.
>> >>
>> >> Also do not think we need to wait for major automotive industry
>> >> players to come on board - that might not happen for a long time.
>> >
>> > right.  So, you don't have a real use case because the people who
>> > would articulate it aren't there.  That's my point.
>> >
>>
>> I feel like the time it would take for major automotive industry
>> players (or any other industry players, for that matter) to come on
>> board is irrelevant.  We're working through this protocol *now*.  As
>> such, only those who are here *now* will get to influence the result.
>> We shouldn't be waiting for *anyone* in particular to join or leave
>> the project, regardless of how useful we believe DTN would (or
>> wouldn't) be to the industry or interest they happen to represent.
>>
>> For what it's worth,
>> Gilbert Clark
>>
>> _______________________________________________
>> dtn mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/dtn
>
>_______________________________________________
>dtn mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/dtn
This message may contain information that is not intended for you. If you are not the addressee or if this message was sent to you by mistake, you are requested to inform the sender and delete the message. TNO accepts no liability for the content of this e-mail, for the manner in which you use it and for damage of any kind resulting from the risks inherent to the electronic transmission of messages.

---

From: "Sheehe, Charles J. (GRC-LCA0)" <[email-masked]>
Date: Wed, 4 Mar 2015 17:31:09 +0000

Need: must maintain priority as the traffic traverses networks.

Chuck 

Charles J. Sheehe III
Electronics Engineer
System Architectures and Networks Branch
21000 Brookpark Rd
Cleveland, OH 44135
[email-masked]
Office: 216-433-5179

-----Original Message-----
From: dtn [mailto:[email-masked]] On Behalf Of Velt, R. (Ronald) in 't
Sent: Wednesday, March 04, 2015 12:26 PM
To: Templin, Fred L; Gilbert Clark; [email-masked]
Subject: Re: [dtn] DTN use cases

Hi Fred, all,

Needs

Thanks,
Ronald in 't Velt

>I consider my industry to be a stakeholder for special-purpose 
>vehicular communications as indicated in my responses to Joerg. That 
>said, I agree with you and Joerg that we should not list the 
>general-purpose automotive use case since we do not have stakeholders 
>from that industry; hence, my proposed rewording:
>
>OLD:
>---
>o Vehicles communicate with each other for road safety, traffic 
>monitoring, navigation, etc.
>o Infreqenet transmission opportunities due to intermittent signals, 
>sparse traffic conditions, terrain features etc.
>o Vehicular communications in special-purpose applications, including 
>public transportation,
>o Vehicles communicate with each other for road safety, traffic 
>monitoring, navigation, information sharing, etc.
>o Infrequent transmission opportunities due to intermittent signals, 
>sparse traffic conditions, terrain features etc.
>> vehicular communications would be a good idea *if* such is going to 
>> be listed as a use case for this protocol.  The burden should be on 
>> *us* ("us", in this case, being the individual stakeholder 
>> representing the

---

From: Brian Haberman <[email-masked]>
Date: Wed, 04 Mar 2015 12:44:08 -0500

WG,
     Does anyone have an objection to adding this use case?

Regards,
Brian

---

From: "Templin, Fred L" <[email-masked]>
Date: Wed, 4 Mar 2015 18:38:58 +0000

No objection.

> From: dtn [mailto:[email-masked]] On Behalf Of Brian Haberman
> Sent: Wednesday, March 04, 2015 9:44 AM
> To: [email-masked]
> > The following use case also comprises what you might call "special-purpose" vehicles, but is not limited to vehicles. It was drafted on
> behalf of the consortium partners in the EDA (European Defence Agency) project MIDNET (MIlitary Disruption-tolerant NETworks).
> >
> > -	At least occasional connectivity to and interoperability with (semi-)static IP-based networks, in order to reach higher echelons
> and co-operation partners (including non-military)
> >
> > This message may contain information that is not intended for you. If you are not the addressee or if this message was sent to you
> by mistake, you are requested to inform the sender and delete the message. TNO accepts no liability for the content of this e-mail, for
> the manner in which you use it and for damage of any kind resulting from the risks inherent to the electronic transmission of
> messages.
> >