Subject: [dtn] UAV / DTN use case

From: "Templin, Fred L" <[email-masked]>
Date: Tue, 10 Mar 2015 21:40:34 +0000

Hi Will,

Regarding the UAV / DTN use case and legislation, I'd like to test out an
analogy with you. Most communities have leash laws for dogs that carry
a fine for violation. Isn't that basically the same as what the UAV comms
legislation is saying, i.e., that the UAV has to stay on a "leash" (i.e., a line
of sight link)?

Regardless of the laws, dogs are constantly getting off-leash where they
might bite someone or poop on someone's lawn. And, the same will be
true for UAVs, as some will invariable find a way to get off leash. But, what
happens when a UAV's leash breaks - does it just crash into the Whitehouse
lawn - or worse?

With DTN, we might be able to build a better leash - one that stretches in
an elastic fashion rather than snapping and letting the UAV run amok.
IMHO, that would not violate the law, but would rather stand a better
chance of ensuring the laws are not broken. What do you think?

Thanks - Fred
[email-masked]

---

From: "Ivancic, William D. (GRC-LCA0)" <[email-masked]>
Date: Wed, 11 Mar 2015 17:02:55 +0000

>legislation is saying, i.e., that the UAV has to stay on a "leash" (i.e.,

No

>happens when a UAV's leash breaks - does it just crash into the Whitehouse

There are many classes of UAVs and many classes of Airspace from the
little remote control units to a Global Hawk or eventually a large cargo
plane.

In the next 10 - 15 years define for me the realistic use cases:

Develop a Concept of Operations for each of these UAV classes and identify
the communication capabilities.  Are the links secure at the below the DTN
layer?  How does one get DTN to communicate?  How many radios do you think
a UAV will have?  $$$ and mass.

>chance of ensuring the laws are not broken. What do you think?

Perhaps 15+ years from now  Governments will permit autonomous UAV
operations.  But then, I don't need DTN because I am operating
autonomously.  I may need something like ADS-B to get situational
awareness, but that is publish/subscribe, not DTN.

For those who care to know ADS-B.
http://en.wikipedia.org/wiki/Automatic_dependent_surveillance_%E2%80%93_bro
adcast
Current ADS-B and has know vulnerabilities.  There are mechanisms to
minimize those, but only for small numbers of large aircraft (10s of
1000s).

Will

---

From: "Burleigh, Scott C (312B)" <[email-masked]>
Date: Wed, 11 Mar 2015 17:26:51 +0000

Will, it sounds to me like you're working pretty hard to miss Fred's point.  He's not saying that UAVs will be operated autonomously any time soon.  He's saying (I think) that it's an imperfect world, which is why we wear seat belts.

UAVs will be driven by operators that are in continuous radio contact with them.  However, on rare occasions it will still be possible for R/F contact between the UAV and the operator to lapse for a short time.  That is in the nature of R/F.

This will of course be very bad; the UAV will have to go into some sort of safe mode while waiting for contact to be re-established.  But it may still be generating valuable information during that time, possibly including telemetry that would account for the communication lapse.  If this information is issued via TCP/IP then it is lost because there is no link to send it on; if it is issued via DTN then it is retained for transmission when R/F contact resumes.

Scott

-----Original Message-----
From: dtn [mailto:[email-masked]] On Behalf Of Ivancic, William D. (GRC-LCA0)
Sent: Wednesday, March 11, 2015 10:03 AM
To: Templin, Fred L
Cc: [email-masked]
Subject: Re: [dtn] UAV / DTN use case

On 3/10/15 5:40 PM, "Templin, Fred L" <[email-masked]> wrote:

>Hi Will,
>
>Regarding the UAV / DTN use case and legislation, I'd like to test out 
>an analogy with you. Most communities have leash laws for dogs that 
>carry a fine for violation. Isn't that basically the same as what the 
>UAV comms legislation is saying, i.e., that the UAV has to stay on a 
>"leash" (i.e., a line of sight link)?

No

>
>Regardless of the laws, dogs are constantly getting off-leash where 
>they might bite someone or poop on someone's lawn. And, the same will 
>be true for UAVs, as some will invariable find a way to get off leash. 
>But, what happens when a UAV's leash breaks - does it just crash into 
>the Whitehouse lawn - or worse?

There are many classes of UAVs and many classes of Airspace from the little remote control units to a Global Hawk or eventually a large cargo plane.

Develop a Concept of Operations for each of these UAV classes and identify the communication capabilities.  Are the links secure at the below the DTN layer?  How does one get DTN to communicate?  How many radios do you think a UAV will have?  $$$ and mass.

>
>With DTN, we might be able to build a better leash - one that stretches 
>in an elastic fashion rather than snapping and letting the UAV run amok.

Perhaps 15+ years from now  Governments will permit autonomous UAV operations.  But then, I don't need DTN because I am operating autonomously.  I may need something like ADS-B to get situational awareness, but that is publish/subscribe, not DTN.

For those who care to know ADS-B.
http://en.wikipedia.org/wiki/Automatic_dependent_surveillance_%E2%80%93_bro
adcast
Current ADS-B and has know vulnerabilities.  There are mechanisms to minimize those, but only for small numbers of large aircraft (10s of 1000s).

Will

_______________________________________________
dtn mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dtn

---

From: "Templin, Fred L" <[email-masked]>
Date: Wed, 11 Mar 2015 17:42:43 +0000

Hi Will,

> From: Ivancic, William D. (GRC-LCA0) [mailto:[email-masked]]
> Subject: Re: UAV / DTN use case
> 
> 
> 

That is hard for me to understand. Based on what you have said before, it
sounds like laws will require users to keep their UAVS on a (comms) leash.

> little remote control units to a Global Hawk or eventually a large cargo

Sure. All different sorts and sizes. And, we have seen how even the
tiny ones can cause major disturbances when they get off leash.

> layer?

Link-layer encryption is something that should be taken care of by the
lnik if possible, yes. Or, the network can apply network layer encryption.
Or both.

> How does one get DTN to communicate?

The same as for in a high-fidelity Live, Virtual and Constructive emulation
with hardware in the loop.

> How many radios do you think a UAV will have?  $$$ and mass.

Numbers of radio links and SWAP are really orthogonal to the discussion.

> autonomously.

I am not talking about autonomy at this point, though I believe the
ability to operate autonomously could benefit safety of flight.

> I may need something like ADS-B to get situational

ADS-B security is indeed a matter for concern, and has been for well over
a decade:

http://www.airsport-corp.com/adsb2.htm

It's just that the FAA has only recently begun to listen.

Thanks - Fred

---

From: "Juan A. Fraire" <[email-masked]>
Date: Thu, 12 Mar 2015 10:05:53 -0300

All,

I'm not an expert on UAVs whatsoever, yet I'm trying to follow the
discussion and keep asking myself the following.

On the one hand, I can understand there might be some problems on agreeing
whether DTN can improve (or not) the UAV *control* communication link.
¿Does the automatic data recovery of a broken control leash justify the
effort and risk of adopting DTN? I suppose it is tough to generalize a
single answer for all UAV missions here.

On the other hand, the *payload data* requires a higher throughput
(probably implying a shorter range) downlink but not necessarily a
permanent end-to-end path. Therefore, doesn't DTN have a better chance in
automating payload data retrieval through different downlink stations or
even other UAVs than improving the control loop?

Regards,

J.Fraire

On Wed, Mar 11, 2015 at 2:42 PM, Templin, Fred L <[email-masked]>
wrote:

> an
> > >legislation is saying, i.e., that the UAV has to stay on a "leash"
> (i.e.,
> > >a line
> > >of sight link)?
> >
> > No
>
> in

---

From: "Templin, Fred L" <[email-masked]>
Date: Thu, 12 Mar 2015 17:39:06 +0000

Hi Juan,

You are right that UAV comms typically entail both Command and Control (C2)
and telemetry data. Often (but not always) these will be conveyed over the same
link or links.  There are two areas of concern. First, maintaining C2 over intermittent
links is the domain of LTP, Saratoga, etc. Second, buffering both telemetry and C2
data during temporary link disruptions is the domain of the Bundle Protocol. So, I
still see it as applicable for both C2 and telemetry.

Thanks – Fred
[email-masked]<mailto:[email-masked]>

From: Juan A. Fraire [mailto:[email-masked]]
Sent: Thursday, March 12, 2015 6:06 AM
To: Templin, Fred L
Cc: Ivancic, William D. (GRC-LCA0); [email-masked]
Subject: Re: [dtn] UAV / DTN use case

All,

I'm not an expert on UAVs whatsoever, yet I'm trying to follow the discussion and keep asking myself the following.

On the one hand, I can understand there might be some problems on agreeing whether DTN can improve (or not) the UAV control communication link. ¿Does the automatic data recovery of a broken control leash justify the effort and risk of adopting DTN? I suppose it is tough to generalize a single answer for all UAV missions here.

On the other hand, the payload data requires a higher throughput (probably implying a shorter range) downlink but not necessarily a permanent end-to-end path. Therefore, doesn't DTN have a better chance in automating payload data retrieval through different downlink stations or even other UAVs than improving the control loop?

Regards,

J.Fraire

On Wed, Mar 11, 2015 at 2:42 PM, Templin, Fred L <[email-masked]<mailto:[email-masked]>> wrote:
Hi Will,

> From: Ivancic, William D. (GRC-LCA0) [mailto:[email-masked]<mailto:[email-masked]>]
> Cc: [email-masked]<mailto:[email-masked]>
> On 3/10/15 5:40 PM, "Templin, Fred L" <[email-masked]<mailto:[email-masked]>> wrote:
>
> >Hi Will,
> >

Thanks - Fred
[email-masked]<mailto:[email-masked]>

_______________________________________________
dtn mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dtn