Subject: [dtn] I-D Action: draft-ietf-dtn-bpbis-01.txt

From: [email-masked]
Date: Wed, 25 Nov 2015 09:43:02 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Delay/Disruption Tolerant Networking Working Group of the IETF.

        Title           : Bundle Protocol
        Authors         : Scott Burleigh
                          Kevin Fall
                          Edward J. Birrane
	Filename        : draft-ietf-dtn-bpbis-01.txt
	Pages           : 47
	Date            : 2015-11-25

Abstract:
   This Internet Draft presents a specification for Bundle Protocol,
   adapted from the experimental Bundle Protocol specification
   developed by the Delay-Tolerant Networking Research group of the
   Internet Research Task Force and documented in RFC 5050.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dtn-bpbis/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-dtn-bpbis-01

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dtn-bpbis-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Burleigh, Scott C (312B)" <[email-masked]>
Date: Wed, 25 Nov 2015 18:23:50 +0000

Hi.  This new draft incorporates all the tentative resolutions to open technical issues that we reached in the DTNWG meeting in Yokohama earlier this month, as I remember them.  Briefly:
-	Notes on possible implementations are removed, shortening the document somewhat.  (Consequently the document isn't split into two documents.)
-	The "Block was forwarded without being processed" flag is removed, since we weren't sure what would be done with it anyway.
-	All QoS markings, including the 2-bit CoS class from RFC 5050, are removed.  We plan to develop an extension block that will provide bundle QoS markings.
-	Status reports will *optionally* include the times at which the bundle entered the indicated states.  (Those times are just at 1-second granularity, as it turns out that DTNperf doesn't need nanosecond granularity after all.)
-	Language is clarified: the BPA controls the time at which a bundle is presented to the CLA, and the CLA controls the time at which the bundle is actually radiated.
-	It is now noted that the BPA itself may function as a CLA, i.e., an entire bundle may form the payload of an encapsulating bundle for some purposes.
-	The "inventory" feature is removed for now, since we don't know what the real requirements are.  This is something to discuss at the virtual meeting in January.

Scott

-----Original Message-----
From: dtn [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, November 25, 2015 9:43 AM
To: [email-masked]
Cc: [email-masked]
Subject: [dtn] I-D Action: draft-ietf-dtn-bpbis-01.txt

        Title           : Bundle Protocol
        Authors         : Scott Burleigh
                          Kevin Fall
                          Edward J. Birrane

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
dtn mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dtn