Subject: [dtn] I-D Action: draft-ietf-dtn-bpbis-02.txt

From: [email-masked]
Date: Mon, 11 Jan 2016 15:07:13 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Delay/Disruption Tolerant Networking Working Group of the IETF.

        Title           : Bundle Protocol
        Authors         : Scott Burleigh
                          Kevin Fall
                          Edward J. Birrane
	Filename        : draft-ietf-dtn-bpbis-02.txt
	Pages           : 43
	Date            : 2016-01-11

Abstract:
   This Internet Draft presents a specification for Bundle Protocol,
   adapted from the experimental Bundle Protocol specification
   developed by the Delay-Tolerant Networking Research group of the
   Internet Research Task Force and documented in RFC 5050.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dtn-bpbis/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-dtn-bpbis-02

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dtn-bpbis-02

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Burleigh, Scott C (312B)" <[email-masked]>
Date: Mon, 11 Jan 2016 23:11:45 +0000

My apologies, everybody.  When I posted the revised BP spec in November, I somehow managed to post the text of that Word file *without* the changes I had made.  I only noticed my mistake this morning.  The correct text has now been posted as version 02 of this document.

Scott

-----Original Message-----
From: dtn [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, January 11, 2016 3:07 PM
To: [email-masked]
Cc: [email-masked]
Subject: [dtn] I-D Action: draft-ietf-dtn-bpbis-02.txt

        Title           : Bundle Protocol
        Authors         : Scott Burleigh
                          Kevin Fall
                          Edward J. Birrane

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
dtn mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dtn

---

From: Carlo Caini <[email-masked]>
Date: Wed, 20 Jan 2016 13:37:48 +0100

Dear Scott,
     I have given a first glance at the 02 version of the bpbis draft 
and I have two minor comments:
1) The first is very trivial, there is a typo in the expiring date in 
both 01 and 02 (2015 instead of 2016).
2) The second is more significant, concerning priorities. If I am not 
wrong, in 02 any reference to priorities has been dropped. I suppose 
that they should be mentioned somewhere, just to say that now they 
are treated in a different way with respect to RFC5050 and maybe in 
another document. As this is undoubtedly a major difference with 
respect to RFC5050, a bullet should be added the corresponding list.

By the way, dealing with priorities, wherever BP priority will be 
treated, I would like to extend the liberty of intermediate nodes in 
dealing with them. In my opinion priorities, as they are set by 
sources at no cost and cannot be modified by intermediate nodes, 
should be considered just as non compulsory indications given by the 
source to other nodes. In RFC5050 priority scope has already been 
limited to bundles coming from the same source, which allows 
intermediate nodes to send low priority bundles of "important" 
sources before high priority bundles of "trivial" sources. I would go 
further and I would explicitly say that priorities are just non 
compulsory indications provided by the source, stop. This because 
intermediate nodes could consider a set of parameters to decide the 
order of forwarding, including source address, destination address 
and metadata, as well as priorities. This would make sense whenever 
the situation awareness of a central node, which controls also at 
least some intermediate nodes, is higher than the source (i.e. the 
fire brigade HQ vs. the single fireman).
Yours,
     Carlo

---

From: "Burleigh, Scott C (312B)" <[email-masked]>
Date: Wed, 20 Jan 2016 17:03:07 +0000

Hi, Carlo.  On point 1, good catch, of course we will fix this.  On point 2: at the Yokohama meeting we reached consensus that both the ECOS features and the original COS flags (used to indicate priority) in RFC 5050 ought to be removed from the base Bundle Protocol specification and an integrated QoS mechanism should be defined in more detail in a new extension block specification.  Quoting from the Minutes:

'Proposal is that ECOS is valuable but does not need to be in the primary block. Remove the current COS 2-bit fields in the primary block. Remove the ECOS block (it is not "extending" anything anymore). Create a COS extension block to capture this information.  <general consensus this was the right thing to do>'

So I would propose that we start a new mailing list thread on this topic, starting off with the concerns you voice here, and try to generate a new BP QoS Internet Draft out of that conversation over the next few months.  Maybe aim to present it in Berlin in July?

Scott

-----Original Message-----
From: Carlo Caini [mailto:[email-masked]] 
Sent: Wednesday, January 20, 2016 4:38 AM
To: Burleigh, Scott C (312B) <[email-masked]>
Cc: [email-masked]
Subject: Re: [dtn] I-D Action: draft-ietf-dtn-bpbis-02.txt

Dear Scott,
     I have given a first glance at the 02 version of the bpbis draft and I have two minor comments:
1) The first is very trivial, there is a typo in the expiring date in both 01 and 02 (2015 instead of 2016).
2) The second is more significant, concerning priorities. If I am not wrong, in 02 any reference to priorities has been dropped. I suppose that they should be mentioned somewhere, just to say that now they are treated in a different way with respect to RFC5050 and maybe in another document. As this is undoubtedly a major difference with respect to RFC5050, a bullet should be added the corresponding list.

By the way, dealing with priorities, wherever BP priority will be treated, I would like to extend the liberty of intermediate nodes in dealing with them. In my opinion priorities, as they are set by sources at no cost and cannot be modified by intermediate nodes, should be considered just as non compulsory indications given by the source to other nodes. In RFC5050 priority scope has already been limited to bundles coming from the same source, which allows intermediate nodes to send low priority bundles of "important" 
sources before high priority bundles of "trivial" sources. I would go further and I would explicitly say that priorities are just non compulsory indications provided by the source, stop. This because intermediate nodes could consider a set of parameters to decide the order of forwarding, including source address, destination address and metadata, as well as priorities. This would make sense whenever the situation awareness of a central node, which controls also at least some intermediate nodes, is higher than the source (i.e. the fire brigade HQ vs. the single fireman).
Yours,
     Carlo

At 00:07 12/01/2016, [email-masked] wrote:

>Please note that it may take a couple of minutes from the time of 
>submission until the htmlized version and diff are available at tools.ietf.org.
>

---

From: Carlo Caini <[email-masked]>
Date: Wed, 20 Jan 2016 19:46:04 +0000

Dear Scott,
       I knew that old priorities and ECOS had to be merged in a different block, but I missed the fact that that they had to be specified outside the bpbis. I will be happy to present my thoughts on priorities in more details in the new thread, if useful to clarify the concept. I also hope to be present in Berlin, but I am not sure.
Yours,
   Carlo

________________________________________
Da: Burleigh, Scott C (312B) [[email-masked]]
Inviato: mercoledì 20 gennaio 2016 18.03
A: Carlo Caini
Cc: [email-masked]
Oggetto: RE: [dtn] I-D Action: draft-ietf-dtn-bpbis-02.txt

Scott

-----Original Message-----
From: Carlo Caini [mailto:[email-masked]]
Sent: Wednesday, January 20, 2016 4:38 AM
To: Burleigh, Scott C (312B) <[email-masked]>
Cc: [email-masked]
Subject: Re: [dtn] I-D Action: draft-ietf-dtn-bpbis-02.txt

Dear Scott,