Subject: [dtn] Request for reviews of LTP-over-PPP draft

From: Brian Sipos <[email-masked]>
Date: Thu, 14 Jan 2016 14:13:51 +0000

All,

I have written up a very simple specification for providing a Licklider Transmission Protocol (LTP) segment transport using Point-to-Point Protocol (PPP) as a data-link/convergence layer. This provides an alternative to LTP-over-UDP for applications where the overhead of UDP/IP is excessive for a genuine point-to-point link, and allows LTP/PPP to be combined with existing infrastructure of PPP/RS-422, PPP/Ethernet, etc. data links.

The draft is at https://datatracker.ietf.org/doc/draft-bsipos-dtn-ppp-ltp-clayer/

This spec is relatively simple, and effectively allocates a PPP protocol number for this purpose. Any comments or questions are greatly appreciated.

Thanks,

Brian S.

---

From: "Burleigh, Scott C (312B)" <[email-masked]>
Date: Sat, 16 Jan 2016 00:48:45 +0000

Thanks, Brian.  I'm not knowledgeable about PPP, but this specification looks very useful to me.  One small point: for consistency, it might be helpful to identify the location of PPP under LTP as the "local data-link layer" (as the term is used in RFC 5326).

Scott

From: dtn [mailto:[email-masked]] On Behalf Of Brian Sipos
Sent: Thursday, January 14, 2016 6:14 AM
To: [email-masked]
Subject: [dtn] Request for reviews of LTP-over-PPP draft

All,

Thanks,

Brian S.